Autofac Namespace

Autofac .NET Inversion of Control Container
Autofac Namespace
Namespaces ► Autofac
Core container interfaces and implementation.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac
Namespace Autofac
namespace Autofac
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | ActivatedEventArgs | Fired when the activation process for a new instance is complete.
 | ActivatingEventArgs | Fired during the activation process to allow instances to be proxied or swapped.
 | ComponentNotRegisteredException | A service was requested that cannot be provided by the container.
 | ComponentRegisteredEventArgs | Information about the ocurrence of a component being registered with a container.
 | ConstantParameter | Base class for parameters that provide a constant value.
 | Container | Standard container implementation.
 | DependencyResolutionException | Problem resolving dependencies, e.g. circular references, no callable constructor etc.
 | Disposable | Base class for disposable objects.
 | IComponentDescriptor | Captures the elements of a component registration that are shared between all contexts in which the component can be used.
 | IComponentRegistration | A component registration is used by the container to create and manage the services it holds.
 | IContainer | Provides the full Autofac container functionality.
 | IContext | The context in which a service can be accessed or a component's dependencies resolved. Disposal of a context will dispose any owned components.
 | IDisposer | Provided on an object that will dispose of other objects when it is itself disposed.
 | IModule | Represents a set of components and related functionality packaged together.
 | InstanceOwnership | Determines when instances supporting IDisposable are disposed.
 | InstanceScope | Determines when instances are created and how they are shared.
 | IRegistrationSource | Allows registrations to be made on-the-fly when unregistered services are requested (lazy registrations.)
 | NamedParameter | A parameter identified according to its name within an argument list declaration.
 | NamedPropertyParameter | Injects into properties according to their name. Needs to be reviewed - not sure if it makes sense to have properties and parameters related this way.
 | NamedService | Identifies a service using a textual name.
 | Parameter | Used in order to provide a value to a constructor parameter or property on an instance being created by the container.
 | ParameterExtensions | Extension methods that ease the extraction of particluar kinds of parameter values from an enumerable sequence of the Parameter abstract type. Each method returns the first matching parameter value, or throws an exception if none is provided.
 | PositionalParameter | A parameter that is identified according to an integer representing its position in an argument list.
 | PreparingEventArgs | Fired before the activation process to allow parameters to be changed or an alternative instance to be provided.
 | Service | Services are the lookup keys used to locate component instances.
 | TypedParameter | A parameter that can supply values to sites that exactly match a specified type.
 | TypedService | Identifies a service according to a type to which it can be assigned.
 | UniqueService | A handy unique service identifier type - all instances will be regarded as unequal.

Send comments on this topic to autofac@googlegroups.com

Copyright (c) 2007-2008 Autofac Contributors


ActivatedEventArgs Class

ActivatedEventArgs Class
Namespaces ► Autofac ► ActivatedEventArgs
Fired when the activation process for a new instance is complete.
Declaration Syntax
C# Visual Basic Visual C++
public class ActivatedEventArgs : EventArgs
Public Class ActivatedEventArgs _
    Inherits EventArgs
public ref class ActivatedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActivatedEventArgs(IContext, IComponentRegistration, Object) | Initializes a new instance of the ActivatedEventArgs class.
 | Component | The component providing the instance.
 | Context | The context in which the activation occurred.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | The instance that will be used to satisfy the request.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ActivatedEventArgs

Send comments on this topic to autofac@googlegroups.com

Copyright (c) 2007-2008 Autofac Contributors

Assembly: Autofac (Module: Autofac) Version: 1.4.2.530 (1.4.2.530)


ActivatedEventArgs Constructor (context, component, instance)

ActivatedEventArgs Constructor (context, component, instance)
Namespaces ► Autofac ► ActivatedEventArgs ► ActivatedEventArgs(IContext, IComponentRegistration, Object)
Initializes a new instance of the ActivatedEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public ActivatedEventArgs(
    IContext context,
    IComponentRegistration component,
    Object instance
)
Public Sub New ( _
    context As IContext, _
    component As IComponentRegistration, _
    instance As Object _
)
public:
ActivatedEventArgs(
    IContext^ context,
    IComponentRegistration^ component,
    Object^ instance
)
Parameters
context (IContext)
The context.
component (IComponentRegistration)
The component.
instance (Object)
The instance.


Component Property

Component Property
Namespaces ► Autofac ► ActivatedEventArgs ► Component
The component providing the instance.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentRegistration Component { get; private set; }
Public Property Component As IComponentRegistration
public:
property IComponentRegistration^ Component {
    IComponentRegistration^ get ();
    void set (IComponentRegistration^ value);
}


Context Property

Context Property
Namespaces ► Autofac ► ActivatedEventArgs ► Context
The context in which the activation occurred.
Declaration Syntax
C# Visual Basic Visual C++
public IContext Context { get; private set; }
Public Property Context As IContext
public:
property IContext^ Context {
    IContext^ get ();
    void set (IContext^ value);
}


Instance Property

Instance Property
Namespaces ► Autofac ► ActivatedEventArgs ► Instance
The instance that will be used to satisfy the request.
Declaration Syntax
C# Visual Basic Visual C++
public Object Instance { get; private set; }
Public Property Instance As Object
public:
property Object^ Instance {
    Object^ get ();
    void set (Object^ value);
}


ActivatingEventArgs Class

ActivatingEventArgs Class
Namespaces ► Autofac ► ActivatingEventArgs
Fired during the activation process to allow instances to be proxied or swapped.
Declaration Syntax
C# Visual Basic Visual C++
public class ActivatingEventArgs : EventArgs
Public Class ActivatingEventArgs _
    Inherits EventArgs
public ref class ActivatingEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActivatingEventArgs(IContext, IComponentRegistration, Object) | Initializes a new instance of the ActivatingEventArgs class.
 | Component | The component providing the instance being activated.
 | Context | The context in which the activation is occurring.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | The instance that will be used to satisfy the request (may be substituted.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ActivatingEventArgs


ActivatingEventArgs Constructor (context, component, instance)

ActivatingEventArgs Constructor (context, component, instance)
Namespaces ► Autofac ► ActivatingEventArgs ► ActivatingEventArgs(IContext, IComponentRegistration, Object)
Initializes a new instance of the ActivatingEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public ActivatingEventArgs(
    IContext context,
    IComponentRegistration component,
    Object instance
)
Public Sub New ( _
    context As IContext, _
    component As IComponentRegistration, _
    instance As Object _
)
public:
ActivatingEventArgs(
    IContext^ context,
    IComponentRegistration^ component,
    Object^ instance
)
Parameters
context (IContext)
The context.
component (IComponentRegistration)
The component.
instance (Object)
The instance.


Component Property

Component Property
Namespaces ► Autofac ► ActivatingEventArgs ► Component
The component providing the instance being activated.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentRegistration Component { get; private set; }
Public Property Component As IComponentRegistration
public:
property IComponentRegistration^ Component {
    IComponentRegistration^ get ();
    void set (IComponentRegistration^ value);
}


Context Property

Context Property
Namespaces ► Autofac ► ActivatingEventArgs ► Context
The context in which the activation is occurring.
Declaration Syntax
C# Visual Basic Visual C++
public IContext Context { get; private set; }
Public Property Context As IContext
public:
property IContext^ Context {
    IContext^ get ();
    void set (IContext^ value);
}


Instance Property

Instance Property
Namespaces ► Autofac ► ActivatingEventArgs ► Instance
The instance that will be used to satisfy the request (may be substituted.)
Declaration Syntax
C# Visual Basic Visual C++
public Object Instance { get; set; }
Public Property Instance As Object
public:
property Object^ Instance {
    Object^ get ();
    void set (Object^ value);
}


ComponentNotRegisteredException Class

ComponentNotRegisteredException Class
Namespaces ► Autofac ► ComponentNotRegisteredException
A service was requested that cannot be provided by the container.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ComponentNotRegisteredException : Exception
<SerializableAttribute> _
Public Class ComponentNotRegisteredException _
    Inherits Exception
[SerializableAttribute]
public ref class ComponentNotRegisteredException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentNotRegisteredException()()() | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(Service) | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(Service, Exception) | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(SerializationInfo, StreamingContext) | Initializes a new instance of the ComponentNotRegisteredException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ComponentNotRegisteredException


ComponentNotRegisteredException Constructor

ComponentNotRegisteredException Constructor
Namespaces ► Autofac ► ComponentNotRegisteredException ► ComponentNotRegisteredException()()()
Members
Icon | Member | Description
 | ComponentNotRegisteredException()()() | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(Service) | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(Service, Exception) | Initializes a new instance of the ComponentNotRegisteredException class.
 | ComponentNotRegisteredException(SerializationInfo, StreamingContext) | Initializes a new instance of the ComponentNotRegisteredException class.


ComponentNotRegisteredException Constructor

ComponentNotRegisteredException Constructor
Namespaces ► Autofac ► ComponentNotRegisteredException ► ComponentNotRegisteredException()()()
Initializes a new instance of the ComponentNotRegisteredException class.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentNotRegisteredException()
Public Sub New
public:
ComponentNotRegisteredException()


ComponentNotRegisteredException Constructor (service)

ComponentNotRegisteredException Constructor (service)
Namespaces ► Autofac ► ComponentNotRegisteredException ► ComponentNotRegisteredException(Service)
Initializes a new instance of the ComponentNotRegisteredException class.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentNotRegisteredException(
    Service service
)
Public Sub New ( _
    service As Service _
)
public:
ComponentNotRegisteredException(
    Service^ service
)
Parameters
service (Service)
The service.


ComponentNotRegisteredException Constructor (service, innerException)

ComponentNotRegisteredException Constructor (service, innerException)
Namespaces ► Autofac ► ComponentNotRegisteredException ► ComponentNotRegisteredException(Service, Exception)
Initializes a new instance of the ComponentNotRegisteredException class.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentNotRegisteredException(
    Service service,
    Exception innerException
)
Public Sub New ( _
    service As Service, _
    innerException As Exception _
)
public:
ComponentNotRegisteredException(
    Service^ service,
    Exception^ innerException
)
Parameters
service (Service)
The service.
innerException (Exception)
The inner exception.


ComponentNotRegisteredException Constructor (info, context)

ComponentNotRegisteredException Constructor (info, context)
Namespaces ► Autofac ► ComponentNotRegisteredException ► ComponentNotRegisteredException(SerializationInfo, StreamingContext)
Initializes a new instance of the ComponentNotRegisteredException class.
Declaration Syntax
C# Visual Basic Visual C++
protected ComponentNotRegisteredException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ComponentNotRegisteredException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).


ComponentRegisteredEventArgs Class

ComponentRegisteredEventArgs Class
Namespaces ► Autofac ► ComponentRegisteredEventArgs
Information about the ocurrence of a component being registered with a container.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentRegisteredEventArgs : EventArgs
Public Class ComponentRegisteredEventArgs _
    Inherits EventArgs
public ref class ComponentRegisteredEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentRegisteredEventArgs(IContainer, IComponentRegistration) | Create a new instance with a valid container and component registration.
 | ComponentRegistration | The component registration.
 | Container | The container into which the registration was made.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ComponentRegisteredEventArgs


ComponentRegisteredEventArgs Constructor (container, componentRegistration)

ComponentRegisteredEventArgs Constructor (container, componentRegistration)
Namespaces ► Autofac ► ComponentRegisteredEventArgs ► ComponentRegisteredEventArgs(IContainer, IComponentRegistration)
Create a new instance with a valid container and component registration.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentRegisteredEventArgs(
    IContainer container,
    IComponentRegistration componentRegistration
)
Public Sub New ( _
    container As IContainer, _
    componentRegistration As IComponentRegistration _
)
public:
ComponentRegisteredEventArgs(
    IContainer^ container,
    IComponentRegistration^ componentRegistration
)
Parameters
container (IContainer)
The container into which the registration was made.
componentRegistration (IComponentRegistration)
The component registration.


ComponentRegistration Property

ComponentRegistration Property
Namespaces ► Autofac ► ComponentRegisteredEventArgs ► ComponentRegistration
The component registration.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentRegistration ComponentRegistration { get; private set; }
Public Property ComponentRegistration As IComponentRegistration
public:
property IComponentRegistration^ ComponentRegistration {
    IComponentRegistration^ get ();
    void set (IComponentRegistration^ value);
}


Container Property

Container Property
Namespaces ► Autofac ► ComponentRegisteredEventArgs ► Container
The container into which the registration was made.
Declaration Syntax
C# Visual Basic Visual C++
public IContainer Container { get; private set; }
Public Property Container As IContainer
public:
property IContainer^ Container {
    IContainer^ get ();
    void set (IContainer^ value);
}


ConstantParameter Class

ConstantParameter Class
Namespaces ► Autofac ► ConstantParameter
Base class for parameters that provide a constant value.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ConstantParameter : Parameter
Public MustInherit Class ConstantParameter _
    Inherits Parameter
public ref class ConstantParameter abstract : public Parameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConstantParameter(Object, Predicate<(Of <(ParameterInfo>)>)) | Create a constant parameter that will apply to parameters matching the supplied predicate.
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site. (Overrides Parameter.CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion. (Inherited from Parameter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | The value of the parameter.
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter
 |  |  | NamedParameter
 |  |  | NamedPropertyParameter
 |  |  | PositionalParameter
 |  |  | TypedParameter


ConstantParameter Constructor (value, predicate)

ConstantParameter Constructor (value, predicate)
Namespaces ► Autofac ► ConstantParameter ► ConstantParameter(Object, Predicate<(Of <(ParameterInfo>)>))
Create a constant parameter that will apply to parameters matching the supplied predicate.
Declaration Syntax
C# Visual Basic Visual C++
protected ConstantParameter(
    Object value,
    Predicate<ParameterInfo> predicate
)
Protected Sub New ( _
    value As Object, _
    predicate As Predicate(Of ParameterInfo) _
)
protected:
ConstantParameter(
    Object^ value,
    Predicate<ParameterInfo^>^ predicate
)
Parameters
value (Object)

[Missing <param name="value"/> documentation for "M:Autofac.ConstantParameter.#ctor(System.Object,System.Predicate{System.Reflection.ParameterInfo})"]

predicate (Predicate <(Of <( ParameterInfo >)>))

[Missing <param name="predicate"/> documentation for "M:Autofac.ConstantParameter.#ctor(System.Object,System.Predicate{System.Reflection.ParameterInfo})"]


CanSupplyValue Method (pi, context, valueProvider)

CanSupplyValue Method (pi, context, valueProvider)
Namespaces ► Autofac ► ConstantParameter ► CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%)
Returns true if the parameter is able to provide a value to a particular site.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSupplyValue(
    ParameterInfo pi,
    IContext context,
    out Func<Object> valueProvider
)
Public Overrides Function CanSupplyValue ( _
    pi As ParameterInfo, _
    context As IContext, _
    <OutAttribute> ByRef valueProvider As Func(Of Object) _
) As Boolean
public:
virtual bool CanSupplyValue(
    ParameterInfo^ pi,
    IContext^ context,
    [OutAttribute] Func<Object^>^% valueProvider
) override
Parameters
pi (ParameterInfo)
Constructor, method, or property-mutator parameter.
context (IContext)
The component context in which the value is being provided.
valueProvider ( Func <(Of <( Object >)>) %)
If the result is true, the valueProvider parameter will be set to a function that will lazily retrieve the parameter value. If the result is false, will be set to null.
Return Value
True if a value can be supplied; otherwise, false.


Value Property

Value Property
Namespaces ► Autofac ► ConstantParameter ► Value
The value of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; private set; }
Public Property Value As Object
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}


Container Class

Container Class
Namespaces ► Autofac ► Container
Standard container implementation.
Declaration Syntax
C# Visual Basic Visual C++
public class Container : Disposable, IContainer,
    IContext, IDisposable, IServiceProvider
Public Class Container _
    Inherits Disposable _
    Implements IContainer, IContext, IDisposable, IServiceProvider
public ref class Container : public Disposable,
    IContainer, IContext, IDisposable, IServiceProvider
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Container()()() | Create a new container.
 | Container(Container) | Initializes a new instance of the Container class.
 | AddRegistrationSource(IRegistrationSource) | Add a source from which registrations may be retrieved in the case that they are not available in the container.
 | CheckNotDisposed()()() | Checks that this instance has not been disposed. (Inherited from Disposable.)
 | ComponentRegistered | Fired whenever a component is registed into the container.
 | ComponentRegistrations | The registrations for all of the components registered with the container.
 | CreateInnerContainer()()() | Begin a new sub-context. Contextual and transient instances created inside the subcontext will be disposed along with it.
 | CreateResolutionContext()()() | Creates the context for a single resolve operation.
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides Disposable.Dispose(Boolean).)
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Disposable.)
 | Disposer | The disposer associated with this container. Instances can be associated with it manually if required.
 | Empty | A container with no component registrations.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InjectProperties<(Of <(T>)>)(T) | Set any properties on instance that can be resolved by the container. (Generally use InjectUnsetProperties<(Of <(T>)>)(T) unless you're using the Null Object pattern for unset dependencies.)
 | InjectUnsetProperties<(Of <(T>)>)(T) | Set any null-valued properties on instance that can be resolved by the container.
 | IsDisposed | Gets a value indicating whether this instance is disposed. (Inherited from Disposable.)
 | IsRegistered(Type) | Determines whether the specified service is registered.
 | IsRegistered(String) | Determines whether the specified service is registered.
 | IsRegistered(Service) | Determines whether the specified service is registered.
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OuterContainer | If the container is an inner container, retrieves the outer container. Otherwise, null;
 | RegisterComponent(IComponentRegistration) | Register a component.
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TagWith<(Of <(T>)>)(T) | Enables context tagging in the container.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetDefaultRegistrationFor(Service, IComponentRegistration%) | Gets the default component registration that will be used to satisfy requests for the provided service.
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
Inheritance Hierarchy
Object
 | Disposable
 |  | Container


Container Constructor

Container Constructor
Namespaces ► Autofac ► Container ► Container()()()
Members
Icon | Member | Description
 | Container()()() | Create a new container.
 | Container(Container) | Initializes a new instance of the Container class.


Container Constructor

Container Constructor
Namespaces ► Autofac ► Container ► Container()()()
Create a new container.
Declaration Syntax
C# Visual Basic Visual C++
public Container()
Public Sub New
public:
Container()


Container Constructor (outerScope)

Container Constructor (outerScope)
Namespaces ► Autofac ► Container ► Container(Container)
Initializes a new instance of the Container class.
Declaration Syntax
C# Visual Basic Visual C++
protected Container(
    Container outerScope
)
Protected Sub New ( _
    outerScope As Container _
)
protected:
Container(
    Container^ outerScope
)
Parameters
outerScope (Container)
The outer scope.


AddRegistrationSource Method (registrationSource)

AddRegistrationSource Method (registrationSource)
Namespaces ► Autofac ► Container ► AddRegistrationSource(IRegistrationSource)
Add a source from which registrations may be retrieved in the case that they are not available in the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRegistrationSource(
    IRegistrationSource registrationSource
)
Public Overridable Sub AddRegistrationSource ( _
    registrationSource As IRegistrationSource _
)
public:
virtual void AddRegistrationSource(
    IRegistrationSource^ registrationSource
)
Parameters
registrationSource (IRegistrationSource)

[Missing <param name="registrationSource"/> documentation for "M:Autofac.Container.AddRegistrationSource(Autofac.IRegistrationSource)"]


ComponentRegistered Event

ComponentRegistered Event
Namespaces ► Autofac ► Container ► ComponentRegistered
Fired whenever a component is registed into the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual event EventHandler<ComponentRegisteredEventArgs> ComponentRegistered
Public Overridable Event ComponentRegistered As EventHandler(Of ComponentRegisteredEventArgs)
public:
virtual  event EventHandler<ComponentRegisteredEventArgs^>^ ComponentRegistered {
    void add (EventHandler<ComponentRegisteredEventArgs^>^ value);
    void remove (EventHandler<ComponentRegisteredEventArgs^>^ value);
}


ComponentRegistrations Property

ComponentRegistrations Property
Namespaces ► Autofac ► Container ► ComponentRegistrations
The registrations for all of the components registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerable<IComponentRegistration> ComponentRegistrations { get; }
Public Overridable ReadOnly Property ComponentRegistrations As IEnumerable(Of IComponentRegistration)
public:
virtual property IEnumerable<IComponentRegistration^>^ ComponentRegistrations {
    IEnumerable<IComponentRegistration^>^ get ();
}


CreateInnerContainer Method

CreateInnerContainer Method
Namespaces ► Autofac ► Container ► CreateInnerContainer()()()
Begin a new sub-context. Contextual and transient instances created inside the subcontext will be disposed along with it.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IContainer CreateInnerContainer()
Public Overridable Function CreateInnerContainer As IContainer
public:
virtual IContainer^ CreateInnerContainer()
Return Value
A new subcontext.


CreateResolutionContext Method

CreateResolutionContext Method
Namespaces ► Autofac ► Container ► CreateResolutionContext()()()
Creates the context for a single resolve operation.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IContext CreateResolutionContext()
Protected Overridable Function CreateResolutionContext As IContext
protected:
virtual IContext^ CreateResolutionContext()
Return Value
The context.


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Autofac ► Container ► Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


Disposer Property

Disposer Property
Namespaces ► Autofac ► Container ► Disposer
The disposer associated with this container. Instances can be associated with it manually if required.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDisposer Disposer { get; }
Public Overridable ReadOnly Property Disposer As IDisposer
public:
virtual property IDisposer^ Disposer {
    IDisposer^ get ();
}


Empty Field

Empty Field
Namespaces ► Autofac ► Container ► Empty
A container with no component registrations.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Container Empty
Public Shared ReadOnly Empty As Container
public:
static initonly Container^ Empty


InjectProperties Method (instance)

InjectProperties<(Of <(T>)>) Method (instance)
Namespaces ► Autofac ► Container ► InjectProperties<(Of <(T>)>)(T)
Set any properties on instance that can be resolved by the container. (Generally use InjectUnsetProperties<(Of <(T>)>)(T) unless you're using the Null Object pattern for unset dependencies.)
Declaration Syntax
C# Visual Basic Visual C++
public virtual T InjectProperties<T>(
    T instance
)

Public Overridable Function InjectProperties(Of T) ( _
    instance As T _
) As T
public:
generic<typename T>
virtual T InjectProperties(
    T instance
)
Generic Template Parameters
T
Type of instance. Used only to provide method chaining.
Parameters
instance (T)
The instance to inject properties into.
Return Value
instance.


InjectUnsetProperties Method (instance)

InjectUnsetProperties<(Of <(T>)>) Method (instance)
Namespaces ► Autofac ► Container ► InjectUnsetProperties<(Of <(T>)>)(T)
Set any null-valued properties on instance that can be resolved by the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual T InjectUnsetProperties<T>(
    T instance
)

Public Overridable Function InjectUnsetProperties(Of T) ( _
    instance As T _
) As T
public:
generic<typename T>
virtual T InjectUnsetProperties(
    T instance
)
Generic Template Parameters
T
Type of instance. Used only to provide method chaining.
Parameters
instance (T)
The instance to inject properties into.
Return Value
instance.


IsRegistered Method

IsRegistered Method
Namespaces ► Autofac ► Container ► IsRegistered()()()
Members
Icon | Member | Description
 | IsRegistered(Type) | Determines whether the specified service is registered.
 | IsRegistered(String) | Determines whether the specified service is registered.
 | IsRegistered(Service) | Determines whether the specified service is registered.
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered.


IsRegistered Method

IsRegistered<(Of <(TService>)>) Method
Namespaces ► Autofac ► Container ► IsRegistered<(Of <(TService>)>)()()()
Determine whether or not a service has been registered.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsRegistered<TService>()

Public Overridable Function IsRegistered(Of TService) As Boolean
public:
generic<typename TService>
virtual bool IsRegistered()
Generic Template Parameters
TService
The service to test for the registration of.
Return Value
True if the service is registered.


IsRegistered Method (service)

IsRegistered Method (service)
Namespaces ► Autofac ► Container ► IsRegistered(Service)
Determines whether the specified service is registered.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsRegistered(
    Service service
)
Public Overridable Function IsRegistered ( _
    service As Service _
) As Boolean
public:
virtual bool IsRegistered(
    Service^ service
)
Parameters
service (Service)
The service.
Return Value
true if the specified service is registered; otherwise, false.


IsRegistered Method (name)

IsRegistered Method (name)
Namespaces ► Autofac ► Container ► IsRegistered(String)
Determines whether the specified service is registered.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsRegistered(
    string name
)
Public Overridable Function IsRegistered ( _
    name As String _
) As Boolean
public:
virtual bool IsRegistered(
    String^ name
)
Parameters
name (String)
The service.
Return Value
true if the specified service is registered; otherwise, false.


IsRegistered Method (service)

IsRegistered Method (service)
Namespaces ► Autofac ► Container ► IsRegistered(Type)
Determines whether the specified service is registered.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsRegistered(
    Type service
)
Public Overridable Function IsRegistered ( _
    service As Type _
) As Boolean
public:
virtual bool IsRegistered(
    Type^ service
)
Parameters
service (Type)
The service.
Return Value
true if the specified service is registered; otherwise, false.


OuterContainer Property

OuterContainer Property
Namespaces ► Autofac ► Container ► OuterContainer
If the container is an inner container, retrieves the outer container. Otherwise, null;
Declaration Syntax
C# Visual Basic Visual C++
public virtual IContainer OuterContainer { get; }
Public Overridable ReadOnly Property OuterContainer As IContainer
public:
virtual property IContainer^ OuterContainer {
    IContainer^ get ();
}
Value


RegisterComponent Method (registration)

RegisterComponent Method (registration)
Namespaces ► Autofac ► Container ► RegisterComponent(IComponentRegistration)
Register a component.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RegisterComponent(
    IComponentRegistration registration
)
Public Overridable Sub RegisterComponent ( _
    registration As IComponentRegistration _
)
public:
virtual void RegisterComponent(
    IComponentRegistration^ registration
)
Parameters
registration (IComponentRegistration)
A component registration.


Resolve Method

Resolve Method
Namespaces ► Autofac ► Container ► Resolve()()()
Members
Icon | Member | Description
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


Resolve Method (parameters)

Resolve<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► Container ► Resolve<(Of <(TService>)>)(array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TService Resolve<TService>(
    params Parameter[] parameters
)

Public Overridable Function Resolve(Of TService) ( _
    ParamArray parameters As Parameter() _
) As TService
public:
generic<typename TService>
virtual TService Resolve(
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.Resolve``1(Autofac.Parameter[])"]

Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (service, parameters)

Resolve Method (service, parameters)
Namespaces ► Autofac ► Container ► Resolve(Service, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Resolve(
    Service service,
    params Parameter[] parameters
)
Public Overridable Function Resolve ( _
    service As Service, _
    ParamArray parameters As Parameter() _
) As Object
public:
virtual Object^ Resolve(
    Service^ service,
    ... array<Parameter^>^ parameters
)
Parameters
service (Service)
The service to retrieve.
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.Resolve(Autofac.Service,Autofac.Parameter[])"]

Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (service, parameters)

Resolve Method (service, parameters)
Namespaces ► Autofac ► Container ► Resolve(Service, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public Object Resolve(
    Service service,
    IEnumerable<Parameter> parameters
)
Public Function Resolve ( _
    service As Service, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ Resolve(
    Service^ service,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
service (Service)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (parameters)

Resolve<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► Container ► Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public TService Resolve<TService>(
    IEnumerable<Parameter> parameters
)

Public Function Resolve(Of TService) ( _
    parameters As IEnumerable(Of Parameter) _
) As TService
public:
generic<typename TService>
virtual TService Resolve(
    IEnumerable<Parameter^>^ parameters
) sealed
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.Resolve``1(System.Collections.Generic.IEnumerable{Autofac.Parameter})"]

Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve<(Of <(TService>)>) Method (serviceName, parameters)
Namespaces ► Autofac ► Container ► Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TService Resolve<TService>(
    string serviceName,
    params Parameter[] parameters
)

Public Overridable Function Resolve(Of TService) ( _
    serviceName As String, _
    ParamArray parameters As Parameter() _
) As TService
public:
generic<typename TService>
virtual TService Resolve(
    String^ serviceName,
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The type to which the result will be cast.
Parameters
serviceName (String)
Name of the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve Method (serviceName, parameters)
Namespaces ► Autofac ► Container ► Resolve(String, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Resolve(
    string serviceName,
    params Parameter[] parameters
)
Public Overridable Function Resolve ( _
    serviceName As String, _
    ParamArray parameters As Parameter() _
) As Object
public:
virtual Object^ Resolve(
    String^ serviceName,
    ... array<Parameter^>^ parameters
)
Parameters
serviceName (String)
The service to retrieve.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve<(Of <(TService>)>) Method (serviceName, parameters)
Namespaces ► Autofac ► Container ► Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public TService Resolve<TService>(
    string serviceName,
    IEnumerable<Parameter> parameters
)

Public Function Resolve(Of TService) ( _
    serviceName As String, _
    parameters As IEnumerable(Of Parameter) _
) As TService
public:
generic<typename TService>
virtual TService Resolve(
    String^ serviceName,
    IEnumerable<Parameter^>^ parameters
) sealed
Generic Template Parameters
TService
The type to which the result will be cast.
Parameters
serviceName (String)
Name of the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve Method (serviceName, parameters)
Namespaces ► Autofac ► Container ► Resolve(String, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public Object Resolve(
    string serviceName,
    IEnumerable<Parameter> parameters
)
Public Function Resolve ( _
    serviceName As String, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ Resolve(
    String^ serviceName,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
serviceName (String)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceType, parameters)

Resolve Method (serviceType, parameters)
Namespaces ► Autofac ► Container ► Resolve(Type, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Resolve(
    Type serviceType,
    params Parameter[] parameters
)
Public Overridable Function Resolve ( _
    serviceType As Type, _
    ParamArray parameters As Parameter() _
) As Object
public:
virtual Object^ Resolve(
    Type^ serviceType,
    ... array<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceType, parameters)

Resolve Method (serviceType, parameters)
Namespaces ► Autofac ► Container ► Resolve(Type, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public Object Resolve(
    Type serviceType,
    IEnumerable<Parameter> parameters
)
Public Function Resolve ( _
    serviceType As Type, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ Resolve(
    Type^ serviceType,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
serviceType (Type)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


ResolveOptional Method

ResolveOptional Method
Namespaces ► Autofac ► Container ► ResolveOptional()()()
Members
Icon | Member | Description
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


ResolveOptional Method (parameters)

ResolveOptional<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► Container ► ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TService ResolveOptional<TService>(
    params Parameter[] parameters
)

Public Overridable Function ResolveOptional(Of TService) ( _
    ParamArray parameters As Parameter() _
) As TService
public:
generic<typename TService>
virtual TService ResolveOptional(
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.ResolveOptional``1(Autofac.Parameter[])"]

Return Value
The component instance that provides the service, or null if none is available.
Remarks
Useful with the C#3 initialiser syntax.
Examples
container.Register<ISomething>(c => new Something(){ AProperty = c.ResolveOptional<IOptional>() });


ResolveOptional Method (parameters)

ResolveOptional<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► Container ► ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public TService ResolveOptional<TService>(
    IEnumerable<Parameter> parameters
)

Public Function ResolveOptional(Of TService) ( _
    parameters As IEnumerable(Of Parameter) _
) As TService
public:
generic<typename TService>
virtual TService ResolveOptional(
    IEnumerable<Parameter^>^ parameters
) sealed
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service, or null if none is available.
Remarks
Useful with the C#3 initialiser syntax.
Examples
container.Register<ISomething>(c => new Something(){ AProperty = c.ResolveOptional<IOptional>() });


TagWith Method (tag)

TagWith<(Of <(T>)>) Method (tag)
Namespaces ► Autofac ► Container ► TagWith<(Of <(T>)>)(T)
Enables context tagging in the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TagWith<T>(
    T tag
)

Public Overridable Sub TagWith(Of T) ( _
    tag As T _
)
public:
generic<typename T>
virtual void TagWith(
    T tag
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Autofac.Container.TagWith``1(``0)"]

Parameters
tag (T)
The tag applied to this container and the contexts genrated when it resolves component dependencies.


TryGetDefaultRegistrationFor Method (service, registration)

TryGetDefaultRegistrationFor Method (service, registration)
Namespaces ► Autofac ► Container ► TryGetDefaultRegistrationFor(Service, IComponentRegistration%)
Gets the default component registration that will be used to satisfy requests for the provided service.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryGetDefaultRegistrationFor(
    Service service,
    out IComponentRegistration registration
)
Public Overridable Function TryGetDefaultRegistrationFor ( _
    service As Service, _
    <OutAttribute> ByRef registration As IComponentRegistration _
) As Boolean
public:
virtual bool TryGetDefaultRegistrationFor(
    Service^ service,
    [OutAttribute] IComponentRegistration^% registration
)
Parameters
service (Service)
The service.
registration ( IComponentRegistration %)
The registration.
Return Value
True if a default exists, false otherwise.


TryResolve Method

TryResolve Method
Namespaces ► Autofac ► Container ► TryResolve()()()
Members
Icon | Member | Description
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.


TryResolve Method (service, instance, parameters)

TryResolve Method (service, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(Service, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryResolve(
    Service service,
    out Object instance,
    params Parameter[] parameters
)
Public Overridable Function TryResolve ( _
    service As Service, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
public:
virtual bool TryResolve(
    Service^ service,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
service (Service)
The key of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.TryResolve(Autofac.Service,System.Object@,Autofac.Parameter[])"]

Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (service, instance, parameters)

TryResolve Method (service, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryResolve(
    Service service,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Public Function TryResolve ( _
    service As Service, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
public:
virtual bool TryResolve(
    Service^ service,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
service (Service)
The key of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (componentName, instance, parameters)

TryResolve Method (componentName, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(String, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryResolve(
    string componentName,
    out Object instance,
    params Parameter[] parameters
)
Public Overridable Function TryResolve ( _
    componentName As String, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
public:
virtual bool TryResolve(
    String^ componentName,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
componentName (String)
The name of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.TryResolve(System.String,System.Object@,Autofac.Parameter[])"]

Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (componentName, instance, parameters)

TryResolve Method (componentName, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryResolve(
    string componentName,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Public Function TryResolve ( _
    componentName As String, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
public:
virtual bool TryResolve(
    String^ componentName,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
componentName (String)
The name of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (serviceType, instance, parameters)

TryResolve Method (serviceType, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(Type, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryResolve(
    Type serviceType,
    out Object instance,
    params Parameter[] parameters
)
Public Overridable Function TryResolve ( _
    serviceType As Type, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
public:
virtual bool TryResolve(
    Type^ serviceType,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.TryResolve(System.Type,System.Object@,Autofac.Parameter[])"]

Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (serviceType, instance, parameters)

TryResolve Method (serviceType, instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryResolve(
    Type serviceType,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Public Function TryResolve ( _
    serviceType As Type, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
public:
virtual bool TryResolve(
    Type^ serviceType,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
serviceType (Type)
The service to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (instance, parameters)

TryResolve<(Of <(TService>)>) Method (instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryResolve<TService>(
    out TService instance,
    params Parameter[] parameters
)

Public Overridable Function TryResolve(Of TService) ( _
    <OutAttribute> ByRef instance As TService, _
    ParamArray parameters As Parameter() _
) As Boolean
public:
generic<typename TService>
virtual bool TryResolve(
    [OutAttribute] TService% instance,
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
instance ( TService %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.Container.TryResolve``1(``0@,Autofac.Parameter[])"]

Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (instance, parameters)

TryResolve<(Of <(TService>)>) Method (instance, parameters)
Namespaces ► Autofac ► Container ► TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryResolve<TService>(
    out TService instance,
    IEnumerable<Parameter> parameters
)

Public Function TryResolve(Of TService) ( _
    <OutAttribute> ByRef instance As TService, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
public:
generic<typename TService>
virtual bool TryResolve(
    [OutAttribute] TService% instance,
    IEnumerable<Parameter^>^ parameters
) sealed
Generic Template Parameters
TService
The service to retrieve.
Parameters
instance ( TService %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


DependencyResolutionException Class

DependencyResolutionException Class
Namespaces ► Autofac ► DependencyResolutionException
Problem resolving dependencies, e.g. circular references, no callable constructor etc.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DependencyResolutionException : Exception
<SerializableAttribute> _
Public Class DependencyResolutionException _
    Inherits Exception
[SerializableAttribute]
public ref class DependencyResolutionException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DependencyResolutionException()()() | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(String) | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(String, Exception) | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ComponentNotRegisteredException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | DependencyResolutionException


DependencyResolutionException Constructor

DependencyResolutionException Constructor
Namespaces ► Autofac ► DependencyResolutionException ► DependencyResolutionException()()()
Members
Icon | Member | Description
 | DependencyResolutionException()()() | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(String) | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(String, Exception) | Initializes a new instance of the DependencyResolutionException class.
 | DependencyResolutionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ComponentNotRegisteredException class.


DependencyResolutionException Constructor

DependencyResolutionException Constructor
Namespaces ► Autofac ► DependencyResolutionException ► DependencyResolutionException()()()
Initializes a new instance of the DependencyResolutionException class.
Declaration Syntax
C# Visual Basic Visual C++
public DependencyResolutionException()
Public Sub New
public:
DependencyResolutionException()


DependencyResolutionException Constructor (info, context)

DependencyResolutionException Constructor (info, context)
Namespaces ► Autofac ► DependencyResolutionException ► DependencyResolutionException(SerializationInfo, StreamingContext)
Initializes a new instance of the ComponentNotRegisteredException class.
Declaration Syntax
C# Visual Basic Visual C++
protected DependencyResolutionException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DependencyResolutionException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).


DependencyResolutionException Constructor (message)

DependencyResolutionException Constructor (message)
Namespaces ► Autofac ► DependencyResolutionException ► DependencyResolutionException(String)
Initializes a new instance of the DependencyResolutionException class.
Declaration Syntax
C# Visual Basic Visual C++
public DependencyResolutionException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
DependencyResolutionException(
    String^ message
)
Parameters
message (String)
The message.


DependencyResolutionException Constructor (message, innerException)

DependencyResolutionException Constructor (message, innerException)
Namespaces ► Autofac ► DependencyResolutionException ► DependencyResolutionException(String, Exception)
Initializes a new instance of the DependencyResolutionException class.
Declaration Syntax
C# Visual Basic Visual C++
public DependencyResolutionException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
DependencyResolutionException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


Disposable Class

Disposable Class
Namespaces ► Autofac ► Disposable
Base class for disposable objects.
Declaration Syntax
C# Visual Basic Visual C++
public class Disposable : IDisposable
Public Class Disposable _
    Implements IDisposable
public ref class Disposable : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Disposable()()() | Initializes a new instance of the Disposable class
 | CheckNotDisposed()()() | Checks that this instance has not been disposed.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDisposed | Gets a value indicating whether this instance is disposed.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Disposable
 |  | Registration
 |  | Container


Disposable Constructor

Disposable Constructor
Namespaces ► Autofac ► Disposable ► Disposable()()()
Initializes a new instance of the Disposable class
Declaration Syntax
C# Visual Basic Visual C++
public Disposable()
Public Sub New
public:
Disposable()


CheckNotDisposed Method

CheckNotDisposed Method
Namespaces ► Autofac ► Disposable ► CheckNotDisposed()()()
Checks that this instance has not been disposed.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void CheckNotDisposed()
Protected Overridable Sub CheckNotDisposed
protected:
virtual void CheckNotDisposed()


Dispose Method

Dispose Method
Namespaces ► Autofac ► Disposable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources


Dispose Method

Dispose Method
Namespaces ► Autofac ► Disposable ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Autofac ► Disposable ► Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.


IsDisposed Property

IsDisposed Property
Namespaces ► Autofac ► Disposable ► IsDisposed
Gets a value indicating whether this instance is disposed.
Declaration Syntax
C# Visual Basic Visual C++
protected bool IsDisposed { get; }
Protected ReadOnly Property IsDisposed As Boolean
protected:
property bool IsDisposed {
    bool get ();
}
Value
true if this instance is disposed; otherwise, false.


IComponentDescriptor Interface

IComponentDescriptor Interface
Namespaces ► Autofac ► IComponentDescriptor
Captures the elements of a component registration that are shared between all contexts in which the component can be used.
Declaration Syntax
C# Visual Basic Visual C++
public interface IComponentDescriptor
Public Interface IComponentDescriptor
public interface class IComponentDescriptor
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BestKnownImplementationType | Returns the most specific type that the returned intstances are assignable to. This may be the actual implementation type, a base class, and abstract class, or an interface.
 | ExtendedProperties | Additional data associated with the component.
 | Id | A unique identifier for this component (shared in all sub-contexts.) This value also appears in Services.
 | Services | The services (named and typed) exposed by the component.


BestKnownImplementationType Property

BestKnownImplementationType Property
Namespaces ► Autofac ► IComponentDescriptor ► BestKnownImplementationType
Returns the most specific type that the returned intstances are assignable to. This may be the actual implementation type, a base class, and abstract class, or an interface.
Declaration Syntax
C# Visual Basic Visual C++
Type BestKnownImplementationType { get; }
ReadOnly Property BestKnownImplementationType As Type
property Type^ BestKnownImplementationType {
    Type^ get ();
}
Return Value
The best known implementation type.
Remarks
For registrations where the type is an interface or abstract class it is recommended that the returned instances are inspected as they are activated.


ExtendedProperties Property

ExtendedProperties Property
Namespaces ► Autofac ► IComponentDescriptor ► ExtendedProperties
Additional data associated with the component.
Declaration Syntax
C# Visual Basic Visual C++
IDictionary<string, Object> ExtendedProperties { get; }
ReadOnly Property ExtendedProperties As IDictionary(Of String, Object)
property IDictionary<String^, Object^>^ ExtendedProperties {
    IDictionary<String^, Object^>^ get ();
}
Remarks
Note, component registrations are currently copied into subcontainers: these properties are shared between all instances of the registration in all subcontainers.


Id Property

Id Property
Namespaces ► Autofac ► IComponentDescriptor ► Id
A unique identifier for this component (shared in all sub-contexts.) This value also appears in Services.
Declaration Syntax
C# Visual Basic Visual C++
Service Id { get; }
ReadOnly Property Id As Service
property Service^ Id {
    Service^ get ();
}


Services Property

Services Property
Namespaces ► Autofac ► IComponentDescriptor ► Services
The services (named and typed) exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<Service> Services { get; }
ReadOnly Property Services As IEnumerable(Of Service)
property IEnumerable<Service^>^ Services {
    IEnumerable<Service^>^ get ();
}


IComponentRegistration Interface

IComponentRegistration Interface
Namespaces ► Autofac ► IComponentRegistration
A component registration is used by the container to create and manage the services it holds.
Declaration Syntax
C# Visual Basic Visual C++
public interface IComponentRegistration : IDisposable
Public Interface IComponentRegistration _
    Implements IDisposable
public interface class IComponentRegistration : IDisposable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Activated | Fired when the activation process for a new instance is complete.
 | Activating | Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
 | Descriptor | Describes the component registration and the services it provides.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | DuplicateForNewContext(IComponentRegistration%) | Create a duplicate of this instance if it is semantically valid to copy it to a new context.
 | InstanceActivated(IContext, Object) | Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
 | Preparing | Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
 | ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%) | Must return a valid instance, or throw an exception on failure.


Activated Event

Activated Event
Namespaces ► Autofac ► IComponentRegistration ► Activated
Fired when the activation process for a new instance is complete.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<ActivatedEventArgs> Activated
Event Activated As EventHandler(Of ActivatedEventArgs)
 event EventHandler<ActivatedEventArgs^>^ Activated {
    void add (EventHandler<ActivatedEventArgs^>^ value);
    void remove (EventHandler<ActivatedEventArgs^>^ value);
}


Activating Event

Activating Event
Namespaces ► Autofac ► IComponentRegistration ► Activating
Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<ActivatingEventArgs> Activating
Event Activating As EventHandler(Of ActivatingEventArgs)
 event EventHandler<ActivatingEventArgs^>^ Activating {
    void add (EventHandler<ActivatingEventArgs^>^ value);
    void remove (EventHandler<ActivatingEventArgs^>^ value);
}


Descriptor Property

Descriptor Property
Namespaces ► Autofac ► IComponentRegistration ► Descriptor
Describes the component registration and the services it provides.
Declaration Syntax
C# Visual Basic Visual C++
IComponentDescriptor Descriptor { get; }
ReadOnly Property Descriptor As IComponentDescriptor
property IComponentDescriptor^ Descriptor {
    IComponentDescriptor^ get ();
}


DuplicateForNewContext Method (duplicate)

DuplicateForNewContext Method (duplicate)
Namespaces ► Autofac ► IComponentRegistration ► DuplicateForNewContext(IComponentRegistration%)
Create a duplicate of this instance if it is semantically valid to copy it to a new context.
Declaration Syntax
C# Visual Basic Visual C++
bool DuplicateForNewContext(
    out IComponentRegistration duplicate
)
Function DuplicateForNewContext ( _
    <OutAttribute> ByRef duplicate As IComponentRegistration _
) As Boolean
bool DuplicateForNewContext(
    [OutAttribute] IComponentRegistration^% duplicate
)
Parameters
duplicate ( IComponentRegistration %)
The duplicate.
Return Value
True if the duplicate was created.


InstanceActivated Method (context, instance)

InstanceActivated Method (context, instance)
Namespaces ► Autofac ► IComponentRegistration ► InstanceActivated(IContext, Object)
Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
Declaration Syntax
C# Visual Basic Visual C++
void InstanceActivated(
    IContext context,
    Object instance
)
Sub InstanceActivated ( _
    context As IContext, _
    instance As Object _
)
void InstanceActivated(
    IContext^ context,
    Object^ instance
)
Parameters
context (IContext)
The context in which the instance was activated.
instance (Object)
The instance.


Preparing Event

Preparing Event
Namespaces ► Autofac ► IComponentRegistration ► Preparing
Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<PreparingEventArgs> Preparing
Event Preparing As EventHandler(Of PreparingEventArgs)
 event EventHandler<PreparingEventArgs^>^ Preparing {
    void add (EventHandler<PreparingEventArgs^>^ value);
    void remove (EventHandler<PreparingEventArgs^>^ value);
}


ResolveInstance Method (context, parameters, disposer, newInstance)

ResolveInstance Method (context, parameters, disposer, newInstance)
Namespaces ► Autofac ► IComponentRegistration ► ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%)
Must return a valid instance, or throw an exception on failure.
Declaration Syntax
C# Visual Basic Visual C++
Object ResolveInstance(
    IContext context,
    IEnumerable<Parameter> parameters,
    IDisposer disposer,
    out bool newInstance
)
Function ResolveInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter), _
    disposer As IDisposer, _
    <OutAttribute> ByRef newInstance As Boolean _
) As Object
Object^ ResolveInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters,
    IDisposer^ disposer,
    [OutAttribute] bool% newInstance
)
Parameters
context (IContext)
The context that is to be used to resolve the instance's dependencies.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
disposer (IDisposer)
The disposer.
newInstance ( Boolean %)
if set to true a new instance was created.
Return Value
A newly-resolved instance.


IContainer Interface

IContainer Interface
Namespaces ► Autofac ► IContainer
Provides the full Autofac container functionality.
Declaration Syntax
C# Visual Basic Visual C++
public interface IContainer : IContext,
    IDisposable
Public Interface IContainer _
    Implements IContext, IDisposable
public interface class IContainer : IContext,
    IDisposable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddRegistrationSource(IRegistrationSource) | Add a source from which registrations may be retrieved in the case that they are not available in the container.
 | ComponentRegistered | Fired whenever a component is registed into the container.
 | ComponentRegistrations | The registrations for all of the components registered with the container.
 | CreateInnerContainer()()() | Begin a new sub-context. Contextual and transient instances created inside the subcontext will be disposed along with it.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | Disposer | The disposer associated with this container. Instances can be associated with it manually if required.
 | InjectProperties<(Of <(T>)>)(T) | Set any properties on instance that can be resolved by the container. (Generally use InjectUnsetProperties<(Of <(T>)>)(T) unless you're using the Null Object pattern for unset dependencies.) (Inherited from IContext.)
 | InjectUnsetProperties<(Of <(T>)>)(T) | Set any null-valued properties on instance that can be resolved by the container. (Inherited from IContext.)
 | IsRegistered(Type) | Determine whether or not a service has been registered. (Inherited from IContext.)
 | IsRegistered(String) | Determine whether or not a service has been registered. (Inherited from IContext.)
 | IsRegistered(Service) | Determine whether or not a service has been registered. (Inherited from IContext.)
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered. (Inherited from IContext.)
 | OuterContainer | If the container is an inner container, retrieves the outer container. Otherwise, null;
 | RegisterComponent(IComponentRegistration) | Register a component.
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TagWith<(Of <(T>)>)(T) | Tags the container with the provided value.
 | TryGetDefaultRegistrationFor(Service, IComponentRegistration%) | Gets the default component registration that will be used to satisfy requests for the provided service.
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container. (Inherited from IContext.)
Remarks
It is recommended that in most instances the more limited IContext interface is used instead, as this is easier to implement on top of a different back-end, e.g. a customised or alternative container.


AddRegistrationSource Method (source)

AddRegistrationSource Method (source)
Namespaces ► Autofac ► IContainer ► AddRegistrationSource(IRegistrationSource)
Add a source from which registrations may be retrieved in the case that they are not available in the container.
Declaration Syntax
C# Visual Basic Visual C++
void AddRegistrationSource(
    IRegistrationSource source
)
Sub AddRegistrationSource ( _
    source As IRegistrationSource _
)
void AddRegistrationSource(
    IRegistrationSource^ source
)
Parameters
source (IRegistrationSource)
The source.


ComponentRegistered Event

ComponentRegistered Event
Namespaces ► Autofac ► IContainer ► ComponentRegistered
Fired whenever a component is registed into the container.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<ComponentRegisteredEventArgs> ComponentRegistered
Event ComponentRegistered As EventHandler(Of ComponentRegisteredEventArgs)
 event EventHandler<ComponentRegisteredEventArgs^>^ ComponentRegistered {
    void add (EventHandler<ComponentRegisteredEventArgs^>^ value);
    void remove (EventHandler<ComponentRegisteredEventArgs^>^ value);
}


ComponentRegistrations Property

ComponentRegistrations Property
Namespaces ► Autofac ► IContainer ► ComponentRegistrations
The registrations for all of the components registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<IComponentRegistration> ComponentRegistrations { get; }
ReadOnly Property ComponentRegistrations As IEnumerable(Of IComponentRegistration)
property IEnumerable<IComponentRegistration^>^ ComponentRegistrations {
    IEnumerable<IComponentRegistration^>^ get ();
}


CreateInnerContainer Method

CreateInnerContainer Method
Namespaces ► Autofac ► IContainer ► CreateInnerContainer()()()
Begin a new sub-context. Contextual and transient instances created inside the subcontext will be disposed along with it.
Declaration Syntax
C# Visual Basic Visual C++
IContainer CreateInnerContainer()
Function CreateInnerContainer As IContainer
IContainer^ CreateInnerContainer()
Return Value
A new subcontext.


Disposer Property

Disposer Property
Namespaces ► Autofac ► IContainer ► Disposer
The disposer associated with this container. Instances can be associated with it manually if required.
Declaration Syntax
C# Visual Basic Visual C++
IDisposer Disposer { get; }
ReadOnly Property Disposer As IDisposer
property IDisposer^ Disposer {
    IDisposer^ get ();
}


OuterContainer Property

OuterContainer Property
Namespaces ► Autofac ► IContainer ► OuterContainer
If the container is an inner container, retrieves the outer container. Otherwise, null;
Declaration Syntax
C# Visual Basic Visual C++
IContainer OuterContainer { get; }
ReadOnly Property OuterContainer As IContainer
property IContainer^ OuterContainer {
    IContainer^ get ();
}


RegisterComponent Method (registration)

RegisterComponent Method (registration)
Namespaces ► Autofac ► IContainer ► RegisterComponent(IComponentRegistration)
Register a component.
Declaration Syntax
C# Visual Basic Visual C++
void RegisterComponent(
    IComponentRegistration registration
)
Sub RegisterComponent ( _
    registration As IComponentRegistration _
)
void RegisterComponent(
    IComponentRegistration^ registration
)
Parameters
registration (IComponentRegistration)
A component registration.


TagWith Method (tag)

TagWith<(Of <(T>)>) Method (tag)
Namespaces ► Autofac ► IContainer ► TagWith<(Of <(T>)>)(T)
Tags the container with the provided value.
Declaration Syntax
C# Visual Basic Visual C++
void TagWith<T>(
    T tag
)

Sub TagWith(Of T) ( _
    tag As T _
)
generic<typename T>
void TagWith(
    T tag
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Autofac.IContainer.TagWith``1(``0)"]

Parameters
tag (T)
The tag applied to this container and the contexts genrated when it resolves component dependencies.


TryGetDefaultRegistrationFor Method (service, registration)

TryGetDefaultRegistrationFor Method (service, registration)
Namespaces ► Autofac ► IContainer ► TryGetDefaultRegistrationFor(Service, IComponentRegistration%)
Gets the default component registration that will be used to satisfy requests for the provided service.
Declaration Syntax
C# Visual Basic Visual C++
bool TryGetDefaultRegistrationFor(
    Service service,
    out IComponentRegistration registration
)
Function TryGetDefaultRegistrationFor ( _
    service As Service, _
    <OutAttribute> ByRef registration As IComponentRegistration _
) As Boolean
bool TryGetDefaultRegistrationFor(
    Service^ service,
    [OutAttribute] IComponentRegistration^% registration
)
Parameters
service (Service)
The service.
registration ( IComponentRegistration %)
The registration.
Return Value
True if a default exists, false otherwise.


IContext Interface

IContext Interface
Namespaces ► Autofac ► IContext
The context in which a service can be accessed or a component's dependencies resolved. Disposal of a context will dispose any owned components.
Declaration Syntax
C# Visual Basic Visual C++
public interface IContext
Public Interface IContext
public interface class IContext
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InjectProperties<(Of <(T>)>)(T) | Set any properties on instance that can be resolved by the container. (Generally use InjectUnsetProperties<(Of <(T>)>)(T) unless you're using the Null Object pattern for unset dependencies.)
 | InjectUnsetProperties<(Of <(T>)>)(T) | Set any null-valued properties on instance that can be resolved by the container.
 | IsRegistered(Type) | Determine whether or not a service has been registered.
 | IsRegistered(String) | Determine whether or not a service has been registered.
 | IsRegistered(Service) | Determine whether or not a service has been registered.
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered.
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
Remarks
This interface is intended to be the lowest-common-denominator between IoC containers - the Autofac-specific features are generally available through the Container class only. By restricting wider application access to this interface, an application can remain compatible with other containers and be adapted to them via this interface if necessary.


InjectProperties Method (instance)

InjectProperties<(Of <(T>)>) Method (instance)
Namespaces ► Autofac ► IContext ► InjectProperties<(Of <(T>)>)(T)
Set any properties on instance that can be resolved by the container. (Generally use InjectUnsetProperties<(Of <(T>)>)(T) unless you're using the Null Object pattern for unset dependencies.)
Declaration Syntax
C# Visual Basic Visual C++
T InjectProperties<T>(
    T instance
)

Function InjectProperties(Of T) ( _
    instance As T _
) As T
generic<typename T>
T InjectProperties(
    T instance
)
Generic Template Parameters
T
Type of instance. Used only to provide method chaining.
Parameters
instance (T)
The instance to inject properties into.
Return Value
instance.


InjectUnsetProperties Method (instance)

InjectUnsetProperties<(Of <(T>)>) Method (instance)
Namespaces ► Autofac ► IContext ► InjectUnsetProperties<(Of <(T>)>)(T)
Set any null-valued properties on instance that can be resolved by the container.
Declaration Syntax
C# Visual Basic Visual C++
T InjectUnsetProperties<T>(
    T instance
)

Function InjectUnsetProperties(Of T) ( _
    instance As T _
) As T
generic<typename T>
T InjectUnsetProperties(
    T instance
)
Generic Template Parameters
T
Type of instance. Used only to provide method chaining.
Parameters
instance (T)
The instance to inject properties into.
Return Value
instance.


IsRegistered Method

IsRegistered Method
Namespaces ► Autofac ► IContext ► IsRegistered()()()
Members
Icon | Member | Description
 | IsRegistered(Type) | Determine whether or not a service has been registered.
 | IsRegistered(String) | Determine whether or not a service has been registered.
 | IsRegistered(Service) | Determine whether or not a service has been registered.
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered.


IsRegistered Method

IsRegistered<(Of <(TService>)>) Method
Namespaces ► Autofac ► IContext ► IsRegistered<(Of <(TService>)>)()()()
Determine whether or not a service has been registered.
Declaration Syntax
C# Visual Basic Visual C++
bool IsRegistered<TService>()

Function IsRegistered(Of TService) As Boolean
generic<typename TService>
bool IsRegistered()
Generic Template Parameters
TService
The service to test for the registration of.
Return Value
True if the service is registered.


IsRegistered Method (service)

IsRegistered Method (service)
Namespaces ► Autofac ► IContext ► IsRegistered(Service)
Determine whether or not a service has been registered.
Declaration Syntax
C# Visual Basic Visual C++
bool IsRegistered(
    Service service
)
Function IsRegistered ( _
    service As Service _
) As Boolean
bool IsRegistered(
    Service^ service
)
Parameters
service (Service)
The service to test for the registration of.
Return Value
True if the service is registered.


IsRegistered Method (serviceName)

IsRegistered Method (serviceName)
Namespaces ► Autofac ► IContext ► IsRegistered(String)
Determine whether or not a service has been registered.
Declaration Syntax
C# Visual Basic Visual C++
bool IsRegistered(
    string serviceName
)
Function IsRegistered ( _
    serviceName As String _
) As Boolean
bool IsRegistered(
    String^ serviceName
)
Parameters
serviceName (String)
The service to test for the registration of.
Return Value
True if the service is registered.


IsRegistered Method (serviceType)

IsRegistered Method (serviceType)
Namespaces ► Autofac ► IContext ► IsRegistered(Type)
Determine whether or not a service has been registered.
Declaration Syntax
C# Visual Basic Visual C++
bool IsRegistered(
    Type serviceType
)
Function IsRegistered ( _
    serviceType As Type _
) As Boolean
bool IsRegistered(
    Type^ serviceType
)
Parameters
serviceType (Type)
The service to test for the registration of.
Return Value
True if the service is registered.


Resolve Method

Resolve Method
Namespaces ► Autofac ► IContext ► Resolve()()()
Members
Icon | Member | Description
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


Resolve Method (parameters)

Resolve<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► IContext ► Resolve<(Of <(TService>)>)(array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService Resolve<TService>(
    params Parameter[] parameters
)

Function Resolve(Of TService) ( _
    ParamArray parameters As Parameter() _
) As TService
generic<typename TService>
TService Resolve(
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (array< Parameter >[]()[])

[Missing <param name="parameters"/> documentation for "M:Autofac.IContext.Resolve``1(Autofac.Parameter[])"]

Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (service, parameters)

Resolve Method (service, parameters)
Namespaces ► Autofac ► IContext ► Resolve(Service, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    Service service,
    params Parameter[] parameters
)
Function Resolve ( _
    service As Service, _
    ParamArray parameters As Parameter() _
) As Object
Object^ Resolve(
    Service^ service,
    ... array<Parameter^>^ parameters
)
Parameters
service (Service)
The service to retrieve.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (service, parameters)

Resolve Method (service, parameters)
Namespaces ► Autofac ► IContext ► Resolve(Service, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    Service service,
    IEnumerable<Parameter> parameters
)
Function Resolve ( _
    service As Service, _
    parameters As IEnumerable(Of Parameter) _
) As Object
Object^ Resolve(
    Service^ service,
    IEnumerable<Parameter^>^ parameters
)
Parameters
service (Service)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (parameters)

Resolve<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► IContext ► Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService Resolve<TService>(
    IEnumerable<Parameter> parameters
)

Function Resolve(Of TService) ( _
    parameters As IEnumerable(Of Parameter) _
) As TService
generic<typename TService>
TService Resolve(
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))

[Missing <param name="parameters"/> documentation for "M:Autofac.IContext.Resolve``1(System.Collections.Generic.IEnumerable{Autofac.Parameter})"]

Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve<(Of <(TService>)>) Method (serviceName, parameters)
Namespaces ► Autofac ► IContext ► Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService Resolve<TService>(
    string serviceName,
    params Parameter[] parameters
)

Function Resolve(Of TService) ( _
    serviceName As String, _
    ParamArray parameters As Parameter() _
) As TService
generic<typename TService>
TService Resolve(
    String^ serviceName,
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The type to which the result will be cast.
Parameters
serviceName (String)
Name of the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve Method (serviceName, parameters)
Namespaces ► Autofac ► IContext ► Resolve(String, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    string serviceName,
    params Parameter[] parameters
)
Function Resolve ( _
    serviceName As String, _
    ParamArray parameters As Parameter() _
) As Object
Object^ Resolve(
    String^ serviceName,
    ... array<Parameter^>^ parameters
)
Parameters
serviceName (String)
The service to retrieve.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve Method (serviceName, parameters)
Namespaces ► Autofac ► IContext ► Resolve(String, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    string serviceName,
    IEnumerable<Parameter> parameters
)
Function Resolve ( _
    serviceName As String, _
    parameters As IEnumerable(Of Parameter) _
) As Object
Object^ Resolve(
    String^ serviceName,
    IEnumerable<Parameter^>^ parameters
)
Parameters
serviceName (String)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceName, parameters)

Resolve<(Of <(TService>)>) Method (serviceName, parameters)
Namespaces ► Autofac ► IContext ► Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService Resolve<TService>(
    string serviceName,
    IEnumerable<Parameter> parameters
)

Function Resolve(Of TService) ( _
    serviceName As String, _
    parameters As IEnumerable(Of Parameter) _
) As TService
generic<typename TService>
TService Resolve(
    String^ serviceName,
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
TService
The type to which the result will be cast.
Parameters
serviceName (String)
Name of the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceType, parameters)

Resolve Method (serviceType, parameters)
Namespaces ► Autofac ► IContext ► Resolve(Type, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    Type serviceType,
    params Parameter[] parameters
)
Function Resolve ( _
    serviceType As Type, _
    ParamArray parameters As Parameter() _
) As Object
Object^ Resolve(
    Type^ serviceType,
    ... array<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


Resolve Method (serviceType, parameters)

Resolve Method (serviceType, parameters)
Namespaces ► Autofac ► IContext ► Resolve(Type, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
Object Resolve(
    Type serviceType,
    IEnumerable<Parameter> parameters
)
Function Resolve ( _
    serviceType As Type, _
    parameters As IEnumerable(Of Parameter) _
) As Object
Object^ Resolve(
    Type^ serviceType,
    IEnumerable<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service.
Exceptions
Exception | Condition
ComponentNotRegisteredException |
DependencyResolutionException |


ResolveOptional Method

ResolveOptional Method
Namespaces ► Autofac ► IContext ► ResolveOptional()()()
Members
Icon | Member | Description
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


ResolveOptional Method (parameters)

ResolveOptional<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► IContext ► ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService ResolveOptional<TService>(
    params Parameter[] parameters
)

Function ResolveOptional(Of TService) ( _
    ParamArray parameters As Parameter() _
) As TService
generic<typename TService>
TService ResolveOptional(
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (array< Parameter >[]()[])
The parameters.
Return Value
The component instance that provides the service, or null if none is available.
Remarks
Useful with the C#3 initialiser syntax.
Examples
container.Register<ISomething>(c => new Something(){ AProperty = c.ResolveOptional<IOptional>() });


ResolveOptional Method (parameters)

ResolveOptional<(Of <(TService>)>) Method (parameters)
Namespaces ► Autofac ► IContext ► ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
TService ResolveOptional<TService>(
    IEnumerable<Parameter> parameters
)

Function ResolveOptional(Of TService) ( _
    parameters As IEnumerable(Of Parameter) _
) As TService
generic<typename TService>
TService ResolveOptional(
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
The component instance that provides the service, or null if none is available.
Remarks
Useful with the C#3 initialiser syntax.
Examples
container.Register<ISomething>(c => new Something(){ AProperty = c.ResolveOptional<IOptional>() });


TryResolve Method

TryResolve Method
Namespaces ► Autofac ► IContext ► TryResolve()()()
Members
Icon | Member | Description
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


TryResolve Method (service, instance, parameters)

TryResolve Method (service, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(Service, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    Service service,
    out Object instance,
    params Parameter[] parameters
)
Function TryResolve ( _
    service As Service, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
bool TryResolve(
    Service^ service,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
service (Service)
The key of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (service, instance, parameters)

TryResolve Method (service, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    Service service,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Function TryResolve ( _
    service As Service, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
bool TryResolve(
    Service^ service,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
)
Parameters
service (Service)
The key of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (componentName, instance, parameters)

TryResolve Method (componentName, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(String, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    string componentName,
    out Object instance,
    params Parameter[] parameters
)
Function TryResolve ( _
    componentName As String, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
bool TryResolve(
    String^ componentName,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
componentName (String)
The name of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (componentName, instance, parameters)

TryResolve Method (componentName, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    string componentName,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Function TryResolve ( _
    componentName As String, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
bool TryResolve(
    String^ componentName,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
)
Parameters
componentName (String)
The name of the component to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (serviceType, instance, parameters)

TryResolve Method (serviceType, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(Type, Object%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    Type serviceType,
    out Object instance,
    params Parameter[] parameters
)
Function TryResolve ( _
    serviceType As Type, _
    <OutAttribute> ByRef instance As Object, _
    ParamArray parameters As Parameter() _
) As Boolean
bool TryResolve(
    Type^ serviceType,
    [OutAttribute] Object^% instance,
    ... array<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (serviceType, instance, parameters)

TryResolve Method (serviceType, instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve(
    Type serviceType,
    out Object instance,
    IEnumerable<Parameter> parameters
)
Function TryResolve ( _
    serviceType As Type, _
    <OutAttribute> ByRef instance As Object, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
bool TryResolve(
    Type^ serviceType,
    [OutAttribute] Object^% instance,
    IEnumerable<Parameter^>^ parameters
)
Parameters
serviceType (Type)
The service to retrieve.
instance ( Object %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (instance, parameters)

TryResolve<(Of <(TService>)>) Method (instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[])
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve<TService>(
    out TService instance,
    params Parameter[] parameters
)

Function TryResolve(Of TService) ( _
    <OutAttribute> ByRef instance As TService, _
    ParamArray parameters As Parameter() _
) As Boolean
generic<typename TService>
bool TryResolve(
    [OutAttribute] TService% instance,
    ... array<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
instance ( TService %)
The component instance that provides the service.
parameters (array< Parameter >[]()[])
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


TryResolve Method (instance, parameters)

TryResolve<(Of <(TService>)>) Method (instance, parameters)
Namespaces ► Autofac ► IContext ► TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>))
Retrieve a service registered with the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryResolve<TService>(
    out TService instance,
    IEnumerable<Parameter> parameters
)

Function TryResolve(Of TService) ( _
    <OutAttribute> ByRef instance As TService, _
    parameters As IEnumerable(Of Parameter) _
) As Boolean
generic<typename TService>
bool TryResolve(
    [OutAttribute] TService% instance,
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
TService
The service to retrieve.
Parameters
instance ( TService %)
The component instance that provides the service.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
Return Value
True if the service was registered and its instance created; false otherwise.
Exceptions
Exception | Condition
DependencyResolutionException |


IDisposer Interface

IDisposer Interface
Namespaces ► Autofac ► IDisposer
Provided on an object that will dispose of other objects when it is itself disposed.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDisposer : IDisposable
Public Interface IDisposer _
    Implements IDisposable
public interface class IDisposer : IDisposable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddInstanceForDisposal(IDisposable) | Adds an object to the disposer. When the disposer is disposed, so will the object be.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)


AddInstanceForDisposal Method (instance)

AddInstanceForDisposal Method (instance)
Namespaces ► Autofac ► IDisposer ► AddInstanceForDisposal(IDisposable)
Adds an object to the disposer. When the disposer is disposed, so will the object be.
Declaration Syntax
C# Visual Basic Visual C++
void AddInstanceForDisposal(
    IDisposable instance
)
Sub AddInstanceForDisposal ( _
    instance As IDisposable _
)
void AddInstanceForDisposal(
    IDisposable^ instance
)
Parameters
instance (IDisposable)
The instance.


IModule Interface

IModule Interface
Namespaces ► Autofac ► IModule
Represents a set of components and related functionality packaged together.
Declaration Syntax
C# Visual Basic Visual C++
public interface IModule
Public Interface IModule
public interface class IModule
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Configure(IContainer) | Apply the module to the container.


Configure Method (container)

Configure Method (container)
Namespaces ► Autofac ► IModule ► Configure(IContainer)
Apply the module to the container.
Declaration Syntax
C# Visual Basic Visual C++
void Configure(
    IContainer container
)
Sub Configure ( _
    container As IContainer _
)
void Configure(
    IContainer^ container
)
Parameters
container (IContainer)
Container to apply configuration to.


InstanceOwnership Enumeration

InstanceOwnership Enumeration
Namespaces ► Autofac ► InstanceOwnership
Determines when instances supporting IDisposable are disposed.
Declaration Syntax
C# Visual Basic Visual C++
public enum InstanceOwnership
Public Enumeration InstanceOwnership
public enum class InstanceOwnership
Members
Member | Description
External | The container/context does not dispose the instances.
Container | The instances are disposed when the container/context is disposed.


InstanceScope Enumeration

InstanceScope Enumeration
Namespaces ► Autofac ► InstanceScope
Determines when instances are created and how they are shared.
Declaration Syntax
C# Visual Basic Visual C++
public enum InstanceScope
Public Enumeration InstanceScope
public enum class InstanceScope
Members
Member | Description
Singleton | Each request for an instance will return the same object, regardless of any subcontexts created.
Container | Each request for an instance in the same container will return the same object.
Factory | Each request for an instance will return a new object.


IRegistrationSource Interface

IRegistrationSource Interface
Namespaces ► Autofac ► IRegistrationSource
Allows registrations to be made on-the-fly when unregistered services are requested (lazy registrations.)
Declaration Syntax
C# Visual Basic Visual C++
public interface IRegistrationSource
Public Interface IRegistrationSource
public interface class IRegistrationSource
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TryGetRegistration(Service, IComponentRegistration%) | Retrieve a registration for an unregistered service, to be used by the container.


TryGetRegistration Method (service, registration)

TryGetRegistration Method (service, registration)
Namespaces ► Autofac ► IRegistrationSource ► TryGetRegistration(Service, IComponentRegistration%)
Retrieve a registration for an unregistered service, to be used by the container.
Declaration Syntax
C# Visual Basic Visual C++
bool TryGetRegistration(
    Service service,
    out IComponentRegistration registration
)
Function TryGetRegistration ( _
    service As Service, _
    <OutAttribute> ByRef registration As IComponentRegistration _
) As Boolean
bool TryGetRegistration(
    Service^ service,
    [OutAttribute] IComponentRegistration^% registration
)
Parameters
service (Service)
The service that was requested.
registration ( IComponentRegistration %)
A registration providing the service.
Return Value
True if the registration could be created.


NamedParameter Class

NamedParameter Class
Namespaces ► Autofac ► NamedParameter
A parameter identified according to its name within an argument list declaration.
Declaration Syntax
C# Visual Basic Visual C++
public class NamedParameter : ConstantParameter
Public Class NamedParameter _
    Inherits ConstantParameter
public ref class NamedParameter : public ConstantParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamedParameter(String, Object) | Create a named parameter with the specified value.
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site. (Inherited from ConstantParameter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion. (Inherited from Parameter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | The name of the parameter.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | The value of the parameter. (Inherited from ConstantParameter.)
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter
 |  |  | NamedParameter


NamedParameter Constructor (name, value)

NamedParameter Constructor (name, value)
Namespaces ► Autofac ► NamedParameter ► NamedParameter(String, Object)
Create a named parameter with the specified value.
Declaration Syntax
C# Visual Basic Visual C++
public NamedParameter(
    string name,
    Object value
)
Public Sub New ( _
    name As String, _
    value As Object _
)
public:
NamedParameter(
    String^ name,
    Object^ value
)
Parameters
name (String)
The name of the parameter.
value (Object)
The parameter value.


Name Property

Name Property
Namespaces ► Autofac ► NamedParameter ► Name
The name of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; private set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NamedPropertyParameter Class

NamedPropertyParameter Class
Namespaces ► Autofac ► NamedPropertyParameter
Injects into properties according to their name. Needs to be reviewed - not sure if it makes sense to have properties and parameters related this way.
Declaration Syntax
C# Visual Basic Visual C++
public class NamedPropertyParameter : ConstantParameter
Public Class NamedPropertyParameter _
    Inherits ConstantParameter
public ref class NamedPropertyParameter : public ConstantParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamedPropertyParameter(String, Object) | Create a named parameter with the specified value.
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site. (Inherited from ConstantParameter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion. (Inherited from Parameter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | The name of the parameter.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | The value of the parameter. (Inherited from ConstantParameter.)
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter
 |  |  | NamedPropertyParameter


NamedPropertyParameter Constructor (name, value)

NamedPropertyParameter Constructor (name, value)
Namespaces ► Autofac ► NamedPropertyParameter ► NamedPropertyParameter(String, Object)
Create a named parameter with the specified value.
Declaration Syntax
C# Visual Basic Visual C++
public NamedPropertyParameter(
    string name,
    Object value
)
Public Sub New ( _
    name As String, _
    value As Object _
)
public:
NamedPropertyParameter(
    String^ name,
    Object^ value
)
Parameters
name (String)
The name of the parameter.
value (Object)
The parameter value.


Name Property

Name Property
Namespaces ► Autofac ► NamedPropertyParameter ► Name
The name of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; private set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NamedService Class

NamedService Class
Namespaces ► Autofac ► NamedService
Identifies a service using a textual name.
Declaration Syntax
C# Visual Basic Visual C++
public class NamedService : Service
Public Class NamedService _
    Inherits Service
public ref class NamedService : public Service
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamedService(String) | Initializes a new instance of the NamedService class.
 | Description | Gets a human-readable description of the service. (Overrides Service.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Service.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Service.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServiceName | Gets or sets the name of the service.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Service.)
Inheritance Hierarchy
Object
 | Service
 |  | NamedService


NamedService Constructor (serviceName)

NamedService Constructor (serviceName)
Namespaces ► Autofac ► NamedService ► NamedService(String)
Initializes a new instance of the NamedService class.
Declaration Syntax
C# Visual Basic Visual C++
public NamedService(
    string serviceName
)
Public Sub New ( _
    serviceName As String _
)
public:
NamedService(
    String^ serviceName
)
Parameters
serviceName (String)
Name of the service.


Description Property

Description Property
Namespaces ► Autofac ► NamedService ► Description
Gets a human-readable description of the service.
Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}
Value
The description.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Autofac ► NamedService ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


GetHashCode Method

GetHashCode Method
Namespaces ► Autofac ► NamedService ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the current Object.


ServiceName Property

ServiceName Property
Namespaces ► Autofac ► NamedService ► ServiceName
Gets or sets the name of the service.
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; private set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the service.


Parameter Class

Parameter Class
Namespaces ► Autofac ► Parameter
Used in order to provide a value to a constructor parameter or property on an instance being created by the container.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Parameter
Public MustInherit Class Parameter
public ref class Parameter abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Parameter()()() | Initializes a new instance of the Parameter class
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Not all parameters can be applied to all sites.
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter


Parameter Constructor

Parameter Constructor
Namespaces ► Autofac ► Parameter ► Parameter()()()
Initializes a new instance of the Parameter class
Declaration Syntax
C# Visual Basic Visual C++
protected Parameter()
Protected Sub New
protected:
Parameter()


CanSupplyValue Method (pi, context, valueProvider)

CanSupplyValue Method (pi, context, valueProvider)
Namespaces ► Autofac ► Parameter ► CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%)
Returns true if the parameter is able to provide a value to a particular site.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool CanSupplyValue(
    ParameterInfo pi,
    IContext context,
    out Func<Object> valueProvider
)
Public MustOverride Function CanSupplyValue ( _
    pi As ParameterInfo, _
    context As IContext, _
    <OutAttribute> ByRef valueProvider As Func(Of Object) _
) As Boolean
public:
virtual bool CanSupplyValue(
    ParameterInfo^ pi,
    IContext^ context,
    [OutAttribute] Func<Object^>^% valueProvider
) abstract
Parameters
pi (ParameterInfo)
Constructor, method, or property-mutator parameter.
context (IContext)
The component context in which the value is being provided.
valueProvider ( Func <(Of <( Object >)>) %)
If the result is true, the valueProvider parameter will be set to a function that will lazily retrieve the parameter value. If the result is false, will be set to null.
Return Value
True if a value can be supplied; otherwise, false.


MatchTypes Method (pi, parameterValue)

MatchTypes Method (pi, parameterValue)
Namespaces ► Autofac ► Parameter ► MatchTypes(ParameterInfo, Object)
Helper method for parameters that allow type conversion.
Declaration Syntax
C# Visual Basic Visual C++
protected Object MatchTypes(
    ParameterInfo pi,
    Object parameterValue
)
Protected Function MatchTypes ( _
    pi As ParameterInfo, _
    parameterValue As Object _
) As Object
protected:
Object^ MatchTypes(
    ParameterInfo^ pi,
    Object^ parameterValue
)
Parameters
pi (ParameterInfo)
The parameter.
parameterValue (Object)
The value.
Return Value
A representation of the value able to be supplied for the parameter.


ParameterExtensions Class

ParameterExtensions Class
Namespaces ► Autofac ► ParameterExtensions
Extension methods that ease the extraction of particluar kinds of parameter values from an enumerable sequence of the Parameter abstract type. Each method returns the first matching parameter value, or throws an exception if none is provided.
Declaration Syntax
C# Visual Basic Visual C++
public static class ParameterExtensions
Public NotInheritable Class ParameterExtensions
public ref class ParameterExtensions abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Named<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>), String) | Retrieve a parameter value from a NamedParameter instance.
 | Positional<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>), Int32) | Retrieve a parameter value from a PositionalParameter instance.
 | TypedAs<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a parameter value from a TypedParameter instance.
Inheritance Hierarchy
Object
ParameterExtensions


Named Method (parameters, name)

Named<(Of <(T>)>) Method (parameters, name)
Namespaces ► Autofac ► ParameterExtensions ► Named<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>), String)
Retrieve a parameter value from a NamedParameter instance.
Declaration Syntax
C# Visual Basic Visual C++
public static T Named<T>(
    IEnumerable<Parameter> parameters,
    string name
)

Public Shared Function Named(Of T) ( _
    parameters As IEnumerable(Of Parameter), _
    name As String _
) As T
public:
generic<typename T>
static T Named(
    IEnumerable<Parameter^>^ parameters,
    String^ name
)
Generic Template Parameters
T
The type to which the returned value will be cast.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))
The available parameters to choose from.
name (String)
The name of the parameter to select.
Return Value
The value of the selected parameter.


Positional Method (parameters, position)

Positional<(Of <(T>)>) Method (parameters, position)
Namespaces ► Autofac ► ParameterExtensions ► Positional<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>), Int32)
Retrieve a parameter value from a PositionalParameter instance.
Declaration Syntax
C# Visual Basic Visual C++
public static T Positional<T>(
    IEnumerable<Parameter> parameters,
    int position
)

Public Shared Function Positional(Of T) ( _
    parameters As IEnumerable(Of Parameter), _
    position As Integer _
) As T
public:
generic<typename T>
static T Positional(
    IEnumerable<Parameter^>^ parameters,
    int position
)
Generic Template Parameters
T
The type to which the returned value will be cast.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))
The available parameters to choose from.
position (Int32)
The zero-based position of the parameter to select.
Return Value
The value of the selected parameter.


TypedAs Method (parameters)

TypedAs<(Of <(T>)>) Method (parameters)
Namespaces ► Autofac ► ParameterExtensions ► TypedAs<(Of <(T>)>)(IEnumerable<(Of <(Parameter>)>))
Retrieve a parameter value from a TypedParameter instance.
Declaration Syntax
C# Visual Basic Visual C++
public static T TypedAs<T>(
    IEnumerable<Parameter> parameters
)

Public Shared Function TypedAs(Of T) ( _
    parameters As IEnumerable(Of Parameter) _
) As T
public:
generic<typename T>
static T TypedAs(
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
T
The type to which the returned value will be cast.
Parameters
parameters (IEnumerable <(Of <( Parameter >)>))
The available parameters to choose from.
Return Value
The value of the selected parameter.


PositionalParameter Class

PositionalParameter Class
Namespaces ► Autofac ► PositionalParameter
A parameter that is identified according to an integer representing its position in an argument list.
Declaration Syntax
C# Visual Basic Visual C++
public class PositionalParameter : ConstantParameter
Public Class PositionalParameter _
    Inherits ConstantParameter
public ref class PositionalParameter : public ConstantParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PositionalParameter(Int32, Object) | Construct a positional parameter with the specified value.
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site. (Inherited from ConstantParameter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion. (Inherited from Parameter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The zero-based position of the parameter.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | The value of the parameter. (Inherited from ConstantParameter.)
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter
 |  |  | PositionalParameter


PositionalParameter Constructor (position, value)

PositionalParameter Constructor (position, value)
Namespaces ► Autofac ► PositionalParameter ► PositionalParameter(Int32, Object)
Construct a positional parameter with the specified value.
Declaration Syntax
C# Visual Basic Visual C++
public PositionalParameter(
    int position,
    Object value
)
Public Sub New ( _
    position As Integer, _
    value As Object _
)
public:
PositionalParameter(
    int position,
    Object^ value
)
Parameters
position (Int32)
The zero-based position of the parameter.
value (Object)
The parameter value.


Position Property

Position Property
Namespaces ► Autofac ► PositionalParameter ► Position
The zero-based position of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; private set; }
Public Property Position As Integer
public:
property int Position {
    int get ();
    void set (int value);
}


PreparingEventArgs Class

PreparingEventArgs Class
Namespaces ► Autofac ► PreparingEventArgs
Fired before the activation process to allow parameters to be changed or an alternative instance to be provided.
Declaration Syntax
C# Visual Basic Visual C++
public class PreparingEventArgs : EventArgs
Public Class PreparingEventArgs _
    Inherits EventArgs
public ref class PreparingEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreparingEventArgs(IContext, IComponentRegistration, IEnumerable<(Of <(Parameter>)>)) | Initializes a new instance of the ActivatingEventArgs class.
 | Component | The component providing the instance being activated.
 | Context | The context in which the activation is occurring.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | An instance can be supplied in order to avoid using the regular activator.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | The parameters supplied to the activator.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PreparingEventArgs


PreparingEventArgs Constructor (context, component, parameters)

PreparingEventArgs Constructor (context, component, parameters)
Namespaces ► Autofac ► PreparingEventArgs ► PreparingEventArgs(IContext, IComponentRegistration, IEnumerable<(Of <(Parameter>)>))
Initializes a new instance of the ActivatingEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public PreparingEventArgs(
    IContext context,
    IComponentRegistration component,
    IEnumerable<Parameter> parameters
)
Public Sub New ( _
    context As IContext, _
    component As IComponentRegistration, _
    parameters As IEnumerable(Of Parameter) _
)
public:
PreparingEventArgs(
    IContext^ context,
    IComponentRegistration^ component,
    IEnumerable<Parameter^>^ parameters
)
Parameters
context (IContext)
The context.
component (IComponentRegistration)
The component.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.


Component Property

Component Property
Namespaces ► Autofac ► PreparingEventArgs ► Component
The component providing the instance being activated.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentRegistration Component { get; private set; }
Public Property Component As IComponentRegistration
public:
property IComponentRegistration^ Component {
    IComponentRegistration^ get ();
    void set (IComponentRegistration^ value);
}


Context Property

Context Property
Namespaces ► Autofac ► PreparingEventArgs ► Context
The context in which the activation is occurring.
Declaration Syntax
C# Visual Basic Visual C++
public IContext Context { get; private set; }
Public Property Context As IContext
public:
property IContext^ Context {
    IContext^ get ();
    void set (IContext^ value);
}


Instance Property

Instance Property
Namespaces ► Autofac ► PreparingEventArgs ► Instance
An instance can be supplied in order to avoid using the regular activator.
Declaration Syntax
C# Visual Basic Visual C++
public Object Instance { get; set; }
Public Property Instance As Object
public:
property Object^ Instance {
    Object^ get ();
    void set (Object^ value);
}


Parameters Property

Parameters Property
Namespaces ► Autofac ► PreparingEventArgs ► Parameters
The parameters supplied to the activator.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<Parameter> Parameters { get; set; }
Public Property Parameters As IEnumerable(Of Parameter)
public:
property IEnumerable<Parameter^>^ Parameters {
    IEnumerable<Parameter^>^ get ();
    void set (IEnumerable<Parameter^>^ value);
}


Service Class

Service Class
Namespaces ► Autofac ► Service
Services are the lookup keys used to locate component instances.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Service
Public MustInherit Class Service
public ref class Service abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Service()()() | Initializes a new instance of the Service class
 | Description | Gets a human-readable description of the service.
 | Equality(Service, Service) | Implements the operator ==.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(Service, Service) | Implements the operator !=.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | Service
 |  | NamedService
 |  | TypedService
 |  | UniqueService


Service Constructor

Service Constructor
Namespaces ► Autofac ► Service ► Service()()()
Initializes a new instance of the Service class
Declaration Syntax
C# Visual Basic Visual C++
protected Service()
Protected Sub New
protected:
Service()


Description Property

Description Property
Namespaces ► Autofac ► Service ► Description
Gets a human-readable description of the service.
Declaration Syntax
C# Visual Basic Visual C++
public abstract string Description { get; }
Public MustOverride ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () abstract;
}
Value
The description.


Equality Operator

Equality Operator
Namespaces ► Autofac ► Service ► Equality(Service, Service)
Implements the operator ==.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Service lhs,
    Service rhs
)
Public Shared Operator = ( _
    lhs As Service, _
    rhs As Service _
) As Boolean
public:
static bool operator ==(
    Service^ lhs,
    Service^ rhs
)
Parameters
lhs (Service)
The LHS.
rhs (Service)
The RHS.
Return Value
The result of the operator.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Autofac ► Service ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


GetHashCode Method

GetHashCode Method
Namespaces ► Autofac ► Service ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the current Object.


Inequality Operator

Inequality Operator
Namespaces ► Autofac ► Service ► Inequality(Service, Service)
Implements the operator !=.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Service lhs,
    Service rhs
)
Public Shared Operator <> ( _
    lhs As Service, _
    rhs As Service _
) As Boolean
public:
static bool operator !=(
    Service^ lhs,
    Service^ rhs
)
Parameters
lhs (Service)
The LHS.
rhs (Service)
The RHS.
Return Value
The result of the operator.


ToString Method

ToString Method
Namespaces ► Autofac ► Service ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


TypedParameter Class

TypedParameter Class
Namespaces ► Autofac ► TypedParameter
A parameter that can supply values to sites that exactly match a specified type.
Declaration Syntax
C# Visual Basic Visual C++
public class TypedParameter : ConstantParameter
Public Class TypedParameter _
    Inherits ConstantParameter
public ref class TypedParameter : public ConstantParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypedParameter(Type, Object) | Create a typed parameter for the specified type.
 | CanSupplyValue(ParameterInfo, IContext, Func<(Of <(Object>)>)%) | Returns true if the parameter is able to provide a value to a particular site. (Inherited from ConstantParameter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | From<(Of <(T>)>)(T) | Shortcut for creating TypedParameter by using the T
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchTypes(ParameterInfo, Object) | Helper method for parameters that allow type conversion. (Inherited from Parameter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | The type against which sites are matched.
 | Value | The value of the parameter. (Inherited from ConstantParameter.)
Inheritance Hierarchy
Object
 | Parameter
 |  | ConstantParameter
 |  |  | TypedParameter


TypedParameter Constructor (type, value)

TypedParameter Constructor (type, value)
Namespaces ► Autofac ► TypedParameter ► TypedParameter(Type, Object)
Create a typed parameter for the specified type.
Declaration Syntax
C# Visual Basic Visual C++
public TypedParameter(
    Type type,
    Object value
)
Public Sub New ( _
    type As Type, _
    value As Object _
)
public:
TypedParameter(
    Type^ type,
    Object^ value
)
Parameters
type (Type)
The exact type to match.
value (Object)
The parameter value.


From Method (value)

From<(Of <(T>)>) Method (value)
Namespaces ► Autofac ► TypedParameter ► From<(Of <(T>)>)(T)
Shortcut for creating TypedParameter by using the T
Declaration Syntax
C# Visual Basic Visual C++
public static TypedParameter From<T>(
    T value
)

Public Shared Function From(Of T) ( _
    value As T _
) As TypedParameter
public:
generic<typename T>
static TypedParameter^ From(
    T value
)
Generic Template Parameters
T
type to be used for the parameter
Parameters
value (T)
The parameter value.
Return Value
new typed parameter


Type Property

Type Property
Namespaces ► Autofac ► TypedParameter ► Type
The type against which sites are matched.
Declaration Syntax
C# Visual Basic Visual C++
public Type Type { get; private set; }
Public Property Type As Type
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}


TypedService Class

TypedService Class
Namespaces ► Autofac ► TypedService
Identifies a service according to a type to which it can be assigned.
Declaration Syntax
C# Visual Basic Visual C++
public class TypedService : Service
Public Class TypedService _
    Inherits Service
public ref class TypedService : public Service
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypedService(Type) | Initializes a new instance of the TypedService class.
 | Description | Gets a human-readable description of the service. (Overrides Service.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Service.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Service.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServiceType | Gets or sets the type of the service.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Service.)
Inheritance Hierarchy
Object
 | Service
 |  | TypedService


TypedService Constructor (serviceType)

TypedService Constructor (serviceType)
Namespaces ► Autofac ► TypedService ► TypedService(Type)
Initializes a new instance of the TypedService class.
Declaration Syntax
C# Visual Basic Visual C++
public TypedService(
    Type serviceType
)
Public Sub New ( _
    serviceType As Type _
)
public:
TypedService(
    Type^ serviceType
)
Parameters
serviceType (Type)
Type of the service.


Description Property

Description Property
Namespaces ► Autofac ► TypedService ► Description
Gets a human-readable description of the service.
Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}
Value
The description.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Autofac ► TypedService ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


GetHashCode Method

GetHashCode Method
Namespaces ► Autofac ► TypedService ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the current Object.


ServiceType Property

ServiceType Property
Namespaces ► Autofac ► TypedService ► ServiceType
Gets or sets the type of the service.
Declaration Syntax
C# Visual Basic Visual C++
public Type ServiceType { get; private set; }
Public Property ServiceType As Type
public:
property Type^ ServiceType {
    Type^ get ();
    void set (Type^ value);
}
Value
The type of the service.


UniqueService Class

UniqueService Class
Namespaces ► Autofac ► UniqueService
A handy unique service identifier type - all instances will be regarded as unequal.
Declaration Syntax
C# Visual Basic Visual C++
public class UniqueService : Service
Public Class UniqueService _
    Inherits Service
public ref class UniqueService : public Service
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UniqueService()()() | Initializes a new instance of the UniqueService class
 | Description | Provides a programmer-readable description of the identifying feature of the service. (Overrides Service.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Service.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Service.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Service.)
Inheritance Hierarchy
Object
 | Service
 |  | UniqueService


UniqueService Constructor

UniqueService Constructor
Namespaces ► Autofac ► UniqueService ► UniqueService()()()
Initializes a new instance of the UniqueService class
Declaration Syntax
C# Visual Basic Visual C++
public UniqueService()
Public Sub New
public:
UniqueService()


Description Property

Description Property
Namespaces ► Autofac ► UniqueService ► Description
Provides a programmer-readable description of the identifying feature of the service.
Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}
Value


Equals Method (obj)

Equals Method (obj)
Namespaces ► Autofac ► UniqueService ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


GetHashCode Method

GetHashCode Method
Namespaces ► Autofac ► UniqueService ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the current Object.


Autofac.Builder Namespace

Autofac.Builder Namespace
Namespaces ► Autofac.Builder
ContainerBuilder and related extension methods/registrars.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Builder
Namespace Autofac.Builder
namespace Autofac.Builder
Types
All Types Classes
Icon | Type | Description
 | ActivatedHandler | Utilities to handle common activation scenarios
 | ActivatingHandler | Utilities to handle common activation scenarios
 | ContainerBuilder | Used to incrementally build component registrations.
 | GeneratedFactoryExtensions | Extends ContainerBuilder with methods for registering generated factories.
 | Module | Base class for user-defined modules. Implements IModule on top of ContainerBuilder.


ActivatedHandler Class

ActivatedHandler Class
Namespaces ► Autofac.Builder ► ActivatedHandler
Utilities to handle common activation scenarios
Declaration Syntax
C# Visual Basic Visual C++
public static class ActivatedHandler
Public NotInheritable Class ActivatedHandler
public ref class ActivatedHandler abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InjectProperties(Object, ActivatedEventArgs) | Inject properties from the context into the newly activated instance.
 | InjectUnsetProperties(Object, ActivatedEventArgs) | Inject properties from the context into the newly activated instance unless they're non null on the instance.
Inheritance Hierarchy
Object
ActivatedHandler


InjectProperties Method (sender, e)

InjectProperties Method (sender, e)
Namespaces ► Autofac.Builder ► ActivatedHandler ► InjectProperties(Object, ActivatedEventArgs)
Inject properties from the context into the newly activated instance.
Declaration Syntax
C# Visual Basic Visual C++
public static void InjectProperties(
    Object sender,
    ActivatedEventArgs e
)
Public Shared Sub InjectProperties ( _
    sender As Object, _
    e As ActivatedEventArgs _
)
public:
static void InjectProperties(
    Object^ sender,
    ActivatedEventArgs^ e
)
Parameters
sender (Object)
The sender.
e (ActivatedEventArgs)
The ActivatingEventArgs instance containing the event data.


InjectUnsetProperties Method (sender, e)

InjectUnsetProperties Method (sender, e)
Namespaces ► Autofac.Builder ► ActivatedHandler ► InjectUnsetProperties(Object, ActivatedEventArgs)
Inject properties from the context into the newly activated instance unless they're non null on the instance.
Declaration Syntax
C# Visual Basic Visual C++
public static void InjectUnsetProperties(
    Object sender,
    ActivatedEventArgs e
)
Public Shared Sub InjectUnsetProperties ( _
    sender As Object, _
    e As ActivatedEventArgs _
)
public:
static void InjectUnsetProperties(
    Object^ sender,
    ActivatedEventArgs^ e
)
Parameters
sender (Object)
The sender.
e (ActivatedEventArgs)
The ActivatingEventArgs instance containing the event data.


ActivatingHandler Class

ActivatingHandler Class
Namespaces ► Autofac.Builder ► ActivatingHandler
Utilities to handle common activation scenarios
Declaration Syntax
C# Visual Basic Visual C++
public static class ActivatingHandler
Public NotInheritable Class ActivatingHandler
public ref class ActivatingHandler abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InjectProperties(Object, ActivatingEventArgs) | Inject properties from the context into the newly activated instance.
 | InjectUnsetProperties(Object, ActivatingEventArgs) | Inject properties from the context into the newly activated instance unless they're non null on the instance.
Inheritance Hierarchy
Object
ActivatingHandler


InjectProperties Method (sender, e)

InjectProperties Method (sender, e)
Namespaces ► Autofac.Builder ► ActivatingHandler ► InjectProperties(Object, ActivatingEventArgs)
Inject properties from the context into the newly activated instance.
Declaration Syntax
C# Visual Basic Visual C++
public static void InjectProperties(
    Object sender,
    ActivatingEventArgs e
)
Public Shared Sub InjectProperties ( _
    sender As Object, _
    e As ActivatingEventArgs _
)
public:
static void InjectProperties(
    Object^ sender,
    ActivatingEventArgs^ e
)
Parameters
sender (Object)
The sender.
e (ActivatingEventArgs)
The ActivatingEventArgs instance containing the event data.


InjectUnsetProperties Method (sender, e)

InjectUnsetProperties Method (sender, e)
Namespaces ► Autofac.Builder ► ActivatingHandler ► InjectUnsetProperties(Object, ActivatingEventArgs)
Inject properties from the context into the newly activated instance unless they're non null on the instance.
Declaration Syntax
C# Visual Basic Visual C++
public static void InjectUnsetProperties(
    Object sender,
    ActivatingEventArgs e
)
Public Shared Sub InjectUnsetProperties ( _
    sender As Object, _
    e As ActivatingEventArgs _
)
public:
static void InjectUnsetProperties(
    Object^ sender,
    ActivatingEventArgs^ e
)
Parameters
sender (Object)
The sender.
e (ActivatingEventArgs)
The ActivatingEventArgs instance containing the event data.


ContainerBuilder Class

ContainerBuilder Class
Namespaces ► Autofac.Builder ► ContainerBuilder
Used to incrementally build component registrations.
Declaration Syntax
C# Visual Basic Visual C++
public class ContainerBuilder
Public Class ContainerBuilder
public ref class ContainerBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
ContainerBuilder()()()
Initializes a new instance of the ContainerBuilder class

Build()()()
Create a new container with the registrations that have been built so far.

Build(IContainer)
Configure an existing container with the registrations that have been built so far.

DefaultOwnership
The default InstanceOwnership for new registrations.

DefaultScope
The default InstanceScope for new registrations.

Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()()()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode()()()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()()()
Gets the Type of the current instance.
(Inherited from Object.)
MemberwiseClone()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Register<(Of <(T>)>)()()()
Register a component to be created through reflection.

Register(Type)
Register a component to be created through reflection.

Register<(Of <(T>)>)(ComponentActivator<(Of <(T>)>))
Register a component that will be created using a provided delegate.

Register<(Of <(T>)>)(ComponentActivatorWithParameters<(Of <(T>)>))
Register a component that will be created using a provided delegate.

Register<(Of <(T>)>)(T)
Register a component using a provided instance.

RegisterCollection<(Of <(T>)>)()()()
Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();

RegisterCollection(Type)
Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();

RegisterComponent(IComponentRegistration)
Register a component using a component registration.

RegisterGeneric(Type)
Register an un-parameterised generic type, e.g.
CopyC#
Repository<>
. Concrete types will be made as they are requested, e.g. with
CopyC#
Resolve<Repository<int>>()
.

RegisterModule(IModule)
Add a module to the container.

RegisterTypesAssignableTo<(Of <(T>)>)()()()
Registers the types assignable to.

RegisterTypesFromAssembly(Assembly)
Registers the types from assembly.

RegisterTypesMatching(Predicate<(Of <(Type>)>))
Registers the types matching.

SetDefaultOwnership(InstanceOwnership)
Set the default InstanceOwnership for new registrations. Registrations already made will not be affected by changes in this value.

SetDefaultScope(InstanceScope)
Set the default InstanceScope for new registrations. Registrations already made will not be affected by changes in this value.

ToString()()()
Returns a String that represents the current Object.
(Inherited from Object.)
Inheritance Hierarchy
Object
ContainerBuilder


ContainerBuilder Constructor

ContainerBuilder Constructor
Namespaces ► Autofac.Builder ► ContainerBuilder ► ContainerBuilder()()()
Initializes a new instance of the ContainerBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ContainerBuilder()
Public Sub New
public:
ContainerBuilder()


Build Method

Build Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► Build()()()
Members
Icon | Member | Description
 | Build()()() | Create a new container with the registrations that have been built so far.
 | Build(IContainer) | Configure an existing container with the registrations that have been built so far.


Build Method

Build Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► Build()()()
Create a new container with the registrations that have been built so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IContainer Build()
Public Overridable Function Build As IContainer
public:
virtual IContainer^ Build()
Return Value
A new container with the registrations made.
Remarks
Build can only be called once per ContainerBuilder - this prevents lifecycle issues for provided instances.


Build Method (container)

Build Method (container)
Namespaces ► Autofac.Builder ► ContainerBuilder ► Build(IContainer)
Configure an existing container with the registrations that have been built so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Build(
    IContainer container
)
Public Overridable Sub Build ( _
    container As IContainer _
)
public:
virtual void Build(
    IContainer^ container
)
Parameters
container (IContainer)
An existing container to make the registrations in.
Remarks
Build can only be called once per ContainerBuilder - this prevents lifecycle issues for provided instances.


DefaultOwnership Property

DefaultOwnership Property
Namespaces ► Autofac.Builder ► ContainerBuilder ► DefaultOwnership
The default InstanceOwnership for new registrations.
Declaration Syntax
C# Visual Basic Visual C++
public virtual InstanceOwnership DefaultOwnership { get; }
Public Overridable ReadOnly Property DefaultOwnership As InstanceOwnership
public:
virtual property InstanceOwnership DefaultOwnership {
    InstanceOwnership get ();
}


DefaultScope Property

DefaultScope Property
Namespaces ► Autofac.Builder ► ContainerBuilder ► DefaultScope
The default InstanceScope for new registrations.
Declaration Syntax
C# Visual Basic Visual C++
public virtual InstanceScope DefaultScope { get; }
Public Overridable ReadOnly Property DefaultScope As InstanceScope
public:
virtual property InstanceScope DefaultScope {
    InstanceScope get ();
}


Register Method

Register Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register()()()
Members
Icon | Member | Description
 | Register<(Of <(T>)>)()()() | Register a component to be created through reflection.
 | Register(Type) | Register a component to be created through reflection.
 | Register<(Of <(T>)>)(ComponentActivator<(Of <(T>)>)) | Register a component that will be created using a provided delegate.
 | Register<(Of <(T>)>)(ComponentActivatorWithParameters<(Of <(T>)>)) | Register a component that will be created using a provided delegate.
 | Register<(Of <(T>)>)(T) | Register a component using a provided instance.


Register Method

Register<(Of <(T>)>) Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register<(Of <(T>)>)()()()
Register a component to be created through reflection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IReflectiveRegistrar Register<T>()

Public Overridable Function Register(Of T) As IReflectiveRegistrar
public:
generic<typename T>
virtual IReflectiveRegistrar^ Register()
Generic Template Parameters
T
The type of the component.
Return Value
A registrar allowing details of the registration to be customised.


Register Method (creator)

Register<(Of <(T>)>) Method (creator)
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register<(Of <(T>)>)(ComponentActivator<(Of <(T>)>))
Register a component that will be created using a provided delegate.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConcreteRegistrar Register<T>(
    ComponentActivator<T> creator
)

Public Overridable Function Register(Of T) ( _
    creator As ComponentActivator(Of T) _
) As IConcreteRegistrar
public:
generic<typename T>
virtual IConcreteRegistrar^ Register(
    ComponentActivator<T>^ creator
)
Generic Template Parameters
T
The type of the component.
Parameters
creator (ComponentActivator <(Of <(T>)>))
The creator.
Return Value
A registrar allowing details of the registration to be customised.


Register Method (creator)

Register<(Of <(T>)>) Method (creator)
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register<(Of <(T>)>)(ComponentActivatorWithParameters<(Of <(T>)>))
Register a component that will be created using a provided delegate.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConcreteRegistrar Register<T>(
    ComponentActivatorWithParameters<T> creator
)

Public Overridable Function Register(Of T) ( _
    creator As ComponentActivatorWithParameters(Of T) _
) As IConcreteRegistrar
public:
generic<typename T>
virtual IConcreteRegistrar^ Register(
    ComponentActivatorWithParameters<T>^ creator
)
Generic Template Parameters
T
The type of the component.
Parameters
creator (ComponentActivatorWithParameters <(Of <(T>)>))
The creator.
Return Value
A registrar allowing details of the registration to be customised.


Register Method (implementor)

Register Method (implementor)
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register(Type)
Register a component to be created through reflection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IReflectiveRegistrar Register(
    Type implementor
)
Public Overridable Function Register ( _
    implementor As Type _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ Register(
    Type^ implementor
)
Parameters
implementor (Type)
The type of the component.
Return Value
A registrar allowing details of the registration to be customised.


Register Method (instance)

Register<(Of <(T>)>) Method (instance)
Namespaces ► Autofac.Builder ► ContainerBuilder ► Register<(Of <(T>)>)(T)
Register a component using a provided instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConcreteRegistrar Register<T>(
    T instance
)

Public Overridable Function Register(Of T) ( _
    instance As T _
) As IConcreteRegistrar
public:
generic<typename T>
virtual IConcreteRegistrar^ Register(
    T instance
)
Generic Template Parameters
T
The type of the component.
Parameters
instance (T)
The instance.
Return Value
A registrar allowing details of the registration to be customised.


RegisterCollection Method

RegisterCollection Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterCollection()()()
Members
Icon | Member | Description
 | RegisterCollection<(Of <(T>)>)()()() | Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();
 | RegisterCollection(Type) | Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();


RegisterCollection Method

RegisterCollection<(Of <(T>)>) Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterCollection<(Of <(T>)>)()()()
Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConcreteRegistrar RegisterCollection<T>()

Public Overridable Function RegisterCollection(Of T) As IConcreteRegistrar
public:
generic<typename T>
virtual IConcreteRegistrar^ RegisterCollection()
Generic Template Parameters
T
Collection item type
Return Value
A registrar allowing configuration to continue.


RegisterCollection Method (collectionType)

RegisterCollection Method (collectionType)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterCollection(Type)
Registers the type as a collection. If no services or names are specified, the default service will be IEnumerable<T>();
Declaration Syntax
C# Visual Basic Visual C++
public virtual IConcreteRegistrar RegisterCollection(
    Type collectionType
)
Public Overridable Function RegisterCollection ( _
    collectionType As Type _
) As IConcreteRegistrar
public:
virtual IConcreteRegistrar^ RegisterCollection(
    Type^ collectionType
)
Parameters
collectionType (Type)
Collection item type
Return Value
A registrar allowing configuration to continue.


RegisterComponent Method (registration)

RegisterComponent Method (registration)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterComponent(IComponentRegistration)
Register a component using a component registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RegisterComponent(
    IComponentRegistration registration
)
Public Overridable Sub RegisterComponent ( _
    registration As IComponentRegistration _
)
public:
virtual void RegisterComponent(
    IComponentRegistration^ registration
)
Parameters
registration (IComponentRegistration)

[Missing <param name="registration"/> documentation for "M:Autofac.Builder.ContainerBuilder.RegisterComponent(Autofac.IComponentRegistration)"]


RegisterGeneric Method (implementor)

RegisterGeneric Method (implementor)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterGeneric(Type)
Register an un-parameterised generic type, e.g.
CopyC#
Repository<>
. Concrete types will be made as they are requested, e.g. with
CopyC#
Resolve<Repository<int>>()
.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar RegisterGeneric(
    Type implementor
)
Public Overridable Function RegisterGeneric ( _
    implementor As Type _
) As IGenericRegistrar
public:
virtual IGenericRegistrar^ RegisterGeneric(
    Type^ implementor
)
Parameters
implementor (Type)
The implementor.
Return Value
A registrar allowing configuration to continue.


RegisterModule Method (module)

RegisterModule Method (module)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterModule(IModule)
Add a module to the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RegisterModule(
    IModule module
)
Public Overridable Sub RegisterModule ( _
    module As IModule _
)
public:
virtual void RegisterModule(
    IModule^ module
)
Parameters
module (IModule)
The module to add.


RegisterTypesAssignableTo Method

RegisterTypesAssignableTo<(Of <(T>)>) Method
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterTypesAssignableTo<(Of <(T>)>)()()()
Registers the types assignable to.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar RegisterTypesAssignableTo<T>()

Public Overridable Function RegisterTypesAssignableTo(Of T) As IGenericRegistrar
public:
generic<typename T>
virtual IGenericRegistrar^ RegisterTypesAssignableTo()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Autofac.Builder.ContainerBuilder.RegisterTypesAssignableTo``1"]

Return Value
A registrar allowing configuration to continue.


RegisterTypesFromAssembly Method (assembly)

RegisterTypesFromAssembly Method (assembly)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterTypesFromAssembly(Assembly)
Registers the types from assembly.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar RegisterTypesFromAssembly(
    Assembly assembly
)
Public Overridable Function RegisterTypesFromAssembly ( _
    assembly As Assembly _
) As IGenericRegistrar
public:
virtual IGenericRegistrar^ RegisterTypesFromAssembly(
    Assembly^ assembly
)
Parameters
assembly (Assembly)
The assembly.
Return Value
A registrar allowing configuration to continue.


RegisterTypesMatching Method (predicate)

RegisterTypesMatching Method (predicate)
Namespaces ► Autofac.Builder ► ContainerBuilder ► RegisterTypesMatching(Predicate<(Of <(Type>)>))
Registers the types matching.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar RegisterTypesMatching(
    Predicate<Type> predicate
)
Public Overridable Function RegisterTypesMatching ( _
    predicate As Predicate(Of Type) _
) As IGenericRegistrar
public:
virtual IGenericRegistrar^ RegisterTypesMatching(
    Predicate<Type^>^ predicate
)
Parameters
predicate (Predicate <(Of <( Type >)>))
The predicate.
Return Value
A registrar allowing configuration to continue.


SetDefaultOwnership Method (ownership)

SetDefaultOwnership Method (ownership)
Namespaces ► Autofac.Builder ► ContainerBuilder ► SetDefaultOwnership(InstanceOwnership)
Set the default InstanceOwnership for new registrations. Registrations already made will not be affected by changes in this value.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDisposable SetDefaultOwnership(
    InstanceOwnership ownership
)
Public Overridable Function SetDefaultOwnership ( _
    ownership As InstanceOwnership _
) As IDisposable
public:
virtual IDisposable^ SetDefaultOwnership(
    InstanceOwnership ownership
)
Parameters
ownership (InstanceOwnership)
The new default ownership.
Return Value
An object that when disposed, will restore the original default ownership.


SetDefaultScope Method (scope)

SetDefaultScope Method (scope)
Namespaces ► Autofac.Builder ► ContainerBuilder ► SetDefaultScope(InstanceScope)
Set the default InstanceScope for new registrations. Registrations already made will not be affected by changes in this value.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDisposable SetDefaultScope(
    InstanceScope scope
)
Public Overridable Function SetDefaultScope ( _
    scope As InstanceScope _
) As IDisposable
public:
virtual IDisposable^ SetDefaultScope(
    InstanceScope scope
)
Parameters
scope (InstanceScope)

[Missing <param name="scope"/> documentation for "M:Autofac.Builder.ContainerBuilder.SetDefaultScope(Autofac.InstanceScope)"]

Return Value
An object that when disposed, will restore the original default scope.


GeneratedFactoryExtensions Class

GeneratedFactoryExtensions Class
Namespaces ► Autofac.Builder ► GeneratedFactoryExtensions
Extends ContainerBuilder with methods for registering generated factories.
Declaration Syntax
C# Visual Basic Visual C++
public static class GeneratedFactoryExtensions
Public NotInheritable Class GeneratedFactoryExtensions
public ref class GeneratedFactoryExtensions abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder, Service) | Registers the factory delegate.
 | RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder) | Registers the factory delegate.
Remarks
This file is excluded from the .NET 2.0 build.
Inheritance Hierarchy
Object
GeneratedFactoryExtensions


RegisterGeneratedFactory Method

RegisterGeneratedFactory Method
Namespaces ► Autofac.Builder ► GeneratedFactoryExtensions ► RegisterGeneratedFactory()()()
Members
Icon | Member | Description
 | RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder, Service) | Registers the factory delegate.
 | RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder) | Registers the factory delegate.


RegisterGeneratedFactory Method (builder)

RegisterGeneratedFactory<(Of <(TDelegate>)>) Method (builder)
Namespaces ► Autofac.Builder ► GeneratedFactoryExtensions ► RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder)
Registers the factory delegate.
Declaration Syntax
C# Visual Basic Visual C++
public static IConcreteRegistrar RegisterGeneratedFactory<TDelegate>(
    ContainerBuilder builder
)
where TDelegate : class

Public Shared Function RegisterGeneratedFactory(Of TDelegate As Class) ( _
    builder As ContainerBuilder _
) As IConcreteRegistrar
public:
generic<typename TDelegate>
where TDelegate : ref class
static IConcreteRegistrar^ RegisterGeneratedFactory(
    ContainerBuilder^ builder
)
Generic Template Parameters
TDelegate
The type of the delegate.
Parameters
builder (ContainerBuilder)
The container builder.
Return Value
A registrar allowing configuration to continue.


RegisterGeneratedFactory Method (builder, service)

RegisterGeneratedFactory<(Of <(TDelegate>)>) Method (builder, service)
Namespaces ► Autofac.Builder ► GeneratedFactoryExtensions ► RegisterGeneratedFactory<(Of <(TDelegate>)>)(ContainerBuilder, Service)
Registers the factory delegate.
Declaration Syntax
C# Visual Basic Visual C++
public static IConcreteRegistrar RegisterGeneratedFactory<TDelegate>(
    ContainerBuilder builder,
    Service service
)
where TDelegate : class

Public Shared Function RegisterGeneratedFactory(Of TDelegate As Class) ( _
    builder As ContainerBuilder, _
    service As Service _
) As IConcreteRegistrar
public:
generic<typename TDelegate>
where TDelegate : ref class
static IConcreteRegistrar^ RegisterGeneratedFactory(
    ContainerBuilder^ builder,
    Service^ service
)
Generic Template Parameters
TDelegate
The type of the delegate.
Parameters
builder (ContainerBuilder)
The container builder.
service (Service)
The service that the delegate will return instances of.
Return Value
A registrar allowing configuration to continue.


Module Class

Module Class
Namespaces ► Autofac.Builder ► Module
Base class for user-defined modules. Implements IModule on top of ContainerBuilder.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Module : IModule
Public MustInherit Class Module _
    Implements IModule
public ref class Module abstract : IModule
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Module()()() | Initializes a new instance of the Module class
 | AttachToComponentRegistration(IContainer, IComponentRegistration) | Attach the module to a registration either already existing in or being registered in the container.
 | Configure(IContainer) | Apply the module to the container.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(ContainerBuilder) | Override to add registrations to the container.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Module
 |  | ConfigurationSettingsReader


Module Constructor

Module Constructor
Namespaces ► Autofac.Builder ► Module ► Module()()()
Initializes a new instance of the Module class
Declaration Syntax
C# Visual Basic Visual C++
protected Module()
Protected Sub New
protected:
Module()


AttachToComponentRegistration Method (container, registration)

AttachToComponentRegistration Method (container, registration)
Namespaces ► Autofac.Builder ► Module ► AttachToComponentRegistration(IContainer, IComponentRegistration)
Attach the module to a registration either already existing in or being registered in the container.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void AttachToComponentRegistration(
    IContainer container,
    IComponentRegistration registration
)
Protected Overridable Sub AttachToComponentRegistration ( _
    container As IContainer, _
    registration As IComponentRegistration _
)
protected:
virtual void AttachToComponentRegistration(
    IContainer^ container,
    IComponentRegistration^ registration
)
Parameters
container (IContainer)
The container.
registration (IComponentRegistration)
The registration.


Configure Method (container)

Configure Method (container)
Namespaces ► Autofac.Builder ► Module ► Configure(IContainer)
Apply the module to the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Configure(
    IContainer container
)
Public Overridable Sub Configure ( _
    container As IContainer _
)
public:
virtual void Configure(
    IContainer^ container
)
Parameters
container (IContainer)
Container to apply configuration to.


Load Method (builder)

Load Method (builder)
Namespaces ► Autofac.Builder ► Module ► Load(ContainerBuilder)
Override to add registrations to the container.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Load(
    ContainerBuilder builder
)
Protected Overridable Sub Load ( _
    builder As ContainerBuilder _
)
protected:
virtual void Load(
    ContainerBuilder^ builder
)
Parameters
builder (ContainerBuilder)
The builder.


Autofac.Component Namespace

Autofac.Component Namespace
Namespaces ► Autofac.Component
Component implementation model.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Component
Namespace Autofac.Component
namespace Autofac.Component
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | ComponentActivator | Implementations of the ComponentCreationDelegate type will create an instance of a component, using the provided container to resolve its dependencies.
 | Descriptor | Describes a component and its services.
 | IActivator | Provides a method by which new instances of a component can be accessed.
 | IScope | Maintains an association between instances and their activation scope. This can represent per-call, global, thread-based, request-based or user-based scope etc. It is an error to call GetInstance() if there is no instance available. Likewise, it is an error to call SetInstance() when an instance already exists in the current scope. An activation scope is also responsible for disposing its managed instances when it is itself disposed.
 | Registration | Implements IComponentRegistration using activator and scope 'policy' classes.


ComponentActivator Delegate

ComponentActivator Delegate
Namespaces ► Autofac.Component ► ComponentActivator
Implementations of the ComponentCreationDelegate type will create an instance of a component, using the provided container to resolve its dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public delegate Object ComponentActivator(
    IContext context,
    IEnumerable<Parameter> parameters
)
Public Delegate Function ComponentActivator ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public delegate Object^ ComponentActivator(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
)
Parameters
context (IContext)
The container from which the component's dependencies may be resolved.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
Return Value
An instance of the component.
Remarks
A creation delegate can be used when the method of initialisation of a component is complex, its constructors require parameters that must be obtained from outside the container. The delegate should always return a unique instance.


Descriptor Class

Descriptor Class
Namespaces ► Autofac.Component ► Descriptor
Describes a component and its services.
Declaration Syntax
C# Visual Basic Visual C++
public class Descriptor : IComponentDescriptor
Public Class Descriptor _
    Implements IComponentDescriptor
public ref class Descriptor : IComponentDescriptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Descriptor(Service, IEnumerable<(Of <(Service>)>), Type) | Initializes a new instance of the Descriptor class.
 | Descriptor(Service, IEnumerable<(Of <(Service>)>), Type, IDictionary<(Of <(String, Object>)>)) | Initializes a new instance of the Descriptor class.
 | BestKnownImplementationType | Returns the most specific type that the returned intstances are assignable to. This may be the actual implementation type, a base class, and abstract class, or an interface.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Additional data associated with the component.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | A unique identifier for this component (shared in all sub-contexts.) This value also appears in Services.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Services | The services (named and typed) exposed by the component.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
Descriptor


Descriptor Constructor

Descriptor Constructor
Namespaces ► Autofac.Component ► Descriptor ► Descriptor()()()
Members
Icon | Member | Description
 | Descriptor(Service, IEnumerable<(Of <(Service>)>), Type) | Initializes a new instance of the Descriptor class.
 | Descriptor(Service, IEnumerable<(Of <(Service>)>), Type, IDictionary<(Of <(String, Object>)>)) | Initializes a new instance of the Descriptor class.


Descriptor Constructor (id, services, bestKnownImplementationType)

Descriptor Constructor (id, services, bestKnownImplementationType)
Namespaces ► Autofac.Component ► Descriptor ► Descriptor(Service, IEnumerable<(Of <(Service>)>), Type)
Initializes a new instance of the Descriptor class.
Declaration Syntax
C# Visual Basic Visual C++
public Descriptor(
    Service id,
    IEnumerable<Service> services,
    Type bestKnownImplementationType
)
Public Sub New ( _
    id As Service, _
    services As IEnumerable(Of Service), _
    bestKnownImplementationType As Type _
)
public:
Descriptor(
    Service^ id,
    IEnumerable<Service^>^ services,
    Type^ bestKnownImplementationType
)
Parameters
id (Service)
The id. Will be exposed as a service.
services (IEnumerable <(Of <( Service >)>))
The services. May or may not contain the id.
bestKnownImplementationType (Type)
Most specific type that can be determined as the implementation.


Descriptor Constructor (id, services, bestKnownImplementationType, extendedProperties)

Descriptor Constructor (id, services, bestKnownImplementationType, extendedProperties)
Namespaces ► Autofac.Component ► Descriptor ► Descriptor(Service, IEnumerable<(Of <(Service>)>), Type, IDictionary<(Of <(String, Object>)>))
Initializes a new instance of the Descriptor class.
Declaration Syntax
C# Visual Basic Visual C++
public Descriptor(
    Service id,
    IEnumerable<Service> services,
    Type bestKnownImplementationType,
    IDictionary<string, Object> extendedProperties
)
Public Sub New ( _
    id As Service, _
    services As IEnumerable(Of Service), _
    bestKnownImplementationType As Type, _
    extendedProperties As IDictionary(Of String, Object) _
)
public:
Descriptor(
    Service^ id,
    IEnumerable<Service^>^ services,
    Type^ bestKnownImplementationType,
    IDictionary<String^, Object^>^ extendedProperties
)
Parameters
id (Service)
The id. Will be exposed as a service.
services (IEnumerable <(Of <( Service >)>))
The services. May or may not contain the id.
bestKnownImplementationType (Type)
Most specific type that can be determined as the implementation.
extendedProperties (IDictionary <(Of <( String, Object >)>))
The extended properties.


BestKnownImplementationType Property

BestKnownImplementationType Property
Namespaces ► Autofac.Component ► Descriptor ► BestKnownImplementationType
Returns the most specific type that the returned intstances are assignable to. This may be the actual implementation type, a base class, and abstract class, or an interface.
Declaration Syntax
C# Visual Basic Visual C++
public Type BestKnownImplementationType { get; private set; }
Public Property BestKnownImplementationType As Type
public:
virtual property Type^ BestKnownImplementationType {
    Type^ get () sealed;
    void set (Type^ value) sealed;
}
Return Value
The best known implementation type.
Remarks
For registrations where the type is an interface or abstract class it is recommended that the returned instances are inspected as they are activated.


ExtendedProperties Property

ExtendedProperties Property
Namespaces ► Autofac.Component ► Descriptor ► ExtendedProperties
Additional data associated with the component.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, Object> ExtendedProperties { get; private set; }
Public Property ExtendedProperties As IDictionary(Of String, Object)
public:
virtual property IDictionary<String^, Object^>^ ExtendedProperties {
    IDictionary<String^, Object^>^ get () sealed;
    void set (IDictionary<String^, Object^>^ value) sealed;
}
Value
Remarks
Note, component registrations are currently copied into subcontainers: these properties are shared between all instances of the registration in all subcontainers.


Id Property

Id Property
Namespaces ► Autofac.Component ► Descriptor ► Id
A unique identifier for this component (shared in all sub-contexts.) This value also appears in Services.
Declaration Syntax
C# Visual Basic Visual C++
public Service Id { get; private set; }
Public Property Id As Service
public:
virtual property Service^ Id {
    Service^ get () sealed;
    void set (Service^ value) sealed;
}
Value


Services Property

Services Property
Namespaces ► Autofac.Component ► Descriptor ► Services
The services (named and typed) exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<Service> Services { get; private set; }
Public Property Services As IEnumerable(Of Service)
public:
virtual property IEnumerable<Service^>^ Services {
    IEnumerable<Service^>^ get () sealed;
    void set (IEnumerable<Service^>^ value) sealed;
}
Value


ToString Method

ToString Method
Namespaces ► Autofac.Component ► Descriptor ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


IActivator Interface

IActivator Interface
Namespaces ► Autofac.Component ► IActivator
Provides a method by which new instances of a component can be accessed.
Declaration Syntax
C# Visual Basic Visual C++
public interface IActivator
Public Interface IActivator
public interface class IActivator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>)) | Create a component instance, using container to resolve the instance's dependencies.
 | CanSupportNewContext | A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.


ActivateInstance Method (context, parameters)

ActivateInstance Method (context, parameters)
Namespaces ► Autofac.Component ► IActivator ► ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>))
Create a component instance, using container to resolve the instance's dependencies.
Declaration Syntax
C# Visual Basic Visual C++
Object ActivateInstance(
    IContext context,
    IEnumerable<Parameter> parameters
)
Function ActivateInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As Object
Object^ ActivateInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
)
Parameters
context (IContext)
The context to use for dependency resolution.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
Return Value
A component instance. Note that while the returned value need not be created on-the-spot, it must not be returned more than once by consecutive calls. (Throw an exception if this is attempted. IActivationScope should manage singleton semantics.)


CanSupportNewContext Property

CanSupportNewContext Property
Namespaces ► Autofac.Component ► IActivator ► CanSupportNewContext
A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
Declaration Syntax
C# Visual Basic Visual C++
bool CanSupportNewContext { get; }
ReadOnly Property CanSupportNewContext As Boolean
property bool CanSupportNewContext {
    bool get ();
}
Value
true if this instance can support a new context; otherwise, false.


IScope Interface

IScope Interface
Namespaces ► Autofac.Component ► IScope
Maintains an association between instances and their activation scope. This can represent per-call, global, thread-based, request-based or user-based scope etc. It is an error to call GetInstance() if there is no instance available. Likewise, it is an error to call SetInstance() when an instance already exists in the current scope. An activation scope is also responsible for disposing its managed instances when it is itself disposed.
Declaration Syntax
C# Visual Basic Visual C++
public interface IScope
Public Interface IScope
public interface class IScope
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DuplicateForNewContext(IScope%) | Try to create a scope container for a new context.
 | GetInstance()()() | The instance corresponding to this scope.
 | InstanceAvailable | Returns true if there is already an instance available in the current activation scope.
 | SetInstance(Object) | Sets the instance to be associated with the current activation scope.
Remarks
Note that obviously an Instance property could be used to mimic the same behaviour, however the semantics would differ from that of a regular property.


DuplicateForNewContext Method (newScope)

DuplicateForNewContext Method (newScope)
Namespaces ► Autofac.Component ► IScope ► DuplicateForNewContext(IScope%)
Try to create a scope container for a new context.
Declaration Syntax
C# Visual Basic Visual C++
bool DuplicateForNewContext(
    out IScope newScope
)
Function DuplicateForNewContext ( _
    <OutAttribute> ByRef newScope As IScope _
) As Boolean
bool DuplicateForNewContext(
    [OutAttribute] IScope^% newScope
)
Parameters
newScope ( IScope %)
The duplicate.
Return Value
True if the semantics of the scope model allow for new contexts.


GetInstance Method

GetInstance Method
Namespaces ► Autofac.Component ► IScope ► GetInstance()()()
The instance corresponding to this scope.
Declaration Syntax
C# Visual Basic Visual C++
Object GetInstance()
Function GetInstance As Object
Object^ GetInstance()
Return Value
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is not instance available.


InstanceAvailable Property

InstanceAvailable Property
Namespaces ► Autofac.Component ► IScope ► InstanceAvailable
Returns true if there is already an instance available in the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
bool InstanceAvailable { get; }
ReadOnly Property InstanceAvailable As Boolean
property bool InstanceAvailable {
    bool get ();
}


SetInstance Method (instance)

SetInstance Method (instance)
Namespaces ► Autofac.Component ► IScope ► SetInstance(Object)
Sets the instance to be associated with the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
void SetInstance(
    Object instance
)
Sub SetInstance ( _
    instance As Object _
)
void SetInstance(
    Object^ instance
)
Parameters
instance (Object)
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is already an instance available.
ArgumentNullException |


Registration Class

Registration Class
Namespaces ► Autofac.Component ► Registration
Implements IComponentRegistration using activator and scope 'policy' classes.
Declaration Syntax
C# Visual Basic Visual C++
public class Registration : Disposable,
    IComponentRegistration, IDisposable
Public Class Registration _
    Inherits Disposable _
    Implements IComponentRegistration, IDisposable
public ref class Registration : public Disposable,
    IComponentRegistration, IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Registration(IComponentDescriptor, IActivator, IScope, InstanceOwnership) | Create a new ComponentRegistration.
 | Activated | Fired when the activation process for a new instance is complete.
 | Activating | Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
 | Activator | Gets the activator.
 | CheckNotDisposed()()() | Checks that this instance has not been disposed. (Inherited from Disposable.)
 | CreateDuplicate(IComponentDescriptor, IActivator, IScope, InstanceOwnership) | Semantically equivalent to ICloneable.Clone().
 | Descriptor | Describes the component registration and the services it provides.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Disposable.)
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Disposable.)
 | DuplicateForNewContext(IComponentRegistration%) | Create a duplicate of this instance if it is semantically valid to copy it to a new context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceActivated(IContext, Object) | Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
 | IsDisposed | Gets a value indicating whether this instance is disposed. (Inherited from Disposable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OwnershipModel | Gets the ownership model.
 | Preparing | Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
 | ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%) | Must return a valid instance, or throw an exception on failure.
 | Scope | Gets the scope.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Remarks
ComponentRegistration, IActivator, IScope etc. are not parameterised with the component type because in some situations, i.e. when calling remote services through a proxy, a component type may not be available.
Inheritance Hierarchy
Object
 | Disposable
 |  | Registration


Registration Constructor (descriptor, activator, scope, ownershipModel)

Registration Constructor (descriptor, activator, scope, ownershipModel)
Namespaces ► Autofac.Component ► Registration ► Registration(IComponentDescriptor, IActivator, IScope, InstanceOwnership)
Create a new ComponentRegistration.
Declaration Syntax
C# Visual Basic Visual C++
public Registration(
    IComponentDescriptor descriptor,
    IActivator activator,
    IScope scope,
    InstanceOwnership ownershipModel
)
Public Sub New ( _
    descriptor As IComponentDescriptor, _
    activator As IActivator, _
    scope As IScope, _
    ownershipModel As InstanceOwnership _
)
public:
Registration(
    IComponentDescriptor^ descriptor,
    IActivator^ activator,
    IScope^ scope,
    InstanceOwnership ownershipModel
)
Parameters
descriptor (IComponentDescriptor)
The descriptor.
activator (IActivator)
An object with which new component instances can be created. Required.
scope (IScope)
An object that tracks created instances with respect to their scope of usage, i.e., per-thread, per-call etc. Required. Will be disposed when the registration is disposed.
ownershipModel (InstanceOwnership)
The ownership model that determines whether the instances are disposed along with the scope.


Activated Event

Activated Event
Namespaces ► Autofac.Component ► Registration ► Activated
Fired when the activation process for a new instance is complete.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<ActivatedEventArgs> Activated
Public Event Activated As EventHandler(Of ActivatedEventArgs)
public:
virtual  event EventHandler<ActivatedEventArgs^>^ Activated {
    void add (EventHandler<ActivatedEventArgs^>^ value);
    void remove (EventHandler<ActivatedEventArgs^>^ value);
}


Activating Event

Activating Event
Namespaces ► Autofac.Component ► Registration ► Activating
Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<ActivatingEventArgs> Activating
Public Event Activating As EventHandler(Of ActivatingEventArgs)
public:
virtual  event EventHandler<ActivatingEventArgs^>^ Activating {
    void add (EventHandler<ActivatingEventArgs^>^ value);
    void remove (EventHandler<ActivatingEventArgs^>^ value);
}


Activator Property

Activator Property
Namespaces ► Autofac.Component ► Registration ► Activator
Gets the activator.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IActivator Activator { get; }
Public Overridable ReadOnly Property Activator As IActivator
public:
virtual property IActivator^ Activator {
    IActivator^ get ();
}
Value
The activator.


CreateDuplicate Method (descriptor, activator, newScope, ownershipModel)

CreateDuplicate Method (descriptor, activator, newScope, ownershipModel)
Namespaces ► Autofac.Component ► Registration ► CreateDuplicate(IComponentDescriptor, IActivator, IScope, InstanceOwnership)
Semantically equivalent to ICloneable.Clone().
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Registration CreateDuplicate(
    IComponentDescriptor descriptor,
    IActivator activator,
    IScope newScope,
    InstanceOwnership ownershipModel
)
Protected Overridable Function CreateDuplicate ( _
    descriptor As IComponentDescriptor, _
    activator As IActivator, _
    newScope As IScope, _
    ownershipModel As InstanceOwnership _
) As Registration
protected:
virtual Registration^ CreateDuplicate(
    IComponentDescriptor^ descriptor,
    IActivator^ activator,
    IScope^ newScope,
    InstanceOwnership ownershipModel
)
Parameters
descriptor (IComponentDescriptor)

[Missing <param name="descriptor"/> documentation for "M:Autofac.Component.Registration.CreateDuplicate(Autofac.IComponentDescriptor,Autofac.Component.IActivator,Autofac.Component.IScope,Autofac.InstanceOwnership)"]

activator (IActivator)

[Missing <param name="activator"/> documentation for "M:Autofac.Component.Registration.CreateDuplicate(Autofac.IComponentDescriptor,Autofac.Component.IActivator,Autofac.Component.IScope,Autofac.InstanceOwnership)"]

newScope (IScope)

[Missing <param name="newScope"/> documentation for "M:Autofac.Component.Registration.CreateDuplicate(Autofac.IComponentDescriptor,Autofac.Component.IActivator,Autofac.Component.IScope,Autofac.InstanceOwnership)"]

ownershipModel (InstanceOwnership)

[Missing <param name="ownershipModel"/> documentation for "M:Autofac.Component.Registration.CreateDuplicate(Autofac.IComponentDescriptor,Autofac.Component.IActivator,Autofac.Component.IScope,Autofac.InstanceOwnership)"]

Return Value

[Missing <returns> documentation for M:Autofac.Component.Registration.CreateDuplicate(Autofac.IComponentDescriptor,Autofac.Component.IActivator,Autofac.Component.IScope,Autofac.InstanceOwnership)]


Descriptor Property

Descriptor Property
Namespaces ► Autofac.Component ► Registration ► Descriptor
Describes the component registration and the services it provides.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentDescriptor Descriptor { get; }
Public ReadOnly Property Descriptor As IComponentDescriptor
public:
virtual property IComponentDescriptor^ Descriptor {
    IComponentDescriptor^ get () sealed;
}
Value


DuplicateForNewContext Method (duplicate)

DuplicateForNewContext Method (duplicate)
Namespaces ► Autofac.Component ► Registration ► DuplicateForNewContext(IComponentRegistration%)
Create a duplicate of this instance if it is semantically valid to copy it to a new context.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DuplicateForNewContext(
    out IComponentRegistration duplicate
)
Public Overridable Function DuplicateForNewContext ( _
    <OutAttribute> ByRef duplicate As IComponentRegistration _
) As Boolean
public:
virtual bool DuplicateForNewContext(
    [OutAttribute] IComponentRegistration^% duplicate
)
Parameters
duplicate ( IComponentRegistration %)
The duplicate.
Return Value
True if the duplicate was created.


InstanceActivated Method (context, instance)

InstanceActivated Method (context, instance)
Namespaces ► Autofac.Component ► Registration ► InstanceActivated(IContext, Object)
Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InstanceActivated(
    IContext context,
    Object instance
)
Public Overridable Sub InstanceActivated ( _
    context As IContext, _
    instance As Object _
)
public:
virtual void InstanceActivated(
    IContext^ context,
    Object^ instance
)
Parameters
context (IContext)
The context in which the instance was activated.
instance (Object)
The instance.


OwnershipModel Property

OwnershipModel Property
Namespaces ► Autofac.Component ► Registration ► OwnershipModel
Gets the ownership model.
Declaration Syntax
C# Visual Basic Visual C++
public virtual InstanceOwnership OwnershipModel { get; }
Public Overridable ReadOnly Property OwnershipModel As InstanceOwnership
public:
virtual property InstanceOwnership OwnershipModel {
    InstanceOwnership get ();
}
Value
The ownership model.


Preparing Event

Preparing Event
Namespaces ► Autofac.Component ► Registration ► Preparing
Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<PreparingEventArgs> Preparing
Public Event Preparing As EventHandler(Of PreparingEventArgs)
public:
virtual  event EventHandler<PreparingEventArgs^>^ Preparing {
    void add (EventHandler<PreparingEventArgs^>^ value);
    void remove (EventHandler<PreparingEventArgs^>^ value);
}


ResolveInstance Method (context, parameters, disposer, newInstance)

ResolveInstance Method (context, parameters, disposer, newInstance)
Namespaces ► Autofac.Component ► Registration ► ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%)
Must return a valid instance, or throw an exception on failure.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object ResolveInstance(
    IContext context,
    IEnumerable<Parameter> parameters,
    IDisposer disposer,
    out bool newInstance
)
Public Overridable Function ResolveInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter), _
    disposer As IDisposer, _
    <OutAttribute> ByRef newInstance As Boolean _
) As Object
public:
virtual Object^ ResolveInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters,
    IDisposer^ disposer,
    [OutAttribute] bool% newInstance
)
Parameters
context (IContext)
The context that is to be used to resolve the instance's dependencies.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
disposer (IDisposer)
The disposer.
newInstance ( Boolean %)
if set to true a new instance was created.
Return Value
A newly-resolved instance.


Scope Property

Scope Property
Namespaces ► Autofac.Component ► Registration ► Scope
Gets the scope.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IScope Scope { get; }
Public Overridable ReadOnly Property Scope As IScope
public:
virtual property IScope^ Scope {
    IScope^ get ();
}
Value
The scope.


ToString Method

ToString Method
Namespaces ► Autofac.Component ► Registration ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


Autofac.Component.Activation Namespace

Autofac.Component.Activation Namespace
Namespaces ► Autofac.Component.Activation
Component activators.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Component.Activation
Namespace Autofac.Component.Activation
namespace Autofac.Component.Activation
Types
All Types Classes Interfaces
Icon | Type | Description
 | DelegateActivator | A component activator that uses a lazily-evaluated delegate/expression to create a component.
 | DirectConstructorInvoker | Executes the ConstructorInfo directly.
 | IConstructorInvoker | Invokes the specified constructor (or an equivalent.)
 | IConstructorSelector | Used to determine which constructor will be used by the ReflectionComponentActivator when more than one matching constructor is found.
 | MostParametersConstructorSelector | Selects the constructor with the most parameters.
 | ProvidedInstanceActivator | A component activator that returns an already-created instance.
 | ReflectionActivator | A component activator that creates a new instance of a type using reflection to select and invoke a constructor based on the available service registrations.
 | SpecificConstructorSelector | Chooses a constructor based on an exact signature.


DelegateActivator Class

DelegateActivator Class
Namespaces ► Autofac.Component.Activation ► DelegateActivator
A component activator that uses a lazily-evaluated delegate/expression to create a component.
Declaration Syntax
C# Visual Basic Visual C++
public class DelegateActivator : IActivator
Public Class DelegateActivator _
    Implements IActivator
public ref class DelegateActivator : IActivator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DelegateActivator(ComponentActivator) | Create a DelegateActivator.
 | ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>)) | Create a component instance, using container to resolve the instance's dependencies.
 | CanSupportNewContext | A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
DelegateActivator


DelegateActivator Constructor (creator)

DelegateActivator Constructor (creator)
Namespaces ► Autofac.Component.Activation ► DelegateActivator ► DelegateActivator(ComponentActivator)
Create a DelegateActivator.
Declaration Syntax
C# Visual Basic Visual C++
public DelegateActivator(
    ComponentActivator creator
)
Public Sub New ( _
    creator As ComponentActivator _
)
public:
DelegateActivator(
    ComponentActivator^ creator
)
Parameters
creator (ComponentActivator)
A creation delegate. Required.


ActivateInstance Method (context, parameters)

ActivateInstance Method (context, parameters)
Namespaces ► Autofac.Component.Activation ► DelegateActivator ► ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>))
Create a component instance, using container to resolve the instance's dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public Object ActivateInstance(
    IContext context,
    IEnumerable<Parameter> parameters
)
Public Function ActivateInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ ActivateInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
context (IContext)
The context to use for dependency resolution.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
Return Value
A component instance. Note that while the returned value need not be created on-the-spot, it must not be returned more than once by consecutive calls. (Throw an exception if this is attempted. IActivationScope should manage singleton semantics.)


CanSupportNewContext Property

CanSupportNewContext Property
Namespaces ► Autofac.Component.Activation ► DelegateActivator ► CanSupportNewContext
A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
Declaration Syntax
C# Visual Basic Visual C++
public bool CanSupportNewContext { get; }
Public ReadOnly Property CanSupportNewContext As Boolean
public:
virtual property bool CanSupportNewContext {
    bool get () sealed;
}
Value
true if this instance can support a new context; otherwise, false.


ToString Method

ToString Method
Namespaces ► Autofac.Component.Activation ► DelegateActivator ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


DirectConstructorInvoker Class

DirectConstructorInvoker Class
Namespaces ► Autofac.Component.Activation ► DirectConstructorInvoker
Executes the ConstructorInfo directly.
Declaration Syntax
C# Visual Basic Visual C++
public class DirectConstructorInvoker : IConstructorInvoker
Public Class DirectConstructorInvoker _
    Implements IConstructorInvoker
public ref class DirectConstructorInvoker : IConstructorInvoker
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DirectConstructorInvoker()()() | Initializes a new instance of the DirectConstructorInvoker class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InvokeConstructor(IContext, IEnumerable<(Of <(Parameter>)>), ConstructorInfo, array<Func<(Of <(Object>)>)>[]()[]) | Invokes the constructor.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DirectConstructorInvoker


DirectConstructorInvoker Constructor

DirectConstructorInvoker Constructor
Namespaces ► Autofac.Component.Activation ► DirectConstructorInvoker ► DirectConstructorInvoker()()()
Initializes a new instance of the DirectConstructorInvoker class
Declaration Syntax
C# Visual Basic Visual C++
public DirectConstructorInvoker()
Public Sub New
public:
DirectConstructorInvoker()


InvokeConstructor Method (context, parameters, ci, args)

InvokeConstructor Method (context, parameters, ci, args)
Namespaces ► Autofac.Component.Activation ► DirectConstructorInvoker ► InvokeConstructor(IContext, IEnumerable<(Of <(Parameter>)>), ConstructorInfo, array<Func<(Of <(Object>)>)>[]()[])
Invokes the constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Object InvokeConstructor(
    IContext context,
    IEnumerable<Parameter> parameters,
    ConstructorInfo ci,
    Func<Object>[] args
)
Public Function InvokeConstructor ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter), _
    ci As ConstructorInfo, _
    args As Func(Of Object)() _
) As Object
public:
virtual Object^ InvokeConstructor(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters,
    ConstructorInfo^ ci,
    array<Func<Object^>^>^ args
) sealed
Parameters
context (IContext)
The context.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
ci (ConstructorInfo)
The selected constructor.
args (array< Func <(Of <( Object >)>) >[]()[])
Arguments appropriate to the constructor.
Return Value
The new instance.


IConstructorInvoker Interface

IConstructorInvoker Interface
Namespaces ► Autofac.Component.Activation ► IConstructorInvoker
Invokes the specified constructor (or an equivalent.)
Declaration Syntax
C# Visual Basic Visual C++
public interface IConstructorInvoker
Public Interface IConstructorInvoker
public interface class IConstructorInvoker
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InvokeConstructor(IContext, IEnumerable<(Of <(Parameter>)>), ConstructorInfo, array<Func<(Of <(Object>)>)>[]()[]) | Invokes the constructor.


InvokeConstructor Method (context, parameters, ci, args)

InvokeConstructor Method (context, parameters, ci, args)
Namespaces ► Autofac.Component.Activation ► IConstructorInvoker ► InvokeConstructor(IContext, IEnumerable<(Of <(Parameter>)>), ConstructorInfo, array<Func<(Of <(Object>)>)>[]()[])
Invokes the constructor.
Declaration Syntax
C# Visual Basic Visual C++
Object InvokeConstructor(
    IContext context,
    IEnumerable<Parameter> parameters,
    ConstructorInfo ci,
    Func<Object>[] args
)
Function InvokeConstructor ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter), _
    ci As ConstructorInfo, _
    args As Func(Of Object)() _
) As Object
Object^ InvokeConstructor(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters,
    ConstructorInfo^ ci,
    array<Func<Object^>^>^ args
)
Parameters
context (IContext)
The context.
parameters (IEnumerable <(Of <( Parameter >)>))
The parameters.
ci (ConstructorInfo)
The selected constructor.
args (array< Func <(Of <( Object >)>) >[]()[])
Arguments appropriate to the constructor.
Return Value
The new instance.


IConstructorSelector Interface

IConstructorSelector Interface
Namespaces ► Autofac.Component.Activation ► IConstructorSelector
Used to determine which constructor will be used by the ReflectionComponentActivator when more than one matching constructor is found.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConstructorSelector
Public Interface IConstructorSelector
public interface class IConstructorSelector
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SelectConstructor(ICollection<(Of <(ConstructorInfo>)>)) | Returns the most suitable constructor from those provided.


SelectConstructor Method (possibleConstructors)

SelectConstructor Method (possibleConstructors)
Namespaces ► Autofac.Component.Activation ► IConstructorSelector ► SelectConstructor(ICollection<(Of <(ConstructorInfo>)>))
Returns the most suitable constructor from those provided.
Declaration Syntax
C# Visual Basic Visual C++
ConstructorInfo SelectConstructor(
    ICollection<ConstructorInfo> possibleConstructors
)
Function SelectConstructor ( _
    possibleConstructors As ICollection(Of ConstructorInfo) _
) As ConstructorInfo
ConstructorInfo^ SelectConstructor(
    ICollection<ConstructorInfo^>^ possibleConstructors
)
Parameters
possibleConstructors (ICollection <(Of <( ConstructorInfo >)>))
Required. Must contain at least one item.
Return Value
The most suitable constructor.


MostParametersConstructorSelector Class

MostParametersConstructorSelector Class
Namespaces ► Autofac.Component.Activation ► MostParametersConstructorSelector
Selects the constructor with the most parameters.
Declaration Syntax
C# Visual Basic Visual C++
public class MostParametersConstructorSelector : IConstructorSelector
Public Class MostParametersConstructorSelector _
    Implements IConstructorSelector
public ref class MostParametersConstructorSelector : IConstructorSelector
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MostParametersConstructorSelector()()() | Initializes a new instance of the MostParametersConstructorSelector class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectConstructor(ICollection<(Of <(ConstructorInfo>)>)) | Returns the most suitable constructor from those provided.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MostParametersConstructorSelector


MostParametersConstructorSelector Constructor

MostParametersConstructorSelector Constructor
Namespaces ► Autofac.Component.Activation ► MostParametersConstructorSelector ► MostParametersConstructorSelector()()()
Initializes a new instance of the MostParametersConstructorSelector class
Declaration Syntax
C# Visual Basic Visual C++
public MostParametersConstructorSelector()
Public Sub New
public:
MostParametersConstructorSelector()


SelectConstructor Method (possibleConstructors)

SelectConstructor Method (possibleConstructors)
Namespaces ► Autofac.Component.Activation ► MostParametersConstructorSelector ► SelectConstructor(ICollection<(Of <(ConstructorInfo>)>))
Returns the most suitable constructor from those provided.
Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInfo SelectConstructor(
    ICollection<ConstructorInfo> possibleConstructors
)
Public Function SelectConstructor ( _
    possibleConstructors As ICollection(Of ConstructorInfo) _
) As ConstructorInfo
public:
virtual ConstructorInfo^ SelectConstructor(
    ICollection<ConstructorInfo^>^ possibleConstructors
) sealed
Parameters
possibleConstructors (ICollection <(Of <( ConstructorInfo >)>))
Required. Must contain at least one item.
Return Value
The most suitable constructor.


ProvidedInstanceActivator Class

ProvidedInstanceActivator Class
Namespaces ► Autofac.Component.Activation ► ProvidedInstanceActivator
A component activator that returns an already-created instance.
Declaration Syntax
C# Visual Basic Visual C++
public class ProvidedInstanceActivator : IActivator
Public Class ProvidedInstanceActivator _
    Implements IActivator
public ref class ProvidedInstanceActivator : IActivator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProvidedInstanceActivator(Object) | Create a new InstanceComponentActivator that will return componentInstance from ActivateInstance().
 | ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>)) | Create a component instance, using container to resolve the instance's dependencies.
 | CanSupportNewContext | A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Remarks
The activator only works once. Subsequent calls to ActivateInstance() will result in a failure (this is to comply with the requirements of the interface.)
Inheritance Hierarchy
Object
ProvidedInstanceActivator


ProvidedInstanceActivator Constructor (componentInstance)

ProvidedInstanceActivator Constructor (componentInstance)
Namespaces ► Autofac.Component.Activation ► ProvidedInstanceActivator ► ProvidedInstanceActivator(Object)
Create a new InstanceComponentActivator that will return componentInstance from ActivateInstance().
Declaration Syntax
C# Visual Basic Visual C++
public ProvidedInstanceActivator(
    Object componentInstance
)
Public Sub New ( _
    componentInstance As Object _
)
public:
ProvidedInstanceActivator(
    Object^ componentInstance
)
Parameters
componentInstance (Object)
The instance provided by this activator.


ActivateInstance Method (context, parameters)

ActivateInstance Method (context, parameters)
Namespaces ► Autofac.Component.Activation ► ProvidedInstanceActivator ► ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>))
Create a component instance, using container to resolve the instance's dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public Object ActivateInstance(
    IContext context,
    IEnumerable<Parameter> parameters
)
Public Function ActivateInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ ActivateInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
context (IContext)
The context to use for dependency resolution.
parameters (IEnumerable <(Of <( Parameter >)>))
Unused.
Return Value
A component instance. Note that while the returned value need not be created on-the-spot, it must not be returned more than once by consecutive calls. (Throw an exception if this is attempted. IActivationScope should manage singleton semantics.)


CanSupportNewContext Property

CanSupportNewContext Property
Namespaces ► Autofac.Component.Activation ► ProvidedInstanceActivator ► CanSupportNewContext
A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
Declaration Syntax
C# Visual Basic Visual C++
public bool CanSupportNewContext { get; }
Public ReadOnly Property CanSupportNewContext As Boolean
public:
virtual property bool CanSupportNewContext {
    bool get () sealed;
}
Value
true if this instance can support a new context; otherwise, false.


ToString Method

ToString Method
Namespaces ► Autofac.Component.Activation ► ProvidedInstanceActivator ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


ReflectionActivator Class

ReflectionActivator Class
Namespaces ► Autofac.Component.Activation ► ReflectionActivator
A component activator that creates a new instance of a type using reflection to select and invoke a constructor based on the available service registrations.
Declaration Syntax
C# Visual Basic Visual C++
public class ReflectionActivator : IActivator
Public Class ReflectionActivator _
    Implements IActivator
public ref class ReflectionActivator : IActivator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReflectionActivator(Type) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>)) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>)) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>), IConstructorSelector) | Initializes a new instance of the ReflectionActivator class.
 | ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>)) | Create a component instance, using container to resolve the instance's dependencies.
 | CanSupportNewContext | A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
 | ConstructorInvoker | Gets or sets the constructor invoker.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplementationType | The type that will be used to reflectively instantiate the component instances.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
ReflectionActivator


ReflectionActivator Constructor

ReflectionActivator Constructor
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ReflectionActivator()()()
Members
Icon | Member | Description
 | ReflectionActivator(Type) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>)) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>)) | Initializes a new instance of the ReflectionActivator class.
 | ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>), IConstructorSelector) | Initializes a new instance of the ReflectionActivator class.


ReflectionActivator Constructor (componentType)

ReflectionActivator Constructor (componentType)
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ReflectionActivator(Type)
Initializes a new instance of the ReflectionActivator class.
Declaration Syntax
C# Visual Basic Visual C++
public ReflectionActivator(
    Type componentType
)
Public Sub New ( _
    componentType As Type _
)
public:
ReflectionActivator(
    Type^ componentType
)
Parameters
componentType (Type)
Type of the component.


ReflectionActivator Constructor (componentType, additionalConstructorParameters)

ReflectionActivator Constructor (componentType, additionalConstructorParameters)
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>))
Initializes a new instance of the ReflectionActivator class.
Declaration Syntax
C# Visual Basic Visual C++
public ReflectionActivator(
    Type componentType,
    IEnumerable<Parameter> additionalConstructorParameters
)
Public Sub New ( _
    componentType As Type, _
    additionalConstructorParameters As IEnumerable(Of Parameter) _
)
public:
ReflectionActivator(
    Type^ componentType,
    IEnumerable<Parameter^>^ additionalConstructorParameters
)
Parameters
componentType (Type)
Type of the component.
additionalConstructorParameters (IEnumerable <(Of <( Parameter >)>))
The additional constructor parameters.


ReflectionActivator Constructor (componentType, additionalConstructorParameters, explicitPropertySetters)

ReflectionActivator Constructor (componentType, additionalConstructorParameters, explicitPropertySetters)
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>))
Initializes a new instance of the ReflectionActivator class.
Declaration Syntax
C# Visual Basic Visual C++
public ReflectionActivator(
    Type componentType,
    IEnumerable<Parameter> additionalConstructorParameters,
    IEnumerable<NamedPropertyParameter> explicitPropertySetters
)
Public Sub New ( _
    componentType As Type, _
    additionalConstructorParameters As IEnumerable(Of Parameter), _
    explicitPropertySetters As IEnumerable(Of NamedPropertyParameter) _
)
public:
ReflectionActivator(
    Type^ componentType,
    IEnumerable<Parameter^>^ additionalConstructorParameters,
    IEnumerable<NamedPropertyParameter^>^ explicitPropertySetters
)
Parameters
componentType (Type)
Type of the component.
additionalConstructorParameters (IEnumerable <(Of <( Parameter >)>))
The additional constructor parameters.
explicitPropertySetters (IEnumerable <(Of <( NamedPropertyParameter >)>))
The explicit property setters.


ReflectionActivator Constructor (componentType, additionalConstructorParameters, explicitPropertySetters, constructorSelector)

ReflectionActivator Constructor (componentType, additionalConstructorParameters, explicitPropertySetters, constructorSelector)
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ReflectionActivator(Type, IEnumerable<(Of <(Parameter>)>), IEnumerable<(Of <(NamedPropertyParameter>)>), IConstructorSelector)
Initializes a new instance of the ReflectionActivator class.
Declaration Syntax
C# Visual Basic Visual C++
public ReflectionActivator(
    Type componentType,
    IEnumerable<Parameter> additionalConstructorParameters,
    IEnumerable<NamedPropertyParameter> explicitPropertySetters,
    IConstructorSelector constructorSelector
)
Public Sub New ( _
    componentType As Type, _
    additionalConstructorParameters As IEnumerable(Of Parameter), _
    explicitPropertySetters As IEnumerable(Of NamedPropertyParameter), _
    constructorSelector As IConstructorSelector _
)
public:
ReflectionActivator(
    Type^ componentType,
    IEnumerable<Parameter^>^ additionalConstructorParameters,
    IEnumerable<NamedPropertyParameter^>^ explicitPropertySetters,
    IConstructorSelector^ constructorSelector
)
Parameters
componentType (Type)
Type of the component.
additionalConstructorParameters (IEnumerable <(Of <( Parameter >)>))
The additional constructor parameters.
explicitPropertySetters (IEnumerable <(Of <( NamedPropertyParameter >)>))
The explicit property setters.
constructorSelector (IConstructorSelector)
The constructor selector.


ActivateInstance Method (context, parameters)

ActivateInstance Method (context, parameters)
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ActivateInstance(IContext, IEnumerable<(Of <(Parameter>)>))
Create a component instance, using container to resolve the instance's dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public Object ActivateInstance(
    IContext context,
    IEnumerable<Parameter> parameters
)
Public Function ActivateInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As Object
public:
virtual Object^ ActivateInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
) sealed
Parameters
context (IContext)
The context to use for dependency resolution.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
Return Value
A component instance. Note that while the returned value need not be created on-the-spot, it must not be returned more than once by consecutive calls. (Throw an exception if this is attempted. IActivationScope should manage singleton semantics.)


CanSupportNewContext Property

CanSupportNewContext Property
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► CanSupportNewContext
A 'new context' is a scope that is self-contained and that can dispose the components it contains before the parent container is disposed. If the activator is stateless it should return true, otherwise false.
Declaration Syntax
C# Visual Basic Visual C++
public bool CanSupportNewContext { get; }
Public ReadOnly Property CanSupportNewContext As Boolean
public:
virtual property bool CanSupportNewContext {
    bool get () sealed;
}
Value
true if this instance can support a new context; otherwise, false.


ConstructorInvoker Property

ConstructorInvoker Property
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ConstructorInvoker
Gets or sets the constructor invoker.
Declaration Syntax
C# Visual Basic Visual C++
public IConstructorInvoker ConstructorInvoker { get; set; }
Public Property ConstructorInvoker As IConstructorInvoker
public:
property IConstructorInvoker^ ConstructorInvoker {
    IConstructorInvoker^ get ();
    void set (IConstructorInvoker^ value);
}
Value
The constructor invoker.


ImplementationType Property

ImplementationType Property
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ImplementationType
The type that will be used to reflectively instantiate the component instances.
Declaration Syntax
C# Visual Basic Visual C++
public Type ImplementationType { get; set; }
Public Property ImplementationType As Type
public:
property Type^ ImplementationType {
    Type^ get ();
    void set (Type^ value);
}
Remarks
The actual implementation type may be substituted with a dynamically-generated subclass. Note that functionality that relies on this feature will obviously not be available to provided instances or to delegate-created instances; interface-based AOP is recommended in these situations.


ToString Method

ToString Method
Namespaces ► Autofac.Component.Activation ► ReflectionActivator ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


SpecificConstructorSelector Class

SpecificConstructorSelector Class
Namespaces ► Autofac.Component.Activation ► SpecificConstructorSelector
Chooses a constructor based on an exact signature.
Declaration Syntax
C# Visual Basic Visual C++
public class SpecificConstructorSelector : IConstructorSelector
Public Class SpecificConstructorSelector _
    Implements IConstructorSelector
public ref class SpecificConstructorSelector : IConstructorSelector
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SpecificConstructorSelector(array<Type>[]()[]) | Initializes a new instance of the SpecificConstructorSelector class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectConstructor(ICollection<(Of <(ConstructorInfo>)>)) | Returns the most suitable constructor from those provided.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpecificConstructorSelector


SpecificConstructorSelector Constructor (constructorSignature)

SpecificConstructorSelector Constructor (constructorSignature)
Namespaces ► Autofac.Component.Activation ► SpecificConstructorSelector ► SpecificConstructorSelector(array<Type>[]()[])
Initializes a new instance of the SpecificConstructorSelector class.
Declaration Syntax
C# Visual Basic Visual C++
public SpecificConstructorSelector(
    params Type[] constructorSignature
)
Public Sub New ( _
    ParamArray constructorSignature As Type() _
)
public:
SpecificConstructorSelector(
    ... array<Type^>^ constructorSignature
)
Parameters
constructorSignature (array< Type >[]()[])
The constructor signature.


SelectConstructor Method (possibleConstructors)

SelectConstructor Method (possibleConstructors)
Namespaces ► Autofac.Component.Activation ► SpecificConstructorSelector ► SelectConstructor(ICollection<(Of <(ConstructorInfo>)>))
Returns the most suitable constructor from those provided.
Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInfo SelectConstructor(
    ICollection<ConstructorInfo> possibleConstructors
)
Public Function SelectConstructor ( _
    possibleConstructors As ICollection(Of ConstructorInfo) _
) As ConstructorInfo
public:
virtual ConstructorInfo^ SelectConstructor(
    ICollection<ConstructorInfo^>^ possibleConstructors
) sealed
Parameters
possibleConstructors (ICollection <(Of <( ConstructorInfo >)>))
Required. Must contain at least one item.
Return Value
The most suitable constructor.


Autofac.Component.Scope Namespace

Autofac.Component.Scope Namespace
Namespaces ► Autofac.Component.Scope
Component scope models.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Component.Scope
Namespace Autofac.Component.Scope
namespace Autofac.Component.Scope
Types
All Types Classes
Icon | Type | Description
 | ContainerScope | Scope model tied to the lifetime of the container in which the instance is resolved. This is useful for items whose lifespan is a single web request, for instance.
 | FactoryScope | Manages instances in such a way that every activation gets a new instance, i.e. the scope of an instance is a single activation. This behaviour is consistent with factory semantics.
 | SingletonScope | Restricts the component to providing a single instance in the root context only.


ContainerScope Class

ContainerScope Class
Namespaces ► Autofac.Component.Scope ► ContainerScope
Scope model tied to the lifetime of the container in which the instance is resolved. This is useful for items whose lifespan is a single web request, for instance.
Declaration Syntax
C# Visual Basic Visual C++
public class ContainerScope : IScope
Public Class ContainerScope _
    Implements IScope
public ref class ContainerScope : IScope
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContainerScope()()() | Initializes a new instance of the ContainerScope class
 | DuplicateForNewContext(IScope%) | Try to create a scope container for a new context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance()()() | The instance corresponding to this scope.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceAvailable | Returns true if there is already an instance available in the current activation scope.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetInstance(Object) | Sets the instance to be associated with the current activation scope.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | ContainerScope
 |  | SingletonScope


ContainerScope Constructor

ContainerScope Constructor
Namespaces ► Autofac.Component.Scope ► ContainerScope ► ContainerScope()()()
Initializes a new instance of the ContainerScope class
Declaration Syntax
C# Visual Basic Visual C++
public ContainerScope()
Public Sub New
public:
ContainerScope()


DuplicateForNewContext Method (newScope)

DuplicateForNewContext Method (newScope)
Namespaces ► Autofac.Component.Scope ► ContainerScope ► DuplicateForNewContext(IScope%)
Try to create a scope container for a new context.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DuplicateForNewContext(
    out IScope newScope
)
Public Overridable Function DuplicateForNewContext ( _
    <OutAttribute> ByRef newScope As IScope _
) As Boolean
public:
virtual bool DuplicateForNewContext(
    [OutAttribute] IScope^% newScope
)
Parameters
newScope ( IScope %)
The duplicate.
Return Value
True if the semantics of the scope model allow for new contexts.


GetInstance Method

GetInstance Method
Namespaces ► Autofac.Component.Scope ► ContainerScope ► GetInstance()()()
The instance corresponding to this scope.
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance()
Public Function GetInstance As Object
public:
virtual Object^ GetInstance() sealed
Return Value
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is not instance available.


InstanceAvailable Property

InstanceAvailable Property
Namespaces ► Autofac.Component.Scope ► ContainerScope ► InstanceAvailable
Returns true if there is already an instance available in the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
public bool InstanceAvailable { get; }
Public ReadOnly Property InstanceAvailable As Boolean
public:
virtual property bool InstanceAvailable {
    bool get () sealed;
}
Value


SetInstance Method (instance)

SetInstance Method (instance)
Namespaces ► Autofac.Component.Scope ► ContainerScope ► SetInstance(Object)
Sets the instance to be associated with the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
public void SetInstance(
    Object instance
)
Public Sub SetInstance ( _
    instance As Object _
)
public:
virtual void SetInstance(
    Object^ instance
) sealed
Parameters
instance (Object)
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is already an instance available.
ArgumentNullException |


ToString Method

ToString Method
Namespaces ► Autofac.Component.Scope ► ContainerScope ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


FactoryScope Class

FactoryScope Class
Namespaces ► Autofac.Component.Scope ► FactoryScope
Manages instances in such a way that every activation gets a new instance, i.e. the scope of an instance is a single activation. This behaviour is consistent with factory semantics.
Declaration Syntax
C# Visual Basic Visual C++
public class FactoryScope : IScope
Public Class FactoryScope _
    Implements IScope
public ref class FactoryScope : IScope
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FactoryScope()()() | Initializes a new instance of the FactoryScope class
 | DuplicateForNewContext(IScope%) | Try to create a scope container for a new context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance()()() | The instance corresponding to this scope.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceAvailable | Returns true if there is already an instance available in the current activation scope.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetInstance(Object) | Sets the instance to be associated with the current activation scope.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
FactoryScope


FactoryScope Constructor

FactoryScope Constructor
Namespaces ► Autofac.Component.Scope ► FactoryScope ► FactoryScope()()()
Initializes a new instance of the FactoryScope class
Declaration Syntax
C# Visual Basic Visual C++
public FactoryScope()
Public Sub New
public:
FactoryScope()


DuplicateForNewContext Method (newScope)

DuplicateForNewContext Method (newScope)
Namespaces ► Autofac.Component.Scope ► FactoryScope ► DuplicateForNewContext(IScope%)
Try to create a scope container for a new context.
Declaration Syntax
C# Visual Basic Visual C++
public bool DuplicateForNewContext(
    out IScope newScope
)
Public Function DuplicateForNewContext ( _
    <OutAttribute> ByRef newScope As IScope _
) As Boolean
public:
virtual bool DuplicateForNewContext(
    [OutAttribute] IScope^% newScope
) sealed
Parameters
newScope ( IScope %)
The duplicate.
Return Value
True if the semantics of the scope model allow for new contexts.


GetInstance Method

GetInstance Method
Namespaces ► Autofac.Component.Scope ► FactoryScope ► GetInstance()()()
The instance corresponding to this scope.
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance()
Public Function GetInstance As Object
public:
virtual Object^ GetInstance() sealed
Return Value
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is not instance available.


InstanceAvailable Property

InstanceAvailable Property
Namespaces ► Autofac.Component.Scope ► FactoryScope ► InstanceAvailable
Returns true if there is already an instance available in the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
public bool InstanceAvailable { get; }
Public ReadOnly Property InstanceAvailable As Boolean
public:
virtual property bool InstanceAvailable {
    bool get () sealed;
}
Value


SetInstance Method (instance)

SetInstance Method (instance)
Namespaces ► Autofac.Component.Scope ► FactoryScope ► SetInstance(Object)
Sets the instance to be associated with the current activation scope.
Declaration Syntax
C# Visual Basic Visual C++
public void SetInstance(
    Object instance
)
Public Sub SetInstance ( _
    instance As Object _
)
public:
virtual void SetInstance(
    Object^ instance
) sealed
Parameters
instance (Object)
The instance.
Exceptions
Exception | Condition
InvalidOperationException | There is already an instance available.
ArgumentNullException |


ToString Method

ToString Method
Namespaces ► Autofac.Component.Scope ► FactoryScope ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


SingletonScope Class

SingletonScope Class
Namespaces ► Autofac.Component.Scope ► SingletonScope
Restricts the component to providing a single instance in the root context only.
Declaration Syntax
C# Visual Basic Visual C++
public class SingletonScope : ContainerScope
Public Class SingletonScope _
    Inherits ContainerScope
public ref class SingletonScope : public ContainerScope
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SingletonScope()()() | Initializes a new instance of the SingletonScope class
 | DuplicateForNewContext(IScope%) | Try to create a scope container for a new context. (Overrides ContainerScope.DuplicateForNewContext(IScope%).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance()()() | The instance corresponding to this scope. (Inherited from ContainerScope.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceAvailable | Returns true if there is already an instance available in the current activation scope. (Inherited from ContainerScope.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetInstance(Object) | Sets the instance to be associated with the current activation scope. (Inherited from ContainerScope.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides ContainerScope.ToString()()().)
Inheritance Hierarchy
Object
 | ContainerScope
 |  | SingletonScope


SingletonScope Constructor

SingletonScope Constructor
Namespaces ► Autofac.Component.Scope ► SingletonScope ► SingletonScope()()()
Initializes a new instance of the SingletonScope class
Declaration Syntax
C# Visual Basic Visual C++
public SingletonScope()
Public Sub New
public:
SingletonScope()


DuplicateForNewContext Method (newScope)

DuplicateForNewContext Method (newScope)
Namespaces ► Autofac.Component.Scope ► SingletonScope ► DuplicateForNewContext(IScope%)
Try to create a scope container for a new context.
Declaration Syntax
C# Visual Basic Visual C++
public override bool DuplicateForNewContext(
    out IScope newScope
)
Public Overrides Function DuplicateForNewContext ( _
    <OutAttribute> ByRef newScope As IScope _
) As Boolean
public:
virtual bool DuplicateForNewContext(
    [OutAttribute] IScope^% newScope
) override
Parameters
newScope ( IScope %)
The duplicate.
Return Value
True if the semantics of the scope model allow for new contexts.


ToString Method

ToString Method
Namespaces ► Autofac.Component.Scope ► SingletonScope ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


Autofac.Component.Tagged Namespace

Autofac.Component.Tagged Namespace
Namespaces ► Autofac.Component.Tagged
Tagged registration support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Component.Tagged
Namespace Autofac.Component.Tagged
namespace Autofac.Component.Tagged
Types
All Types Classes Interfaces
Icon | Type | Description
 | IRegistrationDecorator | Implemented on registrations that decorate other registrations, providing the decorated instance in a non-generic manner to improve API usability.
 | ITagged<(Of <(TTag>)>) | Exposes a tag value.
 | TaggedRegistration<(Of <(TTag>)>) | A TaggedRegistration decorates an IComponentRegistration to implement the Autofac tagging feature.


IRegistrationDecorator Interface

IRegistrationDecorator Interface
Namespaces ► Autofac.Component.Tagged ► IRegistrationDecorator
Implemented on registrations that decorate other registrations, providing the decorated instance in a non-generic manner to improve API usability.
Declaration Syntax
C# Visual Basic Visual C++
public interface IRegistrationDecorator
Public Interface IRegistrationDecorator
public interface class IRegistrationDecorator
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InnerRegistration | The decorated instance.


InnerRegistration Property

InnerRegistration Property
Namespaces ► Autofac.Component.Tagged ► IRegistrationDecorator ► InnerRegistration
The decorated instance.
Declaration Syntax
C# Visual Basic Visual C++
IComponentRegistration InnerRegistration { get; }
ReadOnly Property InnerRegistration As IComponentRegistration
property IComponentRegistration^ InnerRegistration {
    IComponentRegistration^ get ();
}


ITagged(TTag) Interface

ITagged<(Of <(TTag>)>) Interface
Namespaces ► Autofac.Component.Tagged ► ITagged<(Of <(TTag>)>)
Exposes a tag value.
Declaration Syntax
C# Visual Basic Visual C++
public interface ITagged<TTag>

Public Interface ITagged(Of TTag)
generic<typename TTag>
public interface class ITagged
Generic Template Parameters
TTag

[Missing <typeparam name="TTag"/> documentation for "T:Autofac.Component.Tagged.ITagged`1"]

Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Tag | Gets the tag applied to the object.


Tag Property

Tag Property
Namespaces ► Autofac.Component.Tagged ► ITagged<(Of <(TTag>)>) ► Tag
Gets the tag applied to the object.
Declaration Syntax
C# Visual Basic Visual C++
TTag Tag { get; }
ReadOnly Property Tag As TTag
property TTag Tag {
    TTag get ();
}
Value
The tag.


TaggedRegistration(TTag) Class

TaggedRegistration<(Of <(TTag>)>) Class
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>)
A TaggedRegistration decorates an IComponentRegistration to implement the Autofac tagging feature.
Declaration Syntax
C# Visual Basic Visual C++
public class TaggedRegistration<TTag> : IComponentRegistration,
    ITagged<TTag>, IRegistrationDecorator, IDisposable

Public Class TaggedRegistration(Of TTag) _
    Implements IComponentRegistration, ITagged(Of TTag), IRegistrationDecorator,  _
    IDisposable
generic<typename TTag>
public ref class TaggedRegistration : IComponentRegistration,
    ITagged<TTag>, IRegistrationDecorator, IDisposable
Generic Template Parameters
TTag

[Missing <typeparam name="TTag"/> documentation for "T:Autofac.Component.Tagged.TaggedRegistration`1"]

Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaggedRegistration<(Of <(TTag>)>)(TTag, IComponentRegistration) | Create a new TaggedRegistration.
 | Activated | Fired when the activation process for a new instance is complete.
 | Activating | Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
 | Descriptor | Describes the component registration and the services it provides.
 | Dispose()()() | Disposes the innner registration.
 | DuplicateForNewContext(IComponentRegistration%) | Create a duplicate of this instance if it is semantically valid to copy it to a new context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerRegistration | Tags are implemented as decorators over other kinds of component registrations. The inner registration is the decorated instance.
 | InstanceActivated(IContext, Object) | Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Preparing | Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
 | ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%) | Must return a valid instance, or throw an exception on failure.
 | Tag | Gets the tag applied to the registration.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
TaggedRegistration<(Of <(TTag>)>)


TaggedRegistration(TTag) Constructor (tag, inner)

TaggedRegistration<(Of <(TTag>)>) Constructor (tag, inner)
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► TaggedRegistration<(Of <(TTag>)>)(TTag, IComponentRegistration)
Create a new TaggedRegistration.
Declaration Syntax
C# Visual Basic Visual C++
public TaggedRegistration(
    TTag tag,
    IComponentRegistration inner
)
Public Sub New ( _
    tag As TTag, _
    inner As IComponentRegistration _
)
public:
TaggedRegistration(
    TTag tag,
    IComponentRegistration^ inner
)
Parameters
tag (TTag)
The tag corresponding to the context in which this component may be resolved.
inner (IComponentRegistration)
The decorated registration.


Activated Event

Activated Event
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Activated
Fired when the activation process for a new instance is complete.
Declaration Syntax
C# Visual Basic Visual C++
public virtual event EventHandler<ActivatedEventArgs> Activated
Public Overridable Event Activated As EventHandler(Of ActivatedEventArgs)
public:
virtual  event EventHandler<ActivatedEventArgs^>^ Activated {
    void add (EventHandler<ActivatedEventArgs^>^ value);
    void remove (EventHandler<ActivatedEventArgs^>^ value);
}


Activating Event

Activating Event
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Activating
Fired when a new instance is being activated. The instance can be wrapped or switched at this time by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
public virtual event EventHandler<ActivatingEventArgs> Activating
Public Overridable Event Activating As EventHandler(Of ActivatingEventArgs)
public:
virtual  event EventHandler<ActivatingEventArgs^>^ Activating {
    void add (EventHandler<ActivatingEventArgs^>^ value);
    void remove (EventHandler<ActivatingEventArgs^>^ value);
}


Descriptor Property

Descriptor Property
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Descriptor
Describes the component registration and the services it provides.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IComponentDescriptor Descriptor { get; }
Public Overridable ReadOnly Property Descriptor As IComponentDescriptor
public:
virtual property IComponentDescriptor^ Descriptor {
    IComponentDescriptor^ get ();
}


Dispose Method

Dispose Method
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Dispose()()()
Disposes the innner registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()


DuplicateForNewContext Method (duplicate)

DuplicateForNewContext Method (duplicate)
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► DuplicateForNewContext(IComponentRegistration%)
Create a duplicate of this instance if it is semantically valid to copy it to a new context.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DuplicateForNewContext(
    out IComponentRegistration duplicate
)
Public Overridable Function DuplicateForNewContext ( _
    <OutAttribute> ByRef duplicate As IComponentRegistration _
) As Boolean
public:
virtual bool DuplicateForNewContext(
    [OutAttribute] IComponentRegistration^% duplicate
)
Parameters
duplicate ( IComponentRegistration %)
The duplicate.
Return Value
True if the duplicate was created.


InnerRegistration Property

InnerRegistration Property
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► InnerRegistration
Tags are implemented as decorators over other kinds of component registrations. The inner registration is the decorated instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IComponentRegistration InnerRegistration { get; }
Public Overridable ReadOnly Property InnerRegistration As IComponentRegistration
public:
virtual property IComponentRegistration^ InnerRegistration {
    IComponentRegistration^ get ();
}


InstanceActivated Method (context, instance)

InstanceActivated Method (context, instance)
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► InstanceActivated(IContext, Object)
Called by the container once an instance has been fully constructed, including any requested objects that depend on the instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InstanceActivated(
    IContext context,
    Object instance
)
Public Overridable Sub InstanceActivated ( _
    context As IContext, _
    instance As Object _
)
public:
virtual void InstanceActivated(
    IContext^ context,
    Object^ instance
)
Parameters
context (IContext)
The context in which the instance was activated.
instance (Object)
The instance.


Preparing Event

Preparing Event
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Preparing
Fired when a new instance is required. The instance can be provided in order to skip the regular activator, by setting the Instance property in the provided event arguments.
Declaration Syntax
C# Visual Basic Visual C++
public virtual event EventHandler<PreparingEventArgs> Preparing
Public Overridable Event Preparing As EventHandler(Of PreparingEventArgs)
public:
virtual  event EventHandler<PreparingEventArgs^>^ Preparing {
    void add (EventHandler<PreparingEventArgs^>^ value);
    void remove (EventHandler<PreparingEventArgs^>^ value);
}


ResolveInstance Method (context, parameters, disposer, newInstance)

ResolveInstance Method (context, parameters, disposer, newInstance)
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► ResolveInstance(IContext, IEnumerable<(Of <(Parameter>)>), IDisposer, Boolean%)
Must return a valid instance, or throw an exception on failure.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object ResolveInstance(
    IContext context,
    IEnumerable<Parameter> parameters,
    IDisposer disposer,
    out bool newInstance
)
Public Overridable Function ResolveInstance ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter), _
    disposer As IDisposer, _
    <OutAttribute> ByRef newInstance As Boolean _
) As Object
public:
virtual Object^ ResolveInstance(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters,
    IDisposer^ disposer,
    [OutAttribute] bool% newInstance
)
Parameters
context (IContext)
The context that is to be used to resolve the instance's dependencies.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters that can be used in the resolution process.
disposer (IDisposer)
The disposer.
newInstance ( Boolean %)
if set to true a new instance was created.
Return Value
A newly-resolved instance.


Tag Property

Tag Property
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► Tag
Gets the tag applied to the registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TTag Tag { get; }
Public Overridable ReadOnly Property Tag As TTag
public:
virtual property TTag Tag {
    TTag get ();
}
Value
The tag.


ToString Method

ToString Method
Namespaces ► Autofac.Component.Tagged ► TaggedRegistration<(Of <(TTag>)>) ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents the current Object.


Autofac.Configuration Namespace

Autofac.Configuration Namespace
Namespaces ► Autofac.Configuration
System configuration file support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Configuration
Namespace Autofac.Configuration
namespace Autofac.Configuration
Types
All Types Classes
Icon | Type | Description
 | ComponentElement | Element describing a component registration.
 | ComponentElementCollection | A collection of component elements.
 | ConfigurationSettingsReader | Configures containers based upon app.config settings.
 | ExtendedPropertyElement | Element describing a component property.
 | ExtendedPropertyElementCollection | Collection of extended property elements.
 | FileElement | Element describing an additional configuration file.
 | FileElementCollection | A collection of file elements.
 | ModuleElement | Element describing a module registration.
 | ModuleElementCollection | A collection of module elements.
 | NamedConfigurationElementCollection<(Of <(TElementType>)>) | Base for multi-valued configuration elements.
 | ParameterElement | Element describing a component constructor parameter.
 | ParameterElementCollection | A collection of parameter elements.
 | PropertyElement | Element describing a component property.
 | PropertyElementCollection | Collection of property elements.
 | SectionHandler | Section handler for Autofac configuration in app.config files.
 | ServiceElement | Element describing a service exposed by a component.
 | ServiceElementCollection | A collection of service elements.


ComponentElement Class

ComponentElement Class
Namespaces ► Autofac.Configuration ► ComponentElement
Element describing a component registration.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentElement : ConfigurationElement
Public Class ComponentElement _
    Inherits ConfigurationElement
public ref class ComponentElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentElement()()() | Initializes a new instance of the ComponentElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ExplicitProperties | Gets the properties to be explicitly set on the component.
 | ExtendedProperties | Gets the extended properties associated with the registration.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | InjectProperties | Sets up property injection for the component instances. This uses the OnActivated event so that circular dependencies can be handled.
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberOf | Allows the component to be added to another composite component.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Allows the component to be added to another composite component.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | Ownership | Sets the ownership over the component instances.
 | Parameters | Gets the parameters used to construct the component.
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | Scope | Sets the scope of the component instances.
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | Service | Gets the service exposed by the component. For multiple-service components, use the services element instead.
 | Services | Gets the services exposed by the component.
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type of the component.
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ComponentElement


ComponentElement Constructor

ComponentElement Constructor
Namespaces ► Autofac.Configuration ► ComponentElement ► ComponentElement()()()
Initializes a new instance of the ComponentElement class
Declaration Syntax
C# Visual Basic Visual C++
public ComponentElement()
Public Sub New
public:
ComponentElement()


ExplicitProperties Property

ExplicitProperties Property
Namespaces ► Autofac.Configuration ► ComponentElement ► ExplicitProperties
Gets the properties to be explicitly set on the component.
Declaration Syntax
C# Visual Basic Visual C++
public PropertyElementCollection ExplicitProperties { get; }
Public ReadOnly Property ExplicitProperties As PropertyElementCollection
public:
property PropertyElementCollection^ ExplicitProperties {
    PropertyElementCollection^ get ();
}
Value
The explicit properties.


ExtendedProperties Property

ExtendedProperties Property
Namespaces ► Autofac.Configuration ► ComponentElement ► ExtendedProperties
Gets the extended properties associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPropertyElementCollection ExtendedProperties { get; }
Public ReadOnly Property ExtendedProperties As ExtendedPropertyElementCollection
public:
property ExtendedPropertyElementCollection^ ExtendedProperties {
    ExtendedPropertyElementCollection^ get ();
}
Value
The extended properties.


InjectProperties Property

InjectProperties Property
Namespaces ► Autofac.Configuration ► ComponentElement ► InjectProperties
Sets up property injection for the component instances. This uses the OnActivated event so that circular dependencies can be handled.
Declaration Syntax
C# Visual Basic Visual C++
public string InjectProperties { get; }
Public ReadOnly Property InjectProperties As String
public:
property String^ InjectProperties {
    String^ get ();
}
Value
never (default,) all, unset.


MemberOf Property

MemberOf Property
Namespaces ► Autofac.Configuration ► ComponentElement ► MemberOf
Allows the component to be added to another composite component.
Declaration Syntax
C# Visual Basic Visual C++
public string MemberOf { get; }
Public ReadOnly Property MemberOf As String
public:
property String^ MemberOf {
    String^ get ();
}
Value
The name of the composite component.


Name Property

Name Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Name
Allows the component to be added to another composite component.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
The name of the composite component.


Ownership Property

Ownership Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Ownership
Sets the ownership over the component instances.
Declaration Syntax
C# Visual Basic Visual C++
public string Ownership { get; }
Public ReadOnly Property Ownership As String
public:
property String^ Ownership {
    String^ get ();
}
Value
container (default) or external.


Parameters Property

Parameters Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Parameters
Gets the parameters used to construct the component.
Declaration Syntax
C# Visual Basic Visual C++
public ParameterElementCollection Parameters { get; }
Public ReadOnly Property Parameters As ParameterElementCollection
public:
property ParameterElementCollection^ Parameters {
    ParameterElementCollection^ get ();
}
Value
The parameters.


Scope Property

Scope Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Scope
Sets the scope of the component instances.
Declaration Syntax
C# Visual Basic Visual C++
public string Scope { get; }
Public ReadOnly Property Scope As String
public:
property String^ Scope {
    String^ get ();
}
Value
singleton (default,) factory or container.


Service Property

Service Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Service
Gets the service exposed by the component. For multiple-service components, use the services element instead.
Declaration Syntax
C# Visual Basic Visual C++
public string Service { get; }
Public ReadOnly Property Service As String
public:
property String^ Service {
    String^ get ();
}
Value
The service.


Services Property

Services Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Services
Gets the services exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
public ServiceElementCollection Services { get; }
Public ReadOnly Property Services As ServiceElementCollection
public:
property ServiceElementCollection^ Services {
    ServiceElementCollection^ get ();
}
Value
The services.


Type Property

Type Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Type
Gets the type of the component.
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; }
Public ReadOnly Property Type As String
public:
property String^ Type {
    String^ get ();
}
Value
The type.


ComponentElementCollection Class

ComponentElementCollection Class
Namespaces ► Autofac.Configuration ► ComponentElementCollection
A collection of component elements.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentElementCollection : NamedConfigurationElementCollection<ComponentElement>
Public Class ComponentElementCollection _
    Inherits NamedConfigurationElementCollection(Of ComponentElement)
public ref class ComponentElementCollection : public NamedConfigurationElementCollection<ComponentElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentElementCollection()()() | Initializes a new instance of the ComponentElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( ComponentElement >)>)
 |  |  |  | ComponentElementCollection


ComponentElementCollection Constructor

ComponentElementCollection Constructor
Namespaces ► Autofac.Configuration ► ComponentElementCollection ► ComponentElementCollection()()()
Initializes a new instance of the ComponentElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentElementCollection()
Public Sub New
public:
ComponentElementCollection()


ConfigurationSettingsReader Class

ConfigurationSettingsReader Class
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader
Configures containers based upon app.config settings.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationSettingsReader : Module
Public Class ConfigurationSettingsReader _
    Inherits Module
public ref class ConfigurationSettingsReader : public Module
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationSettingsReader()()() | Initializes a new instance of the ConfigurationSettingsReader class. The reader will look for a 'autofac' section.
 | ConfigurationSettingsReader(String, String) | Initializes a new instance of the ConfigurationSettingsReader class.
 | ConfigurationSettingsReader(String) | Initializes a new instance of the ConfigurationSettingsReader class.
 | AttachToComponentRegistration(IContainer, IComponentRegistration) | Attach the module to a registration either already existing in or being registered in the container. (Inherited from Module.)
 | Configure(IContainer) | Apply the module to the container. (Inherited from Module.)
 | DefaultSectionName | The default section name that will be searched for.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(ContainerBuilder) | Override to add registrations to the container. (Overrides Module.Load(ContainerBuilder).)
 | LoadType(String, Assembly) | Loads the type.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SectionHandler | Gets the section handler.
 | SetInjectProperties(ComponentElement, IReflectiveRegistrar) | Sets the property injection mode for the component.
 | SetOwnership(ComponentElement, IReflectiveRegistrar) | Sets the ownership model of the component.
 | SetScope(ComponentElement, IReflectiveRegistrar) | Sets the scope model for the component.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Module
 |  | ConfigurationSettingsReader


ConfigurationSettingsReader Constructor

ConfigurationSettingsReader Constructor
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► ConfigurationSettingsReader()()()
Members
Icon | Member | Description
 | ConfigurationSettingsReader()()() | Initializes a new instance of the ConfigurationSettingsReader class. The reader will look for a 'autofac' section.
 | ConfigurationSettingsReader(String, String) | Initializes a new instance of the ConfigurationSettingsReader class.
 | ConfigurationSettingsReader(String) | Initializes a new instance of the ConfigurationSettingsReader class.


ConfigurationSettingsReader Constructor

ConfigurationSettingsReader Constructor
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► ConfigurationSettingsReader()()()
Initializes a new instance of the ConfigurationSettingsReader class. The reader will look for a 'autofac' section.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationSettingsReader()
Public Sub New
public:
ConfigurationSettingsReader()


ConfigurationSettingsReader Constructor (sectionName)

ConfigurationSettingsReader Constructor (sectionName)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► ConfigurationSettingsReader(String)
Initializes a new instance of the ConfigurationSettingsReader class.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationSettingsReader(
    string sectionName
)
Public Sub New ( _
    sectionName As String _
)
public:
ConfigurationSettingsReader(
    String^ sectionName
)
Parameters
sectionName (String)
Name of the configuration section.


ConfigurationSettingsReader Constructor (sectionName, configurationFile)

ConfigurationSettingsReader Constructor (sectionName, configurationFile)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► ConfigurationSettingsReader(String, String)
Initializes a new instance of the ConfigurationSettingsReader class.
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationSettingsReader(
    string sectionName,
    string configurationFile
)
Public Sub New ( _
    sectionName As String, _
    configurationFile As String _
)
public:
ConfigurationSettingsReader(
    String^ sectionName,
    String^ configurationFile
)
Parameters
sectionName (String)
Name of the configuration section.
configurationFile (String)
The configuration file.


DefaultSectionName Field

DefaultSectionName Field
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► DefaultSectionName
The default section name that will be searched for.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultSectionName
Public Const DefaultSectionName As String
public:
literal String^ DefaultSectionName


Load Method (builder)

Load Method (builder)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► Load(ContainerBuilder)
Override to add registrations to the container.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Load(
    ContainerBuilder builder
)
Protected Overrides Sub Load ( _
    builder As ContainerBuilder _
)
protected:
virtual void Load(
    ContainerBuilder^ builder
) override
Parameters
builder (ContainerBuilder)
The builder.


LoadType Method (typeName, defaultAssembly)

LoadType Method (typeName, defaultAssembly)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► LoadType(String, Assembly)
Loads the type.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Type LoadType(
    string typeName,
    Assembly defaultAssembly
)
Protected Overridable Function LoadType ( _
    typeName As String, _
    defaultAssembly As Assembly _
) As Type
protected:
virtual Type^ LoadType(
    String^ typeName,
    Assembly^ defaultAssembly
)
Parameters
typeName (String)
Name of the type.
defaultAssembly (Assembly)
The default assembly.
Return Value

[Missing <returns> documentation for M:Autofac.Configuration.ConfigurationSettingsReader.LoadType(System.String,System.Reflection.Assembly)]


SectionHandler Property

SectionHandler Property
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► SectionHandler
Gets the section handler.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual SectionHandler SectionHandler { get; }
Protected Overridable ReadOnly Property SectionHandler As SectionHandler
protected:
virtual property SectionHandler^ SectionHandler {
    SectionHandler^ get ();
}
Value
The section handler.


SetInjectProperties Method (component, registrar)

SetInjectProperties Method (component, registrar)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► SetInjectProperties(ComponentElement, IReflectiveRegistrar)
Sets the property injection mode for the component.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SetInjectProperties(
    ComponentElement component,
    IReflectiveRegistrar registrar
)
Protected Overridable Sub SetInjectProperties ( _
    component As ComponentElement, _
    registrar As IReflectiveRegistrar _
)
protected:
virtual void SetInjectProperties(
    ComponentElement^ component,
    IReflectiveRegistrar^ registrar
)
Parameters
component (ComponentElement)
The component.
registrar (IReflectiveRegistrar)
The registrar.


SetOwnership Method (component, registrar)

SetOwnership Method (component, registrar)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► SetOwnership(ComponentElement, IReflectiveRegistrar)
Sets the ownership model of the component.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SetOwnership(
    ComponentElement component,
    IReflectiveRegistrar registrar
)
Protected Overridable Sub SetOwnership ( _
    component As ComponentElement, _
    registrar As IReflectiveRegistrar _
)
protected:
virtual void SetOwnership(
    ComponentElement^ component,
    IReflectiveRegistrar^ registrar
)
Parameters
component (ComponentElement)
The component.
registrar (IReflectiveRegistrar)
The registrar.


SetScope Method (component, registrar)

SetScope Method (component, registrar)
Namespaces ► Autofac.Configuration ► ConfigurationSettingsReader ► SetScope(ComponentElement, IReflectiveRegistrar)
Sets the scope model for the component.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SetScope(
    ComponentElement component,
    IReflectiveRegistrar registrar
)
Protected Overridable Sub SetScope ( _
    component As ComponentElement, _
    registrar As IReflectiveRegistrar _
)
protected:
virtual void SetScope(
    ComponentElement^ component,
    IReflectiveRegistrar^ registrar
)
Parameters
component (ComponentElement)
The component.
registrar (IReflectiveRegistrar)
The registrar.


ExtendedPropertyElement Class

ExtendedPropertyElement Class
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement
Element describing a component property.
Declaration Syntax
C# Visual Basic Visual C++
public class ExtendedPropertyElement : ConfigurationElement
Public Class ExtendedPropertyElement _
    Inherits ConfigurationElement
public ref class ExtendedPropertyElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedPropertyElement()()() | Initializes a new instance of the ExtendedPropertyElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the property.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type of the value.
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
 | Value | Gets the value to be set (will be converted.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ExtendedPropertyElement


ExtendedPropertyElement Constructor

ExtendedPropertyElement Constructor
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement ► ExtendedPropertyElement()()()
Initializes a new instance of the ExtendedPropertyElement class
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPropertyElement()
Public Sub New
public:
ExtendedPropertyElement()


Name Property

Name Property
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement ► Name
Gets the name of the property.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
The name.


Type Property

Type Property
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement ► Type
Gets the type of the value.
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; }
Public ReadOnly Property Type As String
public:
property String^ Type {
    String^ get ();
}
Value
The type of the value. Defaults to string if not specified.


Value Property

Value Property
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement ► Value
Gets the value to be set (will be converted.)
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; }
Public ReadOnly Property Value As String
public:
property String^ Value {
    String^ get ();
}
Value
The value.


ExtendedPropertyElementCollection Class

ExtendedPropertyElementCollection Class
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection
Collection of extended property elements.
Declaration Syntax
C# Visual Basic Visual C++
public class ExtendedPropertyElementCollection : NamedConfigurationElementCollection<ExtendedPropertyElement>
Public Class ExtendedPropertyElementCollection _
    Inherits NamedConfigurationElementCollection(Of ExtendedPropertyElement)
public ref class ExtendedPropertyElementCollection : public NamedConfigurationElementCollection<ExtendedPropertyElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedPropertyElementCollection()()() | Initializes a new instance of the PropertyElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( ExtendedPropertyElement >)>)
 |  |  |  | ExtendedPropertyElementCollection


ExtendedPropertyElementCollection Constructor

ExtendedPropertyElementCollection Constructor
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection ► ExtendedPropertyElementCollection()()()
Initializes a new instance of the PropertyElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPropertyElementCollection()
Public Sub New
public:
ExtendedPropertyElementCollection()


FileElement Class

FileElement Class
Namespaces ► Autofac.Configuration ► FileElement
Element describing an additional configuration file.
Declaration Syntax
C# Visual Basic Visual C++
public class FileElement : ConfigurationElement
Public Class FileElement _
    Inherits ConfigurationElement
public ref class FileElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileElement()()() | Initializes a new instance of the FileElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the filename of the file.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | Section | Gets the section name of the section in the configuration file.
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | FileElement


FileElement Constructor

FileElement Constructor
Namespaces ► Autofac.Configuration ► FileElement ► FileElement()()()
Initializes a new instance of the FileElement class
Declaration Syntax
C# Visual Basic Visual C++
public FileElement()
Public Sub New
public:
FileElement()


Name Property

Name Property
Namespaces ► Autofac.Configuration ► FileElement ► Name
Gets the filename of the file.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
The filename.


Section Property

Section Property
Namespaces ► Autofac.Configuration ► FileElement ► Section
Gets the section name of the section in the configuration file.
Declaration Syntax
C# Visual Basic Visual C++
public string Section { get; }
Public ReadOnly Property Section As String
public:
property String^ Section {
    String^ get ();
}
Value
The section name.


FileElementCollection Class

FileElementCollection Class
Namespaces ► Autofac.Configuration ► FileElementCollection
A collection of file elements.
Declaration Syntax
C# Visual Basic Visual C++
public class FileElementCollection : NamedConfigurationElementCollection<FileElement>
Public Class FileElementCollection _
    Inherits NamedConfigurationElementCollection(Of FileElement)
public ref class FileElementCollection : public NamedConfigurationElementCollection<FileElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileElementCollection()()() | Initializes a new instance of the FileElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( FileElement >)>)
 |  |  |  | FileElementCollection


FileElementCollection Constructor

FileElementCollection Constructor
Namespaces ► Autofac.Configuration ► FileElementCollection ► FileElementCollection()()()
Initializes a new instance of the FileElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public FileElementCollection()
Public Sub New
public:
FileElementCollection()


ModuleElement Class

ModuleElement Class
Namespaces ► Autofac.Configuration ► ModuleElement
Element describing a module registration.
Declaration Syntax
C# Visual Basic Visual C++
public class ModuleElement : ConfigurationElement
Public Class ModuleElement _
    Inherits ConfigurationElement
public ref class ModuleElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModuleElement()()() | Initializes a new instance of the ModuleElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ExplicitProperties | Gets the properties to be explicitly set on the component.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | Parameters | Gets the parameters used to construct the component.
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type of the module. Must expose IModule.
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ModuleElement


ModuleElement Constructor

ModuleElement Constructor
Namespaces ► Autofac.Configuration ► ModuleElement ► ModuleElement()()()
Initializes a new instance of the ModuleElement class
Declaration Syntax
C# Visual Basic Visual C++
public ModuleElement()
Public Sub New
public:
ModuleElement()


ExplicitProperties Property

ExplicitProperties Property
Namespaces ► Autofac.Configuration ► ModuleElement ► ExplicitProperties
Gets the properties to be explicitly set on the component.
Declaration Syntax
C# Visual Basic Visual C++
public PropertyElementCollection ExplicitProperties { get; }
Public ReadOnly Property ExplicitProperties As PropertyElementCollection
public:
property PropertyElementCollection^ ExplicitProperties {
    PropertyElementCollection^ get ();
}
Value
The explicit properties.


Parameters Property

Parameters Property
Namespaces ► Autofac.Configuration ► ModuleElement ► Parameters
Gets the parameters used to construct the component.
Declaration Syntax
C# Visual Basic Visual C++
public ParameterElementCollection Parameters { get; }
Public ReadOnly Property Parameters As ParameterElementCollection
public:
property ParameterElementCollection^ Parameters {
    ParameterElementCollection^ get ();
}
Value
The parameters.


Type Property

Type Property
Namespaces ► Autofac.Configuration ► ModuleElement ► Type
Gets the type of the module. Must expose IModule.
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; }
Public ReadOnly Property Type As String
public:
property String^ Type {
    String^ get ();
}
Value
The type.


ModuleElementCollection Class

ModuleElementCollection Class
Namespaces ► Autofac.Configuration ► ModuleElementCollection
A collection of module elements.
Declaration Syntax
C# Visual Basic Visual C++
public class ModuleElementCollection : NamedConfigurationElementCollection<ModuleElement>
Public Class ModuleElementCollection _
    Inherits NamedConfigurationElementCollection(Of ModuleElement)
public ref class ModuleElementCollection : public NamedConfigurationElementCollection<ModuleElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModuleElementCollection()()() | Initializes a new instance of the ModuleElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( ModuleElement >)>)
 |  |  |  | ModuleElementCollection


ModuleElementCollection Constructor

ModuleElementCollection Constructor
Namespaces ► Autofac.Configuration ► ModuleElementCollection ► ModuleElementCollection()()()
Initializes a new instance of the ModuleElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public ModuleElementCollection()
Public Sub New
public:
ModuleElementCollection()


NamedConfigurationElementCollection(TElementType) Class

NamedConfigurationElementCollection<(Of <(TElementType>)>) Class
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>)
Base for multi-valued configuration elements.
Declaration Syntax
C# Visual Basic Visual C++
public class NamedConfigurationElementCollection<TElementType> : ConfigurationElementCollection,
    IEnumerable<TElementType>, IEnumerable
where TElementType : ConfigurationElement

Public Class NamedConfigurationElementCollection(Of TElementType As ConfigurationElement) _
    Inherits ConfigurationElementCollection _
    Implements IEnumerable(Of TElementType), IEnumerable
generic<typename TElementType>
where TElementType : ConfigurationElement
public ref class NamedConfigurationElementCollection : public ConfigurationElementCollection,
    IEnumerable<TElementType>, IEnumerable
Generic Template Parameters
TElementType

[Missing <typeparam name="TElementType"/> documentation for "T:Autofac.Configuration.NamedConfigurationElementCollection`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamedConfigurationElementCollection<(Of <(TElementType>)>)(String, String) | Initializes a new instance of the NamedConfigurationElementCollection<(Of <(TElementType>)>) class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Overrides ConfigurationElementCollection.CollectionType.)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Overrides ConfigurationElementCollection.ElementName.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Overrides ConfigurationElementCollection.GetElementKey(ConfigurationElement).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Overrides ConfigurationElementCollection.IsElementName(String).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection<(Of <(TElementType>)>)
 |  |  |  | ComponentElementCollection
 |  |  |  | ExtendedPropertyElementCollection
 |  |  |  | FileElementCollection
 |  |  |  | ModuleElementCollection
 |  |  |  | ParameterElementCollection
 |  |  |  | PropertyElementCollection
 |  |  |  | ServiceElementCollection


NamedConfigurationElementCollection(TElementType) Constructor (elementName, elementKey)

NamedConfigurationElementCollection<(Of <(TElementType>)>) Constructor (elementName, elementKey)
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► NamedConfigurationElementCollection<(Of <(TElementType>)>)(String, String)
Initializes a new instance of the NamedConfigurationElementCollection<(Of <(TElementType>)>) class.
Declaration Syntax
C# Visual Basic Visual C++
protected NamedConfigurationElementCollection(
    string elementName,
    string elementKey
)
Protected Sub New ( _
    elementName As String, _
    elementKey As String _
)
protected:
NamedConfigurationElementCollection(
    String^ elementName,
    String^ elementKey
)
Parameters
elementName (String)
Name of the element.
elementKey (String)
The element key.


CollectionType Property

CollectionType Property
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► CollectionType
Gets the type of the ConfigurationElementCollection.
Declaration Syntax
C# Visual Basic Visual C++
public override ConfigurationElementCollectionType CollectionType { get; }
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType
public:
virtual property ConfigurationElementCollectionType CollectionType {
    ConfigurationElementCollectionType get () override;
}
Value
Return Value
The ConfigurationElementCollectionType of this collection.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► CreateNewElement()()()
Creates a new ConfigurationElement.
Declaration Syntax
C# Visual Basic Visual C++
protected override ConfigurationElement CreateNewElement()
Protected Overrides Function CreateNewElement As ConfigurationElement
protected:
virtual ConfigurationElement^ CreateNewElement() override
Return Value
A new ConfigurationElement.


ElementName Property

ElementName Property
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► ElementName
Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class.
Declaration Syntax
C# Visual Basic Visual C++
protected override string ElementName { get; }
Protected Overrides ReadOnly Property ElementName As String
protected:
virtual property String^ ElementName {
    String^ get () override;
}
Value
Return Value
The name of the collection; otherwise, an empty string. The default is an empty string.


GetElementKey Method (element)

GetElementKey Method (element)
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► GetElementKey(ConfigurationElement)
Gets the element key for a specified configuration element when overridden in a derived class.
Declaration Syntax
C# Visual Basic Visual C++
protected override Object GetElementKey(
    ConfigurationElement element
)
Protected Overrides Function GetElementKey ( _
    element As ConfigurationElement _
) As Object
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override
Parameters
element (ConfigurationElement)
The ConfigurationElement to return the key for.
Return Value
An Object that acts as the key for the specified ConfigurationElement.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<TElementType> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TElementType)
public:
virtual IEnumerator<TElementType>^ GetEnumerator() sealed
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


IsElementName Method (elementName)

IsElementName Method (elementName)
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► IsElementName(String)
Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool IsElementName(
    string elementName
)
Protected Overrides Function IsElementName ( _
    elementName As String _
) As Boolean
protected:
virtual bool IsElementName(
    String^ elementName
) override
Parameters
elementName (String)
The name of the element to verify.
Return Value
true if the element exists in the collection; otherwise, false. The default is false.


Item Property (index)

Item Property (index)
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► Item[([(Int32])])
Gets or sets the TElementType at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public TElementType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TElementType
public:
property TElementType default[int index] {
    TElementType get (int index);
    void set (int index, TElementType value);
}
Parameters
index (Int32)
Value


ParameterElement Class

ParameterElement Class
Namespaces ► Autofac.Configuration ► ParameterElement
Element describing a component constructor parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class ParameterElement : ConfigurationElement
Public Class ParameterElement _
    Inherits ConfigurationElement
public ref class ParameterElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParameterElement()()() | Initializes a new instance of the ParameterElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the parameter.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
 | Value | Gets the value used to set the parameter (type will be converted.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ParameterElement


ParameterElement Constructor

ParameterElement Constructor
Namespaces ► Autofac.Configuration ► ParameterElement ► ParameterElement()()()
Initializes a new instance of the ParameterElement class
Declaration Syntax
C# Visual Basic Visual C++
public ParameterElement()
Public Sub New
public:
ParameterElement()


Name Property

Name Property
Namespaces ► Autofac.Configuration ► ParameterElement ► Name
Gets the name of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
The name.


Value Property

Value Property
Namespaces ► Autofac.Configuration ► ParameterElement ► Value
Gets the value used to set the parameter (type will be converted.)
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; }
Public ReadOnly Property Value As String
public:
property String^ Value {
    String^ get ();
}
Value
The value.


ParameterElementCollection Class

ParameterElementCollection Class
Namespaces ► Autofac.Configuration ► ParameterElementCollection
A collection of parameter elements.
Declaration Syntax
C# Visual Basic Visual C++
public class ParameterElementCollection : NamedConfigurationElementCollection<ParameterElement>
Public Class ParameterElementCollection _
    Inherits NamedConfigurationElementCollection(Of ParameterElement)
public ref class ParameterElementCollection : public NamedConfigurationElementCollection<ParameterElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParameterElementCollection()()() | Initializes a new instance of the ParameterElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToParameters()()() | Convert to the Autofac parameter type.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( ParameterElement >)>)
 |  |  |  | ParameterElementCollection


ParameterElementCollection Constructor

ParameterElementCollection Constructor
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► ParameterElementCollection()()()
Initializes a new instance of the ParameterElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public ParameterElementCollection()
Public Sub New
public:
ParameterElementCollection()


ToParameters Method

ToParameters Method
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► ToParameters()()()
Convert to the Autofac parameter type.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<Parameter> ToParameters()
Public Function ToParameters As IEnumerable(Of Parameter)
public:
IEnumerable<Parameter^>^ ToParameters()
Return Value
The parameters represented by this collection.


PropertyElement Class

PropertyElement Class
Namespaces ► Autofac.Configuration ► PropertyElement
Element describing a component property.
Declaration Syntax
C# Visual Basic Visual C++
public class PropertyElement : ConfigurationElement
Public Class PropertyElement _
    Inherits ConfigurationElement
public ref class PropertyElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertyElement()()() | Initializes a new instance of the PropertyElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the property.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
 | Value | Gets the value to be set (will be converted.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | PropertyElement


PropertyElement Constructor

PropertyElement Constructor
Namespaces ► Autofac.Configuration ► PropertyElement ► PropertyElement()()()
Initializes a new instance of the PropertyElement class
Declaration Syntax
C# Visual Basic Visual C++
public PropertyElement()
Public Sub New
public:
PropertyElement()


Name Property

Name Property
Namespaces ► Autofac.Configuration ► PropertyElement ► Name
Gets the name of the property.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
The name.


Value Property

Value Property
Namespaces ► Autofac.Configuration ► PropertyElement ► Value
Gets the value to be set (will be converted.)
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; }
Public ReadOnly Property Value As String
public:
property String^ Value {
    String^ get ();
}
Value
The value.


PropertyElementCollection Class

PropertyElementCollection Class
Namespaces ► Autofac.Configuration ► PropertyElementCollection
Collection of property elements.
Declaration Syntax
C# Visual Basic Visual C++
public class PropertyElementCollection : NamedConfigurationElementCollection<PropertyElement>
Public Class PropertyElementCollection _
    Inherits NamedConfigurationElementCollection(Of PropertyElement)
public ref class PropertyElementCollection : public NamedConfigurationElementCollection<PropertyElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertyElementCollection()()() | Initializes a new instance of the PropertyElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToParameters()()() | Convert to the Autofac parameter type.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( PropertyElement >)>)
 |  |  |  | PropertyElementCollection


PropertyElementCollection Constructor

PropertyElementCollection Constructor
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► PropertyElementCollection()()()
Initializes a new instance of the PropertyElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public PropertyElementCollection()
Public Sub New
public:
PropertyElementCollection()


ToParameters Method

ToParameters Method
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► ToParameters()()()
Convert to the Autofac parameter type.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<NamedPropertyParameter> ToParameters()
Public Function ToParameters As IEnumerable(Of NamedPropertyParameter)
public:
IEnumerable<NamedPropertyParameter^>^ ToParameters()
Return Value
The parameters represented by this collection.


SectionHandler Class

SectionHandler Class
Namespaces ► Autofac.Configuration ► SectionHandler
Section handler for Autofac configuration in app.config files.
Declaration Syntax
C# Visual Basic Visual C++
public class SectionHandler : ConfigurationSection
Public Class SectionHandler _
    Inherits ConfigurationSection
public ref class SectionHandler : public ConfigurationSection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SectionHandler()()() | Initializes a new instance of the SectionHandler class
 | Components | Gets the components to be registered.
 | DefaultAssembly | Gets the default assembly to search for types in when not explicitly provided with the type name.
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | DeserializeSection(XmlReader) | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Files | Gets additional configuration files.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetRuntimeObject()()() | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modules | Gets the modules to be registered.
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
 | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeSection(ConfigurationElement, String, ConfigurationSaveMode) | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationSection
 |  |  | SectionHandler


SectionHandler Constructor

SectionHandler Constructor
Namespaces ► Autofac.Configuration ► SectionHandler ► SectionHandler()()()
Initializes a new instance of the SectionHandler class
Declaration Syntax
C# Visual Basic Visual C++
public SectionHandler()
Public Sub New
public:
SectionHandler()


Components Property

Components Property
Namespaces ► Autofac.Configuration ► SectionHandler ► Components
Gets the components to be registered.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentElementCollection Components { get; }
Public ReadOnly Property Components As ComponentElementCollection
public:
property ComponentElementCollection^ Components {
    ComponentElementCollection^ get ();
}
Value
The components.


DefaultAssembly Property

DefaultAssembly Property
Namespaces ► Autofac.Configuration ► SectionHandler ► DefaultAssembly
Gets the default assembly to search for types in when not explicitly provided with the type name.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string DefaultAssembly { get; }
Public Overridable ReadOnly Property DefaultAssembly As String
public:
virtual property String^ DefaultAssembly {
    String^ get ();
}
Value
The default assembly.


Files Property

Files Property
Namespaces ► Autofac.Configuration ► SectionHandler ► Files
Gets additional configuration files.
Declaration Syntax
C# Visual Basic Visual C++
public FileElementCollection Files { get; }
Public ReadOnly Property Files As FileElementCollection
public:
property FileElementCollection^ Files {
    FileElementCollection^ get ();
}
Value
The files.


Modules Property

Modules Property
Namespaces ► Autofac.Configuration ► SectionHandler ► Modules
Gets the modules to be registered.
Declaration Syntax
C# Visual Basic Visual C++
public ModuleElementCollection Modules { get; }
Public ReadOnly Property Modules As ModuleElementCollection
public:
property ModuleElementCollection^ Modules {
    ModuleElementCollection^ get ();
}
Value
The modules.


ServiceElement Class

ServiceElement Class
Namespaces ► Autofac.Configuration ► ServiceElement
Element describing a service exposed by a component.
Declaration Syntax
C# Visual Basic Visual C++
public class ServiceElement : ConfigurationElement
Public Class ServiceElement _
    Inherits ConfigurationElement
public ref class ServiceElement : public ConfigurationElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceElement()()() | Initializes a new instance of the ServiceElement class
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | Equals(Object) | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsModified()()() | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | Reset(ConfigurationElement) | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
 | ResetModified()()() | Resets the value of the IsModified()()() method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeElement(XmlWriter, Boolean) | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the service type.
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ServiceElement


ServiceElement Constructor

ServiceElement Constructor
Namespaces ► Autofac.Configuration ► ServiceElement ► ServiceElement()()()
Initializes a new instance of the ServiceElement class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceElement()
Public Sub New
public:
ServiceElement()


Type Property

Type Property
Namespaces ► Autofac.Configuration ► ServiceElement ► Type
Gets the service type.
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; }
Public ReadOnly Property Type As String
public:
property String^ Type {
    String^ get ();
}
Value
The type.


ServiceElementCollection Class

ServiceElementCollection Class
Namespaces ► Autofac.Configuration ► ServiceElementCollection
A collection of service elements.
Declaration Syntax
C# Visual Basic Visual C++
public class ServiceElementCollection : NamedConfigurationElementCollection<ServiceElement>
Public Class ServiceElementCollection _
    Inherits NamedConfigurationElementCollection(Of ServiceElement)
public ref class ServiceElementCollection : public NamedConfigurationElementCollection<ServiceElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceElementCollection()()() | Initializes a new instance of the ServiceElementCollection class.
 | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
 | BaseClear()()() | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
 | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseGetAllKeys()()() | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseGetKey(Int32) | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | BaseIndexOf(ConfigurationElement) | The index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
 | BaseIsRemoved(Object) | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | BaseRemove(Object) | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
 | BaseRemoveAt(Int32) | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
 | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CopyTo(array<ConfigurationElement>[]()[], Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
 | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | DeserializeElement(XmlReader, Boolean) | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
 | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
 | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
 | Equals(Object) | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
 | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementKey(ConfigurationElement) | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | GetHashCode()()() | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
 | InitializeDefault()()() | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
 | IsElementName(String) | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | IsElementRemovable(ConfigurationElement) | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | IsModified()()() | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | IsReadOnly()()() | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ConfigurationElementCollection.)
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index. (Inherited from NamedConfigurationElementCollection<(Of <(TElementType>)>).)
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | ListErrors(IList) | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
 | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
 | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
 | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
 | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializeUnrecognizedAttribute(String, String) | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
 | OnDeserializeUnrecognizedElement(String, XmlReader) | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
 | OnRequiredPropertyNotFound(String) | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
 | PostDeserialize()()() | Called after deserialization. (Inherited from ConfigurationElement.)
 | PreSerialize(XmlWriter) | Called before serialization. (Inherited from ConfigurationElement.)
 | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | Reset(ConfigurationElement) | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | ResetModified()()() | Resets the value of the IsModified()()() property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeElement(XmlWriter, Boolean) | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
 | SerializeToXmlElement(XmlWriter, String) | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
 | SetPropertyValue(ConfigurationProperty, Object, Boolean) | Sets a property to the specified value. (Inherited from ConfigurationElement.)
 | SetReadOnly()()() | Sets the IsReadOnly()()() property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
 | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
 | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unmerge(ConfigurationElement, ConfigurationElement, ConfigurationSaveMode) | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Inheritance Hierarchy
Object
 | ConfigurationElement
 |  | ConfigurationElementCollection
 |  |  | NamedConfigurationElementCollection <(Of <( ServiceElement >)>)
 |  |  |  | ServiceElementCollection


ServiceElementCollection Constructor

ServiceElementCollection Constructor
Namespaces ► Autofac.Configuration ► ServiceElementCollection ► ServiceElementCollection()()()
Initializes a new instance of the ServiceElementCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public ServiceElementCollection()
Public Sub New
public:
ServiceElementCollection()


Autofac.GeneratedFactories Namespace

Autofac.GeneratedFactories Namespace
Namespaces ► Autofac.GeneratedFactories

[Missing <summary> documentation for N:Autofac.GeneratedFactories]

Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.GeneratedFactories
Namespace Autofac.GeneratedFactories
namespace Autofac.GeneratedFactories
Types
All Types Classes
Icon | Type | Description
 | FactoryGenerator<(Of <(TDelegate>)>) | Generates context-bound closures that represent factories from a set of heuristics based on delegate type signatures.


FactoryGenerator(TDelegate) Class

FactoryGenerator<(Of <(TDelegate>)>) Class
Namespaces ► Autofac.GeneratedFactories ► FactoryGenerator<(Of <(TDelegate>)>)
Generates context-bound closures that represent factories from a set of heuristics based on delegate type signatures.
Declaration Syntax
C# Visual Basic Visual C++
public class FactoryGenerator<TDelegate>

Public Class FactoryGenerator(Of TDelegate)
generic<typename TDelegate>
public ref class FactoryGenerator
Generic Template Parameters
TDelegate
The factory delegate type.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FactoryGenerator<(Of <(TDelegate>)>)(Service) | Create a factory generator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateFactory(IContext, IEnumerable<(Of <(Parameter>)>)) | Generates a factory delegate that closes over the provided context.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FactoryGenerator<(Of <(TDelegate>)>)


FactoryGenerator(TDelegate) Constructor (service)

FactoryGenerator<(Of <(TDelegate>)>) Constructor (service)
Namespaces ► Autofac.GeneratedFactories ► FactoryGenerator<(Of <(TDelegate>)>) ► FactoryGenerator<(Of <(TDelegate>)>)(Service)
Create a factory generator.
Declaration Syntax
C# Visual Basic Visual C++
public FactoryGenerator(
    Service service
)
Public Sub New ( _
    service As Service _
)
public:
FactoryGenerator(
    Service^ service
)
Parameters
service (Service)
The service that will be resolved in order to create the products of the factory.


GenerateFactory Method (context, parameters)

GenerateFactory Method (context, parameters)
Namespaces ► Autofac.GeneratedFactories ► FactoryGenerator<(Of <(TDelegate>)>) ► GenerateFactory(IContext, IEnumerable<(Of <(Parameter>)>))
Generates a factory delegate that closes over the provided context.
Declaration Syntax
C# Visual Basic Visual C++
public TDelegate GenerateFactory(
    IContext context,
    IEnumerable<Parameter> parameters
)
Public Function GenerateFactory ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As TDelegate
public:
TDelegate GenerateFactory(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
)
Parameters
context (IContext)
The context in which the factory will be used.
parameters (IEnumerable <(Of <( Parameter >)>))
Parameters provided to the resolve call for the factory itself.
Return Value
A factory delegate that will work within the context.


Autofac.Modules Namespace

Autofac.Modules Namespace
Namespaces ► Autofac.Modules

[Missing <summary> documentation for N:Autofac.Modules]

Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Modules
Namespace Autofac.Modules
namespace Autofac.Modules
Types
All Types Classes
Icon | Type | Description
 | ImplicitCollectionSupportModule | Configures the container so that requests for IEnumerable{T} or T[] will result in all of the available instances of T being returned.


ImplicitCollectionSupportModule Class

ImplicitCollectionSupportModule Class
Namespaces ► Autofac.Modules ► ImplicitCollectionSupportModule
Configures the container so that requests for IEnumerable{T} or T[] will result in all of the available instances of T being returned.
Declaration Syntax
C# Visual Basic Visual C++
public class ImplicitCollectionSupportModule : IModule
Public Class ImplicitCollectionSupportModule _
    Implements IModule
public ref class ImplicitCollectionSupportModule : IModule
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImplicitCollectionSupportModule()()() | Initializes a new instance of the ImplicitCollectionSupportModule class
 | Configure(IContainer) | Configures the container.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ImplicitCollectionSupportModule


ImplicitCollectionSupportModule Constructor

ImplicitCollectionSupportModule Constructor
Namespaces ► Autofac.Modules ► ImplicitCollectionSupportModule ► ImplicitCollectionSupportModule()()()
Initializes a new instance of the ImplicitCollectionSupportModule class
Declaration Syntax
C# Visual Basic Visual C++
public ImplicitCollectionSupportModule()
Public Sub New
public:
ImplicitCollectionSupportModule()


Configure Method (container)

Configure Method (container)
Namespaces ► Autofac.Modules ► ImplicitCollectionSupportModule ► Configure(IContainer)
Configures the container.
Declaration Syntax
C# Visual Basic Visual C++
public void Configure(
    IContainer container
)
Public Sub Configure ( _
    container As IContainer _
)
public:
virtual void Configure(
    IContainer^ container
) sealed
Parameters
container (IContainer)
Container to configure.


Autofac.Registrars Namespace

Autofac.Registrars Namespace
Namespaces ► Autofac.Registrars
Builder interfaces used in builder syntax.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars
Namespace Autofac.Registrars
namespace Autofac.Registrars
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | ConcreteRegistrar<(Of <(TSyntax>)>) | Registers a regular component.
 | DeferredRegistrationParameters | Parameters that allow a registration to be created at a later point when one is required.
 | IConcreteRegistrar<(Of <(TSyntax>)>) | A 'concrete' registrar creates IComponentRegistration instances that are registered with the container. This is necessary because some registration types (e.g. Generic) add registrations only on demand through IRegistrationSource and thus do not have unique names within the container.
 | IConcreteRegistrar | A 'concrete' registrar creates IComponentRegistration instances that are registered with the container. This is necessary because some registration types (e.g. Generic) add registrations only on demand through IRegistrationSource and thus do not have unique names within the container.
 | IFluentInterface | Hides standard Object members to make fluent interfaces easier to read. Based on blog post by @kzu here: http://www.clariusconsulting.net/blogs/kzu/archive/2008/03/10/58301.aspx
 | IGenericRegistrar | Provides builder syntax for generic registrations.
 | IReflectiveRegistrar | Adds methods to the IRegistrar interface to add additional information for components created using reflection.
 | IRegistrar<(Of <(TSyntax>)>) | Provides an interface through which a component registration can be incrementally built. Calling any of the methods on this interface after 'Build' has been called on the parent ContainerBuilder will have no effect.
 | ReflectiveRegistrationSource | This class provides a common base for registration handlers that provide reflection-based registrations.
 | RegisteredEventArgs | Fired when a registrar is applied to a container.
 | Registrar<(Of <(TSyntax>)>) | Base class for component registrars.
 | RegistrationCreator | Create the registration.


ConcreteRegistrar(TSyntax) Class

ConcreteRegistrar<(Of <(TSyntax>)>) Class
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>)
Registers a regular component.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ConcreteRegistrar<TSyntax> : Registrar<TSyntax>,
    IModule, IConcreteRegistrar<TSyntax>, IRegistrar<TSyntax>, IFluentInterface
where TSyntax : IConcreteRegistrar<TSyntax>

Public MustInherit Class ConcreteRegistrar(Of TSyntax As IConcreteRegistrar(Of TSyntax)) _
    Inherits Registrar(Of TSyntax) _
    Implements IModule, IConcreteRegistrar(Of TSyntax), IRegistrar(Of TSyntax),  _
    IFluentInterface
generic<typename TSyntax>
where TSyntax : IConcreteRegistrar<TSyntax>
public ref class ConcreteRegistrar abstract : public Registrar<TSyntax>,
    IModule, IConcreteRegistrar<TSyntax>, IRegistrar<TSyntax>, IFluentInterface
Generic Template Parameters
TSyntax

[Missing <typeparam name="TSyntax"/> documentation for "T:Autofac.Registrars.ConcreteRegistrar`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConcreteRegistrar<(Of <(TSyntax>)>)(Type) | Initializes a new instance of the ComponentRegistrar<TComponent> class.
 | ConcreteRegistrar<(Of <(TSyntax>)>)(Type, Service) | Initializes a new instance of the ComponentRegistrar<TComponent> class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Overrides Registrar <(Of <(TSyntax>)>).AddService(Service).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Service>[]()[]) | Change the service associated with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | CreateActivator()()() | Creates the activator for the registration.
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations.
 | DoConfigure(IContainer) | Registers the component. If the component has not been assigned a name, explicit services or a factory delegate, then it will be registered as providing its own type as the default service. (Overrides Registrar <(Of <(TSyntax>)>).DoConfigure(IContainer).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | A unique service identifier that will be associated with the resulting registration.
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Named(String) | Setst the name of the registration.
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Overrides Registrar <(Of <(TSyntax>)>).Services.)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from Registrar<(Of <(TSyntax>)>).)
Inheritance Hierarchy
Object
 | Registrar <(Of <(TSyntax>)>)
 |  | ConcreteRegistrar<(Of <(TSyntax>)>)
 |  |  | DelegateRegistrar
 |  |  | ProvidedInstanceRegistrar
 |  |  | ReflectiveRegistrar


ConcreteRegistrar(TSyntax) Constructor

ConcreteRegistrar<(Of <(TSyntax>)>) Constructor
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► ConcreteRegistrar<(Of <(TSyntax>)>)()()()
Members
Icon | Member | Description
 | ConcreteRegistrar<(Of <(TSyntax>)>)(Type) | Initializes a new instance of the ComponentRegistrar<TComponent> class.
 | ConcreteRegistrar<(Of <(TSyntax>)>)(Type, Service) | Initializes a new instance of the ComponentRegistrar<TComponent> class.


ConcreteRegistrar(TSyntax) Constructor (implementor)

ConcreteRegistrar<(Of <(TSyntax>)>) Constructor (implementor)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► ConcreteRegistrar<(Of <(TSyntax>)>)(Type)
Initializes a new instance of the ComponentRegistrar<TComponent> class.
Declaration Syntax
C# Visual Basic Visual C++
protected ConcreteRegistrar(
    Type implementor
)
Protected Sub New ( _
    implementor As Type _
)
protected:
ConcreteRegistrar(
    Type^ implementor
)
Parameters
implementor (Type)
The implementation type.


ConcreteRegistrar(TSyntax) Constructor (implementor, defaultService)

ConcreteRegistrar<(Of <(TSyntax>)>) Constructor (implementor, defaultService)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► ConcreteRegistrar<(Of <(TSyntax>)>)(Type, Service)
Initializes a new instance of the ComponentRegistrar<TComponent> class.
Declaration Syntax
C# Visual Basic Visual C++
protected ConcreteRegistrar(
    Type implementor,
    Service defaultService
)
Protected Sub New ( _
    implementor As Type, _
    defaultService As Service _
)
protected:
ConcreteRegistrar(
    Type^ implementor,
    Service^ defaultService
)
Parameters
implementor (Type)
The implementation type.
defaultService (Service)
The default service.


AddService Method (service)

AddService Method (service)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► AddService(Service)
Add a service to be exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AddService(
    Service service
)
Protected Overrides Sub AddService ( _
    service As Service _
)
protected:
virtual void AddService(
    Service^ service
) override
Parameters
service (Service)
The service to add.


As Method (services)

As Method (services)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► As(array<Service>[]()[])
Change the service associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public TSyntax As(
    params Service[] services
)
Public Function As ( _
    ParamArray services As Service() _
) As TSyntax
public:
virtual TSyntax As(
    ... array<Service^>^ services
) sealed
Parameters
services (array< Service >[]()[])
The services that the registration will expose.
Return Value
A registrar allowing registration to continue.


CreateActivator Method

CreateActivator Method
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► CreateActivator()()()
Creates the activator for the registration.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract IActivator CreateActivator()
Protected MustOverride Function CreateActivator As IActivator
protected:
virtual IActivator^ CreateActivator() abstract
Return Value
An activator.


DefaultOnly Method

DefaultOnly Method
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► DefaultOnly()()()
Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax DefaultOnly()
Public Overridable Function DefaultOnly As TSyntax
public:
virtual TSyntax DefaultOnly()
Return Value
A registrar allowing registration to continue.


DoConfigure Method (container)

DoConfigure Method (container)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► DoConfigure(IContainer)
Registers the component. If the component has not been assigned a name, explicit services or a factory delegate, then it will be registered as providing its own type as the default service.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DoConfigure(
    IContainer container
)
Protected Overrides Sub DoConfigure ( _
    container As IContainer _
)
protected:
virtual void DoConfigure(
    IContainer^ container
) override
Parameters
container (IContainer)
The container.


Id Property

Id Property
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► Id
A unique service identifier that will be associated with the resulting registration.
Declaration Syntax
C# Visual Basic Visual C++
public Service Id { get; }
Public ReadOnly Property Id As Service
public:
virtual property Service^ Id {
    Service^ get () sealed;
}
Remarks
Only created if accessed.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


MemberOf Method

MemberOf<(Of <(TService>)>) Method
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf<(Of <(TService>)>)()()()
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax MemberOf<TService>()

Public Overridable Function MemberOf(Of TService) As TSyntax
public:
generic<typename TService>
virtual TSyntax MemberOf()
Generic Template Parameters
TService
Type of the service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (service)

MemberOf Method (service)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(Service)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax MemberOf(
    Service service
)
Public Overridable Function MemberOf ( _
    service As Service _
) As TSyntax
public:
virtual TSyntax MemberOf(
    Service^ service
)
Parameters
service (Service)
The service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (serviceName)

MemberOf Method (serviceName)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(String)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax MemberOf(
    string serviceName
)
Public Overridable Function MemberOf ( _
    serviceName As String _
) As TSyntax
public:
virtual TSyntax MemberOf(
    String^ serviceName
)
Parameters
serviceName (String)
Name of the service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (serviceType)

MemberOf Method (serviceType)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(Type)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax MemberOf(
    Type serviceType
)
Public Overridable Function MemberOf ( _
    serviceType As Type _
) As TSyntax
public:
virtual TSyntax MemberOf(
    Type^ serviceType
)
Parameters
serviceType (Type)
Type of the service.
Return Value
A registrar allowing configuration to continue.


Named Method (name)

Named Method (name)
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► Named(String)
Setst the name of the registration.
Declaration Syntax
C# Visual Basic Visual C++
public TSyntax Named(
    string name
)
Public Function Named ( _
    name As String _
) As TSyntax
public:
virtual TSyntax Named(
    String^ name
) sealed
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:Autofac.Registrars.ConcreteRegistrar`1.Named(System.String)"]

Return Value
A registrar allowing configuration to continue.


Services Property

Services Property
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► Services
The services exposed by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected override IEnumerable<Service> Services { get; }
Protected Overrides ReadOnly Property Services As IEnumerable(Of Service)
protected:
virtual property IEnumerable<Service^>^ Services {
    IEnumerable<Service^>^ get () override;
}
Value


DeferredRegistrationParameters Class

DeferredRegistrationParameters Class
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters
Parameters that allow a registration to be created at a later point when one is required.
Declaration Syntax
C# Visual Basic Visual C++
public class DeferredRegistrationParameters
Public Class DeferredRegistrationParameters
public ref class DeferredRegistrationParameters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeferredRegistrationParameters(InstanceOwnership, InstanceScope, IEnumerable<(Of <(EventHandler<(Of <(PreparingEventArgs>)>)>)>), IEnumerable<(Of <(EventHandler<(Of <(ActivatingEventArgs>)>)>)>), IEnumerable<(Of <(EventHandler<(Of <(ActivatedEventArgs>)>)>)>), RegistrationCreator) | Initializes a new instance of the DeferredRegistrationParameters class.
 | ActivatedHandlers | Gets the activated handlers.
 | ActivatingHandlers | Gets the activating handlers.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Ownership | Gets the ownership.
 | PreparingHandlers | Gets the preparing handlers.
 | RegistrationCreator | Gets the registration creator.
 | Scope | Gets the scope.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DeferredRegistrationParameters


DeferredRegistrationParameters Constructor (ownership, scope, preparingHandlers, activatingHandlers, activatedHandlers, createRegistration)

DeferredRegistrationParameters Constructor (ownership, scope, preparingHandlers, activatingHandlers, activatedHandlers, createRegistration)
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► DeferredRegistrationParameters(InstanceOwnership, InstanceScope, IEnumerable<(Of <(EventHandler<(Of <(PreparingEventArgs>)>)>)>), IEnumerable<(Of <(EventHandler<(Of <(ActivatingEventArgs>)>)>)>), IEnumerable<(Of <(EventHandler<(Of <(ActivatedEventArgs>)>)>)>), RegistrationCreator)
Initializes a new instance of the DeferredRegistrationParameters class.
Declaration Syntax
C# Visual Basic Visual C++
public DeferredRegistrationParameters(
    InstanceOwnership ownership,
    InstanceScope scope,
    IEnumerable<EventHandler<PreparingEventArgs>> preparingHandlers,
    IEnumerable<EventHandler<ActivatingEventArgs>> activatingHandlers,
    IEnumerable<EventHandler<ActivatedEventArgs>> activatedHandlers,
    RegistrationCreator createRegistration
)
Public Sub New ( _
    ownership As InstanceOwnership, _
    scope As InstanceScope, _
    preparingHandlers As IEnumerable(Of EventHandler(Of PreparingEventArgs)), _
    activatingHandlers As IEnumerable(Of EventHandler(Of ActivatingEventArgs)), _
    activatedHandlers As IEnumerable(Of EventHandler(Of ActivatedEventArgs)), _
    createRegistration As RegistrationCreator _
)
public:
DeferredRegistrationParameters(
    InstanceOwnership ownership,
    InstanceScope scope,
    IEnumerable<EventHandler<PreparingEventArgs^>^>^ preparingHandlers,
    IEnumerable<EventHandler<ActivatingEventArgs^>^>^ activatingHandlers,
    IEnumerable<EventHandler<ActivatedEventArgs^>^>^ activatedHandlers,
    RegistrationCreator^ createRegistration
)
Parameters
ownership (InstanceOwnership)
The ownership.
scope (InstanceScope)
The scope.
preparingHandlers (IEnumerable <(Of <( EventHandler <(Of <( PreparingEventArgs >)>)>)>))
The preparing handlers.
activatingHandlers (IEnumerable <(Of <( EventHandler <(Of <( ActivatingEventArgs >)>)>)>))
The activating handlers.
activatedHandlers (IEnumerable <(Of <( EventHandler <(Of <( ActivatedEventArgs >)>)>)>))
The activated handlers.
createRegistration (RegistrationCreator)
The create registration.


ActivatedHandlers Property

ActivatedHandlers Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► ActivatedHandlers
Gets the activated handlers.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<EventHandler<ActivatedEventArgs>> ActivatedHandlers { get; }
Public ReadOnly Property ActivatedHandlers As IEnumerable(Of EventHandler(Of ActivatedEventArgs))
public:
property IEnumerable<EventHandler<ActivatedEventArgs^>^>^ ActivatedHandlers {
    IEnumerable<EventHandler<ActivatedEventArgs^>^>^ get ();
}
Value
The handlers.


ActivatingHandlers Property

ActivatingHandlers Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► ActivatingHandlers
Gets the activating handlers.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<EventHandler<ActivatingEventArgs>> ActivatingHandlers { get; }
Public ReadOnly Property ActivatingHandlers As IEnumerable(Of EventHandler(Of ActivatingEventArgs))
public:
property IEnumerable<EventHandler<ActivatingEventArgs^>^>^ ActivatingHandlers {
    IEnumerable<EventHandler<ActivatingEventArgs^>^>^ get ();
}
Value
The handlers.


Ownership Property

Ownership Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► Ownership
Gets the ownership.
Declaration Syntax
C# Visual Basic Visual C++
public InstanceOwnership Ownership { get; }
Public ReadOnly Property Ownership As InstanceOwnership
public:
property InstanceOwnership Ownership {
    InstanceOwnership get ();
}
Value
The ownership.


PreparingHandlers Property

PreparingHandlers Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► PreparingHandlers
Gets the preparing handlers.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<EventHandler<PreparingEventArgs>> PreparingHandlers { get; }
Public ReadOnly Property PreparingHandlers As IEnumerable(Of EventHandler(Of PreparingEventArgs))
public:
property IEnumerable<EventHandler<PreparingEventArgs^>^>^ PreparingHandlers {
    IEnumerable<EventHandler<PreparingEventArgs^>^>^ get ();
}
Value
The handlers.


RegistrationCreator Property

RegistrationCreator Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► RegistrationCreator
Gets the registration creator.
Declaration Syntax
C# Visual Basic Visual C++
public RegistrationCreator RegistrationCreator { get; }
Public ReadOnly Property RegistrationCreator As RegistrationCreator
public:
property RegistrationCreator^ RegistrationCreator {
    RegistrationCreator^ get ();
}
Value
The registration creator.


Scope Property

Scope Property
Namespaces ► Autofac.Registrars ► DeferredRegistrationParameters ► Scope
Gets the scope.
Declaration Syntax
C# Visual Basic Visual C++
public InstanceScope Scope { get; }
Public ReadOnly Property Scope As InstanceScope
public:
property InstanceScope Scope {
    InstanceScope get ();
}
Value
The scope.


IConcreteRegistrar Interface

IConcreteRegistrar Interface
Namespaces ► Autofac.Registrars ► IConcreteRegistrar
A 'concrete' registrar creates IComponentRegistration instances that are registered with the container. This is necessary because some registration types (e.g. Generic) add registrations only on demand through IRegistrationSource and thus do not have unique names within the container.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConcreteRegistrar : IConcreteRegistrar<IConcreteRegistrar>,
    IRegistrar<IConcreteRegistrar>, IFluentInterface
Public Interface IConcreteRegistrar _
    Implements IConcreteRegistrar(Of IConcreteRegistrar), IRegistrar(Of IConcreteRegistrar),  _
    IFluentInterface
public interface class IConcreteRegistrar : IConcreteRegistrar<IConcreteRegistrar^>,
    IRegistrar<IConcreteRegistrar^>, IFluentInterface
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As(array<Service>[]()[]) | Associate services with the registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | Equals(Object) | Standard System.Object member. (Inherited from IFluentInterface.)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | GetType()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | Id | A unique service identifier that will be associated with the resulting registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Type) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Service) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | Named(String) | Associate a name with the registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Calls the provided handler when the registration is made on the container being built. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ToString()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from IRegistrar<(Of <(TSyntax>)>).)


IConcreteRegistrar(TSyntax) Interface

IConcreteRegistrar<(Of <(TSyntax>)>) Interface
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>)
A 'concrete' registrar creates IComponentRegistration instances that are registered with the container. This is necessary because some registration types (e.g. Generic) add registrations only on demand through IRegistrationSource and thus do not have unique names within the container.
Declaration Syntax
C# Visual Basic Visual C++
public interface IConcreteRegistrar<TSyntax> : IRegistrar<TSyntax>,
    IFluentInterface
where TSyntax : Object, IConcreteRegistrar<TSyntax>

Public Interface IConcreteRegistrar(Of TSyntax As {Object, IConcreteRegistrar(Of TSyntax)}) _
    Implements IRegistrar(Of TSyntax), IFluentInterface
generic<typename TSyntax>
where TSyntax : Object, IConcreteRegistrar<TSyntax>
public interface class IConcreteRegistrar : IRegistrar<TSyntax>,
    IFluentInterface
Generic Template Parameters
TSyntax

[Missing <typeparam name="TSyntax"/> documentation for "T:Autofac.Registrars.IConcreteRegistrar`1"]

Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As(array<Service>[]()[]) | Associate services with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations.
 | Equals(Object) | Standard System.Object member. (Inherited from IFluentInterface.)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | GetType()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | Id | A unique service identifier that will be associated with the resulting registration.
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.
 | Named(String) | Associate a name with the registration.
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Calls the provided handler when the registration is made on the container being built. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ToString()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from IRegistrar<(Of <(TSyntax>)>).)


As Method (services)

As Method (services)
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► As(array<Service>[]()[])
Associate services with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax As(
    params Service[] services
)
Function As ( _
    ParamArray services As Service() _
) As TSyntax
TSyntax As(
    ... array<Service^>^ services
)
Parameters
services (array< Service >[]()[])
The services that the registration will expose.
Return Value
A registrar allowing configuration to continue.


DefaultOnly Method

DefaultOnly Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► DefaultOnly()()()
Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax DefaultOnly()
Function DefaultOnly As TSyntax
TSyntax DefaultOnly()
Return Value
A registrar allowing registration to continue.


Id Property

Id Property
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► Id
A unique service identifier that will be associated with the resulting registration.
Declaration Syntax
C# Visual Basic Visual C++
Service Id { get; }
ReadOnly Property Id As Service
property Service^ Id {
    Service^ get ();
}
Examples
var builder = new ContainerBuilder();
var id = builder.Register(c => new Foo()).FactoryScoped().Id;
var container = builder.Build();
var myFoo = container.Resolve(id);
// container.Resolve<Foo>() will also work, but the id guarantees the specific registration


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


MemberOf Method

MemberOf<(Of <(TService>)>) Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf<(Of <(TService>)>)()()()
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax MemberOf<TService>()

Function MemberOf(Of TService) As TSyntax
generic<typename TService>
TSyntax MemberOf()
Generic Template Parameters
TService
Type of the service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (service)

MemberOf Method (service)
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(Service)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax MemberOf(
    Service service
)
Function MemberOf ( _
    service As Service _
) As TSyntax
TSyntax MemberOf(
    Service^ service
)
Parameters
service (Service)
The service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (serviceName)

MemberOf Method (serviceName)
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(String)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax MemberOf(
    string serviceName
)
Function MemberOf ( _
    serviceName As String _
) As TSyntax
TSyntax MemberOf(
    String^ serviceName
)
Parameters
serviceName (String)
Name of the service.
Return Value
A registrar allowing configuration to continue.


MemberOf Method (serviceType)

MemberOf Method (serviceType)
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► MemberOf(Type)
Adds the registration to a previously registered collection.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax MemberOf(
    Type serviceType
)
Function MemberOf ( _
    serviceType As Type _
) As TSyntax
TSyntax MemberOf(
    Type^ serviceType
)
Parameters
serviceType (Type)
Type of the service.
Return Value
A registrar allowing configuration to continue.


Named Method (name)

Named Method (name)
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► Named(String)
Associate a name with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax Named(
    string name
)
Function Named ( _
    name As String _
) As TSyntax
TSyntax Named(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:Autofac.Registrars.IConcreteRegistrar`1.Named(System.String)"]

Return Value
A registrar allowing configuration to continue.


IFluentInterface Interface

IFluentInterface Interface
Namespaces ► Autofac.Registrars ► IFluentInterface
Hides standard Object members to make fluent interfaces easier to read. Based on blog post by @kzu here: http://www.clariusconsulting.net/blogs/kzu/archive/2008/03/10/58301.aspx
Declaration Syntax
C# Visual Basic Visual C++
public interface IFluentInterface
Public Interface IFluentInterface
public interface class IFluentInterface
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Standard System.Object member.
 | GetHashCode()()() | Standard System.Object member.
 | GetType()()() | Standard System.Object member.
 | ToString()()() | Standard System.Object member.


Equals Method (other)

Equals Method (other)
Namespaces ► Autofac.Registrars ► IFluentInterface ► Equals(Object)
Standard System.Object member.
Declaration Syntax
C# Visual Basic Visual C++
bool Equals(
    Object other
)
Function Equals ( _
    other As Object _
) As Boolean
bool Equals(
    Object^ other
)
Parameters
other (Object)
The other.
Return Value
Standard result.


GetHashCode Method

GetHashCode Method
Namespaces ► Autofac.Registrars ► IFluentInterface ► GetHashCode()()()
Standard System.Object member.
Declaration Syntax
C# Visual Basic Visual C++
int GetHashCode()
Function GetHashCode As Integer
int GetHashCode()
Return Value
Standard result.


GetType Method

GetType Method
Namespaces ► Autofac.Registrars ► IFluentInterface ► GetType()()()
Standard System.Object member.
Declaration Syntax
C# Visual Basic Visual C++
Type GetType()
Function GetType As Type
Type^ GetType()
Return Value
Standard result.


ToString Method

ToString Method
Namespaces ► Autofac.Registrars ► IFluentInterface ► ToString()()()
Standard System.Object member.
Declaration Syntax
C# Visual Basic Visual C++
string ToString()
Function ToString As String
String^ ToString()
Return Value
Standard result.


IGenericRegistrar Interface

IGenericRegistrar Interface
Namespaces ► Autofac.Registrars ► IGenericRegistrar
Provides builder syntax for generic registrations.
Declaration Syntax
C# Visual Basic Visual C++
public interface IGenericRegistrar : IRegistrar<IGenericRegistrar>,
    IFluentInterface
Public Interface IGenericRegistrar _
    Implements IRegistrar(Of IGenericRegistrar), IFluentInterface
public interface class IGenericRegistrar : IRegistrar<IGenericRegistrar^>,
    IFluentInterface
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | Equals(Object) | Standard System.Object member. (Inherited from IFluentInterface.)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | GetType()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Calls the provided handler when the registration is made on the container being built. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ToString()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | UsingConstructor(array<Type>[]()[]) | Enforce that the specific constructor with the provided signature is used.
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from IRegistrar<(Of <(TSyntax>)>).)


UsingConstructor Method (ctorSignature)

UsingConstructor Method (ctorSignature)
Namespaces ► Autofac.Registrars ► IGenericRegistrar ► UsingConstructor(array<Type>[]()[])
Enforce that the specific constructor with the provided signature is used.
Declaration Syntax
C# Visual Basic Visual C++
IGenericRegistrar UsingConstructor(
    params Type[] ctorSignature
)
Function UsingConstructor ( _
    ParamArray ctorSignature As Type() _
) As IGenericRegistrar
IGenericRegistrar^ UsingConstructor(
    ... array<Type^>^ ctorSignature
)
Parameters
ctorSignature (array< Type >[]()[])
The types that designate the constructor to use.
Return Value
A registrar allowing registration to continue.


IReflectiveRegistrar Interface

IReflectiveRegistrar Interface
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar
Adds methods to the IRegistrar interface to add additional information for components created using reflection.
Declaration Syntax
C# Visual Basic Visual C++
public interface IReflectiveRegistrar : IConcreteRegistrar<IReflectiveRegistrar>,
    IRegistrar<IReflectiveRegistrar>, IFluentInterface
Public Interface IReflectiveRegistrar _
    Implements IConcreteRegistrar(Of IReflectiveRegistrar), IRegistrar(Of IReflectiveRegistrar),  _
    IFluentInterface
public interface class IReflectiveRegistrar : IConcreteRegistrar<IReflectiveRegistrar^>,
    IRegistrar<IReflectiveRegistrar^>, IFluentInterface
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As<(Of <(TService>)>)()()() | (Inherited from .)
 | As(array<Service>[]()[]) | Associate services with the registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | Equals(Object) | Standard System.Object member. (Inherited from IFluentInterface.)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | GetType()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | Id | A unique service identifier that will be associated with the resulting registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Type) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Service) | Adds the registration to a previously registered collection. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | Named(String) | Associate a name with the registration. (Inherited from IConcreteRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Calls the provided handler when the registration is made on the container being built. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | ToString()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | UsingConstructor(array<Type>[]()[]) | Enforce that the specific constructor with the provided signature is used.
 | WithArguments(array<Parameter>[]()[]) | Associates constructor parameters with default values.
 | WithArguments(IEnumerable<(Of <(Parameter>)>)) | Associates constructor parameters with default values.
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from IRegistrar<(Of <(TSyntax>)>).)
 | WithProperties(array<NamedPropertyParameter>[]()[]) | Provide explicit property values to be set on the new object.
 | WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>)) | Provide explicit property values to be set on the new object.
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from IRegistrar<(Of <(TSyntax>)>).)


UsingConstructor Method (ctorSignature)

UsingConstructor Method (ctorSignature)
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► UsingConstructor(array<Type>[]()[])
Enforce that the specific constructor with the provided signature is used.
Declaration Syntax
C# Visual Basic Visual C++
IReflectiveRegistrar UsingConstructor(
    params Type[] ctorSignature
)
Function UsingConstructor ( _
    ParamArray ctorSignature As Type() _
) As IReflectiveRegistrar
IReflectiveRegistrar^ UsingConstructor(
    ... array<Type^>^ ctorSignature
)
Parameters
ctorSignature (array< Type >[]()[])
The types that designate the constructor to use.
Return Value
A registrar allowing registration to continue.


WithArguments Method

WithArguments Method
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithArguments()()()
Members
Icon | Member | Description
 | WithArguments(array<Parameter>[]()[]) | Associates constructor parameters with default values.
 | WithArguments(IEnumerable<(Of <(Parameter>)>)) | Associates constructor parameters with default values.


WithArguments Method (additionalCtorArgs)

WithArguments Method (additionalCtorArgs)
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithArguments(array<Parameter>[]()[])
Associates constructor parameters with default values.
Declaration Syntax
C# Visual Basic Visual C++
IReflectiveRegistrar WithArguments(
    params Parameter[] additionalCtorArgs
)
Function WithArguments ( _
    ParamArray additionalCtorArgs As Parameter() _
) As IReflectiveRegistrar
IReflectiveRegistrar^ WithArguments(
    ... array<Parameter^>^ additionalCtorArgs
)
Parameters
additionalCtorArgs (array< Parameter >[]()[])
The named values to apply to the constructor. These may be overriden by supplying any/all values to the IContext.Resolve() method.
Return Value
A registrar allowing registration to continue.


WithArguments Method (additionalCtorArgs)

WithArguments Method (additionalCtorArgs)
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithArguments(IEnumerable<(Of <(Parameter>)>))
Associates constructor parameters with default values.
Declaration Syntax
C# Visual Basic Visual C++
IReflectiveRegistrar WithArguments(
    IEnumerable<Parameter> additionalCtorArgs
)
Function WithArguments ( _
    additionalCtorArgs As IEnumerable(Of Parameter) _
) As IReflectiveRegistrar
IReflectiveRegistrar^ WithArguments(
    IEnumerable<Parameter^>^ additionalCtorArgs
)
Parameters
additionalCtorArgs (IEnumerable <(Of <( Parameter >)>))
The named values to apply to the constructor. These may be overriden by supplying any/all values to the IContext.Resolve() method.
Return Value
A registrar allowing registration to continue.


WithProperties Method

WithProperties Method
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithProperties()()()
Members
Icon | Member | Description
 | WithProperties(array<NamedPropertyParameter>[]()[]) | Provide explicit property values to be set on the new object.
 | WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>)) | Provide explicit property values to be set on the new object.


WithProperties Method (explicitProperties)

WithProperties Method (explicitProperties)
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithProperties(array<NamedPropertyParameter>[]()[])
Provide explicit property values to be set on the new object.
Declaration Syntax
C# Visual Basic Visual C++
IReflectiveRegistrar WithProperties(
    params NamedPropertyParameter[] explicitProperties
)
Function WithProperties ( _
    ParamArray explicitProperties As NamedPropertyParameter() _
) As IReflectiveRegistrar
IReflectiveRegistrar^ WithProperties(
    ... array<NamedPropertyParameter^>^ explicitProperties
)
Parameters
explicitProperties (array< NamedPropertyParameter >[]()[])

[Missing <param name="explicitProperties"/> documentation for "M:Autofac.Registrars.IReflectiveRegistrar.WithProperties(Autofac.NamedPropertyParameter[])"]

Return Value
A registrar allowing configuration to continue.
Remarks
Note, supplying a null value will not prevent property injection if property injection is done through an OnActivating handler.


WithProperties Method (explicitProperties)

WithProperties Method (explicitProperties)
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>))
Provide explicit property values to be set on the new object.
Declaration Syntax
C# Visual Basic Visual C++
IReflectiveRegistrar WithProperties(
    IEnumerable<NamedPropertyParameter> explicitProperties
)
Function WithProperties ( _
    explicitProperties As IEnumerable(Of NamedPropertyParameter) _
) As IReflectiveRegistrar
IReflectiveRegistrar^ WithProperties(
    IEnumerable<NamedPropertyParameter^>^ explicitProperties
)
Parameters
explicitProperties (IEnumerable <(Of <( NamedPropertyParameter >)>))

[Missing <param name="explicitProperties"/> documentation for "M:Autofac.Registrars.IReflectiveRegistrar.WithProperties(System.Collections.Generic.IEnumerable{Autofac.NamedPropertyParameter})"]

Return Value
A registrar allowing configuration to continue.
Remarks
Note, supplying a null value will not prevent property injection if property injection is done through an OnActivating handler.


IRegistrar(TSyntax) Interface

IRegistrar<(Of <(TSyntax>)>) Interface
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>)
Provides an interface through which a component registration can be incrementally built. Calling any of the methods on this interface after 'Build' has been called on the parent ContainerBuilder will have no effect.
Declaration Syntax
C# Visual Basic Visual C++
public interface IRegistrar<TSyntax> : IFluentInterface
where TSyntax : Object, IRegistrar<TSyntax>

Public Interface IRegistrar(Of TSyntax As {Object, IRegistrar(Of TSyntax)}) _
    Implements IFluentInterface
generic<typename TSyntax>
where TSyntax : Object, IRegistrar<TSyntax>
public interface class IRegistrar : IFluentInterface
Generic Template Parameters
TSyntax
Self-type.
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As<(Of <(TService1, TService2>)>)()()() | Change the services associated with the registration.
 | As<(Of <(TService1, TService2, TService3>)>)()()() | Change the services associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.
 | ContainerScoped()()() | An instance will be created once per container.
 | Equals(Object) | Standard System.Object member. (Inherited from IFluentInterface.)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed.
 | FactoryScoped()()() | An instance will be created every time one is requested.
 | GetHashCode()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | GetType()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly.
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features.
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state.
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator.
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process.
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Calls the provided handler when the registration is made on the container being built.
 | OwnedByContainer()()() | The instance(s) will be disposed with the container.
 | RegistrationCreator | Gets or sets the registration creator.
 | SingletonScoped()()() | Only one instance will ever be created.
 | ToString()()() | Standard System.Object member. (Inherited from IFluentInterface.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration.
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom.
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared.


As Method

As Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As<(Of <(TService1, TService2>)>)()()() | Change the services associated with the registration.
 | As<(Of <(TService1, TService2, TService3>)>)()()() | Change the services associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


As Method

As<(Of <(TService1, TService2, TService3>)>) Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► As<(Of <(TService1, TService2, TService3>)>)()()()
Change the services associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax As<TService1, TService2, TService3>()

Function As(Of TService1, TService2, TService3) As TSyntax
generic<typename TService1, typename TService2, typename TService3>
TSyntax As()
Generic Template Parameters
TService1
The first service that the registration will expose.
TService2
The second service that the registration will expose.
TService3
The third service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method

As<(Of <(TService1, TService2>)>) Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► As<(Of <(TService1, TService2>)>)()()()
Change the services associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax As<TService1, TService2>()

Function As(Of TService1, TService2) As TSyntax
generic<typename TService1, typename TService2>
TSyntax As()
Generic Template Parameters
TService1
The first service that the registration will expose.
TService2
The second service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method

As<(Of <(TService>)>) Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► As<(Of <(TService>)>)()()()
Change the service associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax As<TService>()

Function As(Of TService) As TSyntax
generic<typename TService>
TSyntax As()
Generic Template Parameters
TService
The service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method (services)

As Method (services)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► As(array<Type>[]()[])
Change the service associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax As(
    params Type[] services
)
Function As ( _
    ParamArray services As Type() _
) As TSyntax
TSyntax As(
    ... array<Type^>^ services
)
Parameters
services (array< Type >[]()[])
The services that the registration will expose.
Return Value
A registrar allowing registration to continue.


ContainerScoped Method

ContainerScoped Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► ContainerScoped()()()
An instance will be created once per container.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax ContainerScoped()
Function ContainerScoped As TSyntax
TSyntax ContainerScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.IRegistrar`1.ContainerScoped]

See Also
CreateInnerContainer()()()


ExternallyOwned Method

ExternallyOwned Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► ExternallyOwned()()()
The instance(s) will not be disposed when the container is disposed.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax ExternallyOwned()
Function ExternallyOwned As TSyntax
TSyntax ExternallyOwned()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.IRegistrar`1.ExternallyOwned]


FactoryScoped Method

FactoryScoped Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► FactoryScoped()()()
An instance will be created every time one is requested.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax FactoryScoped()
Function FactoryScoped As TSyntax
TSyntax FactoryScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.IRegistrar`1.FactoryScoped]


InContext Method (tag)

InContext<(Of <(T>)>) Method (tag)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► InContext<(Of <(T>)>)(T)
Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax InContext<T>(
    T tag
)

Function InContext(Of T) ( _
    tag As T _
) As TSyntax
generic<typename T>
TSyntax InContext(
    T tag
)
Generic Template Parameters
T
The type of the tag.
Parameters
tag (T)
The tag.
Return Value
A registrar allowing registration to continue.


OnActivated Method (handler)

OnActivated Method (handler)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>))
Call the provided handler when an instance is activated. This is the place to perform operations on the activated instance that will use that instance's behaviour/features.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OnActivated(
    EventHandler<ActivatedEventArgs> handler
)
Function OnActivated ( _
    handler As EventHandler(Of ActivatedEventArgs) _
) As TSyntax
TSyntax OnActivated(
    EventHandler<ActivatedEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( ActivatedEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnActivating Method (handler)

OnActivating Method (handler)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>))
Call the provided handler when activating an instance. OnActivating is the place to do work to get an instance into a usable state.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OnActivating(
    EventHandler<ActivatingEventArgs> handler
)
Function OnActivating ( _
    handler As EventHandler(Of ActivatingEventArgs) _
) As TSyntax
TSyntax OnActivating(
    EventHandler<ActivatingEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( ActivatingEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnlyIf Method (containerPredicate)

OnlyIf Method (containerPredicate)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OnlyIf(Predicate<(Of <(IContainer>)>))
Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OnlyIf(
    Predicate<IContainer> containerPredicate
)
Function OnlyIf ( _
    containerPredicate As Predicate(Of IContainer) _
) As TSyntax
TSyntax OnlyIf(
    Predicate<IContainer^>^ containerPredicate
)
Parameters
containerPredicate (Predicate <(Of <( IContainer >)>))
Predicate based on a container.
Return Value
A registrar allowing registration to continue.


OnPreparing Method (handler)

OnPreparing Method (handler)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>))
Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OnPreparing(
    EventHandler<PreparingEventArgs> handler
)
Function OnPreparing ( _
    handler As EventHandler(Of PreparingEventArgs) _
) As TSyntax
TSyntax OnPreparing(
    EventHandler<PreparingEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( PreparingEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnRegistered Method (handler)

OnRegistered Method (handler)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>))
Calls the provided handler when the registration is made on the container being built.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OnRegistered(
    EventHandler<RegisteredEventArgs> handler
)
Function OnRegistered ( _
    handler As EventHandler(Of RegisteredEventArgs) _
) As TSyntax
TSyntax OnRegistered(
    EventHandler<RegisteredEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( RegisteredEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OwnedByContainer Method

OwnedByContainer Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► OwnedByContainer()()()
The instance(s) will be disposed with the container.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax OwnedByContainer()
Function OwnedByContainer As TSyntax
TSyntax OwnedByContainer()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.IRegistrar`1.OwnedByContainer]


RegistrationCreator Property

RegistrationCreator Property
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► RegistrationCreator
Gets or sets the registration creator.
Declaration Syntax
C# Visual Basic Visual C++
RegistrationCreator RegistrationCreator { get; set; }
Property RegistrationCreator As RegistrationCreator
property RegistrationCreator^ RegistrationCreator {
    RegistrationCreator^ get ();
    void set (RegistrationCreator^ value);
}
Value
The registration creator.


SingletonScoped Method

SingletonScoped Method
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► SingletonScoped()()()
Only one instance will ever be created.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax SingletonScoped()
Function SingletonScoped As TSyntax
TSyntax SingletonScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.IRegistrar`1.SingletonScoped]


WithExtendedProperty Method (key, value)

WithExtendedProperty Method (key, value)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► WithExtendedProperty(String, Object)
Associates an extended property with the registration.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax WithExtendedProperty(
    string key,
    Object value
)
Function WithExtendedProperty ( _
    key As String, _
    value As Object _
) As TSyntax
TSyntax WithExtendedProperty(
    String^ key,
    Object^ value
)
Parameters
key (String)
The key.
value (Object)
The value.
Return Value
A registrar allowing registration to continue.


WithOwnership Method (ownership)

WithOwnership Method (ownership)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► WithOwnership(InstanceOwnership)
Change the ownership model associated with the registration. This determines when the instances are disposed and by whom.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax WithOwnership(
    InstanceOwnership ownership
)
Function WithOwnership ( _
    ownership As InstanceOwnership _
) As TSyntax
TSyntax WithOwnership(
    InstanceOwnership ownership
)
Parameters
ownership (InstanceOwnership)
The ownership model to use.
Return Value
A registrar allowing registration to continue.


WithScope Method (scope)

WithScope Method (scope)
Namespaces ► Autofac.Registrars ► IRegistrar<(Of <(TSyntax>)>) ► WithScope(InstanceScope)
Change the scope associated with the registration. This determines how instances are tracked and shared.
Declaration Syntax
C# Visual Basic Visual C++
TSyntax WithScope(
    InstanceScope scope
)
Function WithScope ( _
    scope As InstanceScope _
) As TSyntax
TSyntax WithScope(
    InstanceScope scope
)
Parameters
scope (InstanceScope)
The scope model to use.
Return Value
A registrar allowing registration to continue.


ReflectiveRegistrationSource Class

ReflectiveRegistrationSource Class
Namespaces ► Autofac.Registrars ► ReflectiveRegistrationSource
This class provides a common base for registration handlers that provide reflection-based registrations.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ReflectiveRegistrationSource : IRegistrationSource
Public MustInherit Class ReflectiveRegistrationSource _
    Implements IRegistrationSource
public ref class ReflectiveRegistrationSource abstract : IRegistrationSource
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReflectiveRegistrationSource(DeferredRegistrationParameters, IConstructorSelector) | Initializes a new instance of the ReflectiveRegistrationSource class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%) | Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose.
 | TryGetRegistration(Service, IComponentRegistration%) | Retrieve a registration for an unregistered service, to be used by the container.
Inheritance Hierarchy
Object
 | ReflectiveRegistrationSource
 |  | AutomaticRegistrationHandler
 |  | GenericRegistrationHandler


ReflectiveRegistrationSource Constructor (deferredParams, constructorSelector)

ReflectiveRegistrationSource Constructor (deferredParams, constructorSelector)
Namespaces ► Autofac.Registrars ► ReflectiveRegistrationSource ► ReflectiveRegistrationSource(DeferredRegistrationParameters, IConstructorSelector)
Initializes a new instance of the ReflectiveRegistrationSource class.
Declaration Syntax
C# Visual Basic Visual C++
protected ReflectiveRegistrationSource(
    DeferredRegistrationParameters deferredParams,
    IConstructorSelector constructorSelector
)
Protected Sub New ( _
    deferredParams As DeferredRegistrationParameters, _
    constructorSelector As IConstructorSelector _
)
protected:
ReflectiveRegistrationSource(
    DeferredRegistrationParameters^ deferredParams,
    IConstructorSelector^ constructorSelector
)
Parameters
deferredParams (DeferredRegistrationParameters)
The deferred params.
constructorSelector (IConstructorSelector)
The constructor selector.


TryGetImplementation Method (service, implementor, services)

TryGetImplementation Method (service, implementor, services)
Namespaces ► Autofac.Registrars ► ReflectiveRegistrationSource ► TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%)
Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract bool TryGetImplementation(
    Service service,
    out Type implementor,
    out IEnumerable<Service> services
)
Protected MustOverride Function TryGetImplementation ( _
    service As Service, _
    <OutAttribute> ByRef implementor As Type, _
    <OutAttribute> ByRef services As IEnumerable(Of Service) _
) As Boolean
protected:
virtual bool TryGetImplementation(
    Service^ service,
    [OutAttribute] Type^% implementor,
    [OutAttribute] IEnumerable<Service^>^% services
) abstract
Parameters
service (Service)
The service.
implementor ( Type %)
The implementation type.
services ( IEnumerable <(Of <( Service >)>) %)
The services.
Return Value
True if a registration can be made.


TryGetRegistration Method (service, registration)

TryGetRegistration Method (service, registration)
Namespaces ► Autofac.Registrars ► ReflectiveRegistrationSource ► TryGetRegistration(Service, IComponentRegistration%)
Retrieve a registration for an unregistered service, to be used by the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TryGetRegistration(
    Service service,
    out IComponentRegistration registration
)
Public Overridable Function TryGetRegistration ( _
    service As Service, _
    <OutAttribute> ByRef registration As IComponentRegistration _
) As Boolean
public:
virtual bool TryGetRegistration(
    Service^ service,
    [OutAttribute] IComponentRegistration^% registration
)
Parameters
service (Service)
The service that was requested.
registration ( IComponentRegistration %)
A registration providing the service.
Return Value
True if the registration could be created.


RegisteredEventArgs Class

RegisteredEventArgs Class
Namespaces ► Autofac.Registrars ► RegisteredEventArgs
Fired when a registrar is applied to a container.
Declaration Syntax
C# Visual Basic Visual C++
public class RegisteredEventArgs : EventArgs
Public Class RegisteredEventArgs _
    Inherits EventArgs
public ref class RegisteredEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegisteredEventArgs()()() | Initializes a new instance of the RegisteredEventArgs class
 | Container | The container.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Registration | The registration being made. May be null.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | RegisteredEventArgs


RegisteredEventArgs Constructor

RegisteredEventArgs Constructor
Namespaces ► Autofac.Registrars ► RegisteredEventArgs ► RegisteredEventArgs()()()
Initializes a new instance of the RegisteredEventArgs class
Declaration Syntax
C# Visual Basic Visual C++
public RegisteredEventArgs()
Public Sub New
public:
RegisteredEventArgs()


Container Property

Container Property
Namespaces ► Autofac.Registrars ► RegisteredEventArgs ► Container
The container.
Declaration Syntax
C# Visual Basic Visual C++
public IContainer Container { get; set; }
Public Property Container As IContainer
public:
property IContainer^ Container {
    IContainer^ get ();
    void set (IContainer^ value);
}


Registration Property

Registration Property
Namespaces ► Autofac.Registrars ► RegisteredEventArgs ► Registration
The registration being made. May be null.
Declaration Syntax
C# Visual Basic Visual C++
public IComponentRegistration Registration { get; set; }
Public Property Registration As IComponentRegistration
public:
property IComponentRegistration^ Registration {
    IComponentRegistration^ get ();
    void set (IComponentRegistration^ value);
}


Registrar(TSyntax) Class

Registrar<(Of <(TSyntax>)>) Class
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>)
Base class for component registrars.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Registrar<TSyntax> : IRegistrar<TSyntax>,
    IFluentInterface, IModule
where TSyntax : IRegistrar<TSyntax>

Public MustInherit Class Registrar(Of TSyntax As IRegistrar(Of TSyntax)) _
    Implements IRegistrar(Of TSyntax), IFluentInterface, IModule
generic<typename TSyntax>
where TSyntax : IRegistrar<TSyntax>
public ref class Registrar abstract : IRegistrar<TSyntax>,
    IFluentInterface, IModule
Generic Template Parameters
TSyntax

[Missing <typeparam name="TSyntax"/> documentation for "T:Autofac.Registrars.Registrar`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Registrar<(Of <(TSyntax>)>)()()() | Initializes a new instance of the Registrar<(Of <(TSyntax>)>) class
 | ActivatedHandlers | The handlers for the Activated event used by this registration.
 | ActivatingHandlers | The handlers for the Activating event used by this registration.
 | AddService(Service) | Add a service to be exposed by the component.
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As<(Of <(TService1, TService2>)>)()()() | Change the services associated with the registration.
 | As<(Of <(TService1, TService2, TService3>)>)()()() | Change the services associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member.
 | ContainerScoped()()() | An instance will be created once per container.
 | DoConfigure(IContainer) | Apply the module to the container.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties.
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed.
 | FactoryScoped()()() | An instance will be created every time one is requested.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated.
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance.
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator.
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process.
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance.
 | OwnedByContainer()()() | The instance(s) will be disposed with the container.
 | Ownership | The instance ownership used by this registration.
 | PreparingHandlers | The handlers for the Preparing event used by this registration.
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event.
 | RegistrationCreator | Gets or sets the registration creator.
 | Scope | The instance scope used by this registration.
 | Services | The services exposed by this registration.
 | SingletonScoped()()() | Only one instance will ever be created.
 | Syntax | Returns this instance, correctly-typed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist.
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom.
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared.
Inheritance Hierarchy
Object
 | Registrar<(Of <(TSyntax>)>)
 |  | AutomaticRegistrar
 |  | ConcreteRegistrar<(Of <(TSyntax>)>)
 |  | GenericRegistrar


Registrar(TSyntax) Constructor

Registrar<(Of <(TSyntax>)>) Constructor
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Registrar<(Of <(TSyntax>)>)()()()
Initializes a new instance of the Registrar<(Of <(TSyntax>)>) class
Declaration Syntax
C# Visual Basic Visual C++
protected Registrar()
Protected Sub New
protected:
Registrar()


ActivatedHandlers Property

ActivatedHandlers Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► ActivatedHandlers
The handlers for the Activated event used by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerable<EventHandler<ActivatedEventArgs>> ActivatedHandlers { get; }
Protected Overridable ReadOnly Property ActivatedHandlers As IEnumerable(Of EventHandler(Of ActivatedEventArgs))
protected:
virtual property IEnumerable<EventHandler<ActivatedEventArgs^>^>^ ActivatedHandlers {
    IEnumerable<EventHandler<ActivatedEventArgs^>^>^ get ();
}


ActivatingHandlers Property

ActivatingHandlers Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► ActivatingHandlers
The handlers for the Activating event used by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerable<EventHandler<ActivatingEventArgs>> ActivatingHandlers { get; }
Protected Overridable ReadOnly Property ActivatingHandlers As IEnumerable(Of EventHandler(Of ActivatingEventArgs))
protected:
virtual property IEnumerable<EventHandler<ActivatingEventArgs^>^>^ ActivatingHandlers {
    IEnumerable<EventHandler<ActivatingEventArgs^>^>^ get ();
}


AddService Method (service)

AddService Method (service)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► AddService(Service)
Add a service to be exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void AddService(
    Service service
)
Protected Overridable Sub AddService ( _
    service As Service _
)
protected:
virtual void AddService(
    Service^ service
)
Parameters
service (Service)
The service to add.


AddServices Method (services)

AddServices Method (services)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► AddServices(IEnumerable<(Of <(Service>)>))
Add many services to be exposed by the component.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void AddServices(
    IEnumerable<Service> services
)
Protected Overridable Sub AddServices ( _
    services As IEnumerable(Of Service) _
)
protected:
virtual void AddServices(
    IEnumerable<Service^>^ services
)
Parameters
services (IEnumerable <(Of <( Service >)>))
The services to add (by calling AddService().)


As Method

As Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As<(Of <(TService1, TService2>)>)()()() | Change the services associated with the registration.
 | As<(Of <(TService1, TService2, TService3>)>)()()() | Change the services associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


As Method

As<(Of <(TService1, TService2, TService3>)>) Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► As<(Of <(TService1, TService2, TService3>)>)()()()
Change the services associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax As<TService1, TService2, TService3>()

Public Overridable Function As(Of TService1, TService2, TService3) As TSyntax
public:
generic<typename TService1, typename TService2, typename TService3>
virtual TSyntax As()
Generic Template Parameters
TService1
The first service that the registration will expose.
TService2
The second service that the registration will expose.
TService3
The third service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method

As<(Of <(TService1, TService2>)>) Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► As<(Of <(TService1, TService2>)>)()()()
Change the services associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax As<TService1, TService2>()

Public Overridable Function As(Of TService1, TService2) As TSyntax
public:
generic<typename TService1, typename TService2>
virtual TSyntax As()
Generic Template Parameters
TService1
The first service that the registration will expose.
TService2
The second service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method

As<(Of <(TService>)>) Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► As<(Of <(TService>)>)()()()
Change the service associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax As<TService>()

Public Overridable Function As(Of TService) As TSyntax
public:
generic<typename TService>
virtual TSyntax As()
Generic Template Parameters
TService
The service that the registration will expose.
Return Value
A registrar allowing registration to continue.


As Method (services)

As Method (services)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► As(array<Type>[]()[])
Change the service associated with the registration.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax As(
    params Type[] services
)
Public Overridable Function As ( _
    ParamArray services As Type() _
) As TSyntax
public:
virtual TSyntax As(
    ... array<Type^>^ services
)
Parameters
services (array< Type >[]()[])
The services that the registration will expose.
Return Value
A registrar allowing registration to continue.


Configure Method (container)

Configure Method (container)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Configure(IContainer)
Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Configure(
    IContainer container
)
Public Overridable Sub Configure ( _
    container As IContainer _
)
public:
virtual void Configure(
    IContainer^ container
)
Parameters
container (IContainer)
Container to apply configuration to.


ContainerScoped Method

ContainerScoped Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► ContainerScoped()()()
An instance will be created once per container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax ContainerScoped()
Public Overridable Function ContainerScoped As TSyntax
public:
virtual TSyntax ContainerScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Registrar`1.ContainerScoped]

See Also
CreateInnerContainer()()()


DoConfigure Method (container)

DoConfigure Method (container)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► DoConfigure(IContainer)
Apply the module to the container.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void DoConfigure(
    IContainer container
)
Protected MustOverride Sub DoConfigure ( _
    container As IContainer _
)
protected:
virtual void DoConfigure(
    IContainer^ container
) abstract
Parameters
container (IContainer)
Container to apply configuration to.


ExtendedProperties Property

ExtendedProperties Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► ExtendedProperties
Gets the extended properties.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IDictionary<string, Object> ExtendedProperties { get; }
Protected Overridable ReadOnly Property ExtendedProperties As IDictionary(Of String, Object)
protected:
virtual property IDictionary<String^, Object^>^ ExtendedProperties {
    IDictionary<String^, Object^>^ get ();
}
Value
The extended properties.


ExternallyOwned Method

ExternallyOwned Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► ExternallyOwned()()()
The instance(s) will not be disposed when the container is disposed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax ExternallyOwned()
Public Overridable Function ExternallyOwned As TSyntax
public:
virtual TSyntax ExternallyOwned()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Registrar`1.ExternallyOwned]


FactoryScoped Method

FactoryScoped Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► FactoryScoped()()()
An instance will be created every time one is requested.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax FactoryScoped()
Public Overridable Function FactoryScoped As TSyntax
public:
virtual TSyntax FactoryScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Registrar`1.FactoryScoped]


FireRegistered Method (e)

FireRegistered Method (e)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► FireRegistered(RegisteredEventArgs)
Fires the registered event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void FireRegistered(
    RegisteredEventArgs e
)
Protected Overridable Sub FireRegistered ( _
    e As RegisteredEventArgs _
)
protected:
virtual void FireRegistered(
    RegisteredEventArgs^ e
)
Parameters
e (RegisteredEventArgs)
The RegisteredEventArgs instance containing the event data.


InContext Method (tag)

InContext<(Of <(T>)>) Method (tag)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► InContext<(Of <(T>)>)(T)
Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax InContext<T>(
    T tag
)

Public Overridable Function InContext(Of T) ( _
    tag As T _
) As TSyntax
public:
generic<typename T>
virtual TSyntax InContext(
    T tag
)
Generic Template Parameters
T
The type of the tag.
Parameters
tag (T)
The tag.
Return Value
A registrar allowing registration to continue.


OnActivated Method (handler)

OnActivated Method (handler)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>))
Call the provided handler when an instance is activated.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OnActivated(
    EventHandler<ActivatedEventArgs> handler
)
Public Overridable Function OnActivated ( _
    handler As EventHandler(Of ActivatedEventArgs) _
) As TSyntax
public:
virtual TSyntax OnActivated(
    EventHandler<ActivatedEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( ActivatedEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnActivating Method (handler)

OnActivating Method (handler)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>))
Call the provided handler when activating an instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OnActivating(
    EventHandler<ActivatingEventArgs> handler
)
Public Overridable Function OnActivating ( _
    handler As EventHandler(Of ActivatingEventArgs) _
) As TSyntax
public:
virtual TSyntax OnActivating(
    EventHandler<ActivatingEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( ActivatingEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnlyIf Method (containerPredicate)

OnlyIf Method (containerPredicate)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OnlyIf(Predicate<(Of <(IContainer>)>))
Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OnlyIf(
    Predicate<IContainer> containerPredicate
)
Public Overridable Function OnlyIf ( _
    containerPredicate As Predicate(Of IContainer) _
) As TSyntax
public:
virtual TSyntax OnlyIf(
    Predicate<IContainer^>^ containerPredicate
)
Parameters
containerPredicate (Predicate <(Of <( IContainer >)>))
Predicate based on a container.
Return Value
A registrar allowing registration to continue.


OnPreparing Method (handler)

OnPreparing Method (handler)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>))
Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OnPreparing(
    EventHandler<PreparingEventArgs> handler
)
Public Overridable Function OnPreparing ( _
    handler As EventHandler(Of PreparingEventArgs) _
) As TSyntax
public:
virtual TSyntax OnPreparing(
    EventHandler<PreparingEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( PreparingEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OnRegistered Method (handler)

OnRegistered Method (handler)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>))
Call the provided handler when activating an instance.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OnRegistered(
    EventHandler<RegisteredEventArgs> handler
)
Public Overridable Function OnRegistered ( _
    handler As EventHandler(Of RegisteredEventArgs) _
) As TSyntax
public:
virtual TSyntax OnRegistered(
    EventHandler<RegisteredEventArgs^>^ handler
)
Parameters
handler (EventHandler <(Of <( RegisteredEventArgs >)>))
The handler.
Return Value
A registrar allowing registration to continue.


OwnedByContainer Method

OwnedByContainer Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► OwnedByContainer()()()
The instance(s) will be disposed with the container.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax OwnedByContainer()
Public Overridable Function OwnedByContainer As TSyntax
public:
virtual TSyntax OwnedByContainer()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Registrar`1.OwnedByContainer]


Ownership Property

Ownership Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Ownership
The instance ownership used by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual InstanceOwnership Ownership { get; set; }
Protected Overridable Property Ownership As InstanceOwnership
protected:
virtual property InstanceOwnership Ownership {
    InstanceOwnership get ();
    void set (InstanceOwnership value);
}


PreparingHandlers Property

PreparingHandlers Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► PreparingHandlers
The handlers for the Preparing event used by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerable<EventHandler<PreparingEventArgs>> PreparingHandlers { get; }
Protected Overridable ReadOnly Property PreparingHandlers As IEnumerable(Of EventHandler(Of PreparingEventArgs))
protected:
virtual property IEnumerable<EventHandler<PreparingEventArgs^>^>^ PreparingHandlers {
    IEnumerable<EventHandler<PreparingEventArgs^>^>^ get ();
}


RegisterComponent Method (container, cr)

RegisterComponent Method (container, cr)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► RegisterComponent(IContainer, IComponentRegistration)
Sets up the registration with events, registers it in the container, and fires the Registered event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RegisterComponent(
    IContainer container,
    IComponentRegistration cr
)
Protected Overridable Sub RegisterComponent ( _
    container As IContainer, _
    cr As IComponentRegistration _
)
protected:
virtual void RegisterComponent(
    IContainer^ container,
    IComponentRegistration^ cr
)
Parameters
container (IContainer)
The container.
cr (IComponentRegistration)
The cr.


RegistrationCreator Property

RegistrationCreator Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► RegistrationCreator
Gets or sets the registration creator.
Declaration Syntax
C# Visual Basic Visual C++
public virtual RegistrationCreator RegistrationCreator { get; set; }
Public Overridable Property RegistrationCreator As RegistrationCreator
public:
virtual property RegistrationCreator^ RegistrationCreator {
    RegistrationCreator^ get ();
    void set (RegistrationCreator^ value);
}
Value
The registration creator.


Scope Property

Scope Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Scope
The instance scope used by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual InstanceScope Scope { get; set; }
Protected Overridable Property Scope As InstanceScope
protected:
virtual property InstanceScope Scope {
    InstanceScope get ();
    void set (InstanceScope value);
}


Services Property

Services Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Services
The services exposed by this registration.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerable<Service> Services { get; }
Protected Overridable ReadOnly Property Services As IEnumerable(Of Service)
protected:
virtual property IEnumerable<Service^>^ Services {
    IEnumerable<Service^>^ get ();
}


SingletonScoped Method

SingletonScoped Method
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► SingletonScoped()()()
Only one instance will ever be created.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax SingletonScoped()
Public Overridable Function SingletonScoped As TSyntax
public:
virtual TSyntax SingletonScoped()
Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Registrar`1.SingletonScoped]


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract TSyntax Syntax { get; }
Protected MustOverride ReadOnly Property Syntax As TSyntax
protected:
virtual property TSyntax Syntax {
    TSyntax get () abstract;
}


WithExtendedProperty Method (key, value)

WithExtendedProperty Method (key, value)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► WithExtendedProperty(String, Object)
Associates an extended property with the registration. The property must not already exist.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax WithExtendedProperty(
    string key,
    Object value
)
Public Overridable Function WithExtendedProperty ( _
    key As String, _
    value As Object _
) As TSyntax
public:
virtual TSyntax WithExtendedProperty(
    String^ key,
    Object^ value
)
Parameters
key (String)
The key.
value (Object)
The value.
Return Value
A registrar allowing registration to continue.


WithOwnership Method (ownership)

WithOwnership Method (ownership)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► WithOwnership(InstanceOwnership)
Change the ownership model associated with the registration. This determines when the instances are disposed and by whom.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax WithOwnership(
    InstanceOwnership ownership
)
Public Overridable Function WithOwnership ( _
    ownership As InstanceOwnership _
) As TSyntax
public:
virtual TSyntax WithOwnership(
    InstanceOwnership ownership
)
Parameters
ownership (InstanceOwnership)
The ownership model to use.
Return Value
A registrar allowing registration to continue.


WithScope Method (scope)

WithScope Method (scope)
Namespaces ► Autofac.Registrars ► Registrar<(Of <(TSyntax>)>) ► WithScope(InstanceScope)
Change the scope associated with the registration. This determines how instances are tracked and shared.
Declaration Syntax
C# Visual Basic Visual C++
public virtual TSyntax WithScope(
    InstanceScope scope
)
Public Overridable Function WithScope ( _
    scope As InstanceScope _
) As TSyntax
public:
virtual TSyntax WithScope(
    InstanceScope scope
)
Parameters
scope (InstanceScope)
The scope model to use.
Return Value
A registrar allowing registration to continue.


RegistrationCreator Delegate

RegistrationCreator Delegate
Namespaces ► Autofac.Registrars ► RegistrationCreator
Create the registration.
Declaration Syntax
C# Visual Basic Visual C++
public delegate IComponentRegistration RegistrationCreator(
    IComponentDescriptor descriptor,
    IActivator activator,
    IScope scope,
    InstanceOwnership ownership
)
Public Delegate Function RegistrationCreator ( _
    descriptor As IComponentDescriptor, _
    activator As IActivator, _
    scope As IScope, _
    ownership As InstanceOwnership _
) As IComponentRegistration
public delegate IComponentRegistration^ RegistrationCreator(
    IComponentDescriptor^ descriptor,
    IActivator^ activator,
    IScope^ scope,
    InstanceOwnership ownership
)
Parameters
descriptor (IComponentDescriptor)
The descriptor.
activator (IActivator)
Activator.
scope (IScope)
Scope.
ownership (InstanceOwnership)
Ownership model.
Return Value
The registration.


Autofac.Registrars.Automatic Namespace

Autofac.Registrars.Automatic Namespace
Namespaces ► Autofac.Registrars.Automatic
Automatic registrar support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars.Automatic
Namespace Autofac.Registrars.Automatic
namespace Autofac.Registrars.Automatic
Types
All Types Classes
Icon | Type | Description
 | AutomaticRegistrar | Automatically registers types that match a supplied predicate.
 | AutomaticRegistrationHandler | Provides registrations based on a requested type.


AutomaticRegistrar Class

AutomaticRegistrar Class
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar
Automatically registers types that match a supplied predicate.
Declaration Syntax
C# Visual Basic Visual C++
public class AutomaticRegistrar : Registrar<IGenericRegistrar>,
    IModule, IGenericRegistrar, IRegistrar<IGenericRegistrar>, IFluentInterface
Public Class AutomaticRegistrar _
    Inherits Registrar(Of IGenericRegistrar) _
    Implements IModule, IGenericRegistrar, IRegistrar(Of IGenericRegistrar),  _
    IFluentInterface
public ref class AutomaticRegistrar : public Registrar<IGenericRegistrar^>,
    IModule, IGenericRegistrar, IRegistrar<IGenericRegistrar^>, IFluentInterface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutomaticRegistrar(Predicate<(Of <(Type>)>)) | Initializes a new instance of the AutomaticRegistrar class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | DoConfigure(IContainer) | Registers the component. (Overrides Registrar <(Of <( IGenericRegistrar >)>).DoConfigure(IContainer).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Overrides Registrar <(Of <( IGenericRegistrar >)>).Syntax.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UsingConstructor(array<Type>[]()[]) | Enforce that the specific constructor with the provided signature is used.
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from Registrar<(Of <(TSyntax>)>).)
Inheritance Hierarchy
Object
 | Registrar <(Of <( IGenericRegistrar >)>)
 |  | AutomaticRegistrar


AutomaticRegistrar Constructor (predicate)

AutomaticRegistrar Constructor (predicate)
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar ► AutomaticRegistrar(Predicate<(Of <(Type>)>))
Initializes a new instance of the AutomaticRegistrar class.
Declaration Syntax
C# Visual Basic Visual C++
public AutomaticRegistrar(
    Predicate<Type> predicate
)
Public Sub New ( _
    predicate As Predicate(Of Type) _
)
public:
AutomaticRegistrar(
    Predicate<Type^>^ predicate
)
Parameters
predicate (Predicate <(Of <( Type >)>))
The predicate.


DoConfigure Method (container)

DoConfigure Method (container)
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar ► DoConfigure(IContainer)
Registers the component.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DoConfigure(
    IContainer container
)
Protected Overrides Sub DoConfigure ( _
    container As IContainer _
)
protected:
virtual void DoConfigure(
    IContainer^ container
) override
Parameters
container (IContainer)
The container.


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected override IGenericRegistrar Syntax { get; }
Protected Overrides ReadOnly Property Syntax As IGenericRegistrar
protected:
virtual property IGenericRegistrar^ Syntax {
    IGenericRegistrar^ get () override;
}
Value


UsingConstructor Method (ctorSignature)

UsingConstructor Method (ctorSignature)
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar ► UsingConstructor(array<Type>[]()[])
Enforce that the specific constructor with the provided signature is used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar UsingConstructor(
    params Type[] ctorSignature
)
Public Overridable Function UsingConstructor ( _
    ParamArray ctorSignature As Type() _
) As IGenericRegistrar
public:
virtual IGenericRegistrar^ UsingConstructor(
    ... array<Type^>^ ctorSignature
)
Parameters
ctorSignature (array< Type >[]()[])
The types that designate the constructor to use.
Return Value
A registrar allowing registration to continue.


AutomaticRegistrationHandler Class

AutomaticRegistrationHandler Class
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrationHandler
Provides registrations based on a requested type.
Declaration Syntax
C# Visual Basic Visual C++
public class AutomaticRegistrationHandler : ReflectiveRegistrationSource
Public Class AutomaticRegistrationHandler _
    Inherits ReflectiveRegistrationSource
public ref class AutomaticRegistrationHandler : public ReflectiveRegistrationSource
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutomaticRegistrationHandler(Predicate<(Of <(Type>)>), DeferredRegistrationParameters, IConstructorSelector) | Initializes a new instance of the AutomaticRegistrationHandler class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%) | Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose. (Overrides ReflectiveRegistrationSource.TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%).)
 | TryGetRegistration(Service, IComponentRegistration%) | Retrieve a registration for an unregistered service, to be used by the container. (Inherited from ReflectiveRegistrationSource.)
Inheritance Hierarchy
Object
 | ReflectiveRegistrationSource
 |  | AutomaticRegistrationHandler


AutomaticRegistrationHandler Constructor (predicate, deferredParams, constructorSelector)

AutomaticRegistrationHandler Constructor (predicate, deferredParams, constructorSelector)
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrationHandler ► AutomaticRegistrationHandler(Predicate<(Of <(Type>)>), DeferredRegistrationParameters, IConstructorSelector)
Initializes a new instance of the AutomaticRegistrationHandler class.
Declaration Syntax
C# Visual Basic Visual C++
public AutomaticRegistrationHandler(
    Predicate<Type> predicate,
    DeferredRegistrationParameters deferredParams,
    IConstructorSelector constructorSelector
)
Public Sub New ( _
    predicate As Predicate(Of Type), _
    deferredParams As DeferredRegistrationParameters, _
    constructorSelector As IConstructorSelector _
)
public:
AutomaticRegistrationHandler(
    Predicate<Type^>^ predicate,
    DeferredRegistrationParameters^ deferredParams,
    IConstructorSelector^ constructorSelector
)
Parameters
predicate (Predicate <(Of <( Type >)>))
The predicate.
deferredParams (DeferredRegistrationParameters)
The deferred registration params.
constructorSelector (IConstructorSelector)
The constructor selector.


TryGetImplementation Method (service, implementor, services)

TryGetImplementation Method (service, implementor, services)
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrationHandler ► TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%)
Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool TryGetImplementation(
    Service service,
    out Type implementor,
    out IEnumerable<Service> services
)
Protected Overrides Function TryGetImplementation ( _
    service As Service, _
    <OutAttribute> ByRef implementor As Type, _
    <OutAttribute> ByRef services As IEnumerable(Of Service) _
) As Boolean
protected:
virtual bool TryGetImplementation(
    Service^ service,
    [OutAttribute] Type^% implementor,
    [OutAttribute] IEnumerable<Service^>^% services
) override
Parameters
service (Service)
The service.
implementor ( Type %)
The implementation type.
services ( IEnumerable <(Of <( Service >)>) %)
The services.
Return Value
True if a registration can be made.


Autofac.Registrars.Delegate Namespace

Autofac.Registrars.Delegate Namespace
Namespaces ► Autofac.Registrars.Delegate
Delegate registration support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars.Delegate
Namespace Autofac.Registrars.Delegate
namespace Autofac.Registrars.Delegate
Types
All Types Classes Delegates
Icon | Type | Description
 | ComponentActivator<(Of <(T>)>) | Implementations of the ComponentActivator type will create an instance of a component, using the provided container to resolve its dependencies.
 | ComponentActivatorWithParameters<(Of <(T>)>) | Implementations of the ComponentActivator type will create an instance of a component, using the provided container to resolve its dependencies.
 | DelegateRegistrar | Register a component using a delegate.


ComponentActivator(T) Delegate

ComponentActivator<(Of <(T>)>) Delegate
Namespaces ► Autofac.Registrars.Delegate ► ComponentActivator<(Of <(T>)>)
Implementations of the ComponentActivator type will create an instance of a component, using the provided container to resolve its dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public delegate T ComponentActivator<T>(
    IContext context
)

Public Delegate Function ComponentActivator(Of T) ( _
    context As IContext _
) As T
generic<typename T>
public delegate T ComponentActivator(
    IContext^ context
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:Autofac.Registrars.Delegate.ComponentActivator`1"]

Parameters
context (IContext)
The container from which the component's dependencies may be resolved.
Return Value
An instance of the component.
Remarks
A creation delegate can be used when the method of initialisation of a component is complex, its constructors require parameters that must be obtained from outside the container. The delegate should always return a unique instance.


ComponentActivatorWithParameters(T) Delegate

ComponentActivatorWithParameters<(Of <(T>)>) Delegate
Namespaces ► Autofac.Registrars.Delegate ► ComponentActivatorWithParameters<(Of <(T>)>)
Implementations of the ComponentActivator type will create an instance of a component, using the provided container to resolve its dependencies.
Declaration Syntax
C# Visual Basic Visual C++
public delegate T ComponentActivatorWithParameters<T>(
    IContext context,
    IEnumerable<Parameter> parameters
)

Public Delegate Function ComponentActivatorWithParameters(Of T) ( _
    context As IContext, _
    parameters As IEnumerable(Of Parameter) _
) As T
generic<typename T>
public delegate T ComponentActivatorWithParameters(
    IContext^ context,
    IEnumerable<Parameter^>^ parameters
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:Autofac.Registrars.Delegate.ComponentActivatorWithParameters`1"]

Parameters
context (IContext)
The container from which the component's dependencies may be resolved.
parameters (IEnumerable <(Of <( Parameter >)>))
The activation parameters.
Return Value
An instance of the component.
Remarks
A creation delegate can be used when the method of initialisation of a component is complex, its constructors require parameters that must be obtained from outside the container. The delegate should always return a unique instance.


DelegateRegistrar Class

DelegateRegistrar Class
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar
Register a component using a delegate.
Declaration Syntax
C# Visual Basic Visual C++
public class DelegateRegistrar : ConcreteRegistrar<IConcreteRegistrar>,
    IConcreteRegistrar, IConcreteRegistrar<IConcreteRegistrar>, IRegistrar<IConcreteRegistrar>,
    IFluentInterface
Public Class DelegateRegistrar _
    Inherits ConcreteRegistrar(Of IConcreteRegistrar) _
    Implements IConcreteRegistrar, IConcreteRegistrar(Of IConcreteRegistrar),  _
    IRegistrar(Of IConcreteRegistrar), IFluentInterface
public ref class DelegateRegistrar : public ConcreteRegistrar<IConcreteRegistrar^>,
    IConcreteRegistrar, IConcreteRegistrar<IConcreteRegistrar^>, IRegistrar<IConcreteRegistrar^>,
    IFluentInterface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DelegateRegistrar(Type, ComponentActivator) | Initializes a new instance of the DelegateRegistrar<TComponent> class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Service>[]()[]) | Change the service associated with the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | CreateActivator()()() | Creates the activator for the registration. (Overrides ConcreteRegistrar <(Of <( IConcreteRegistrar >)>).CreateActivator()()().)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | DoConfigure(IContainer) | Registers the component. If the component has not been assigned a name, explicit services or a factory delegate, then it will be registered as providing its own type as the default service. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | A unique service identifier that will be associated with the resulting registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Type) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Service) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Named(String) | Setst the name of the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Overrides Registrar <(Of <( IConcreteRegistrar >)>).Syntax.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from Registrar<(Of <(TSyntax>)>).)
Inheritance Hierarchy
Object
 | Registrar <(Of <( IConcreteRegistrar >)>)
 |  | ConcreteRegistrar <(Of <( IConcreteRegistrar >)>)
 |  |  | DelegateRegistrar


DelegateRegistrar Constructor (implementor, creator)

DelegateRegistrar Constructor (implementor, creator)
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar ► DelegateRegistrar(Type, ComponentActivator)
Initializes a new instance of the DelegateRegistrar<TComponent> class.
Declaration Syntax
C# Visual Basic Visual C++
public DelegateRegistrar(
    Type implementor,
    ComponentActivator creator
)
Public Sub New ( _
    implementor As Type, _
    creator As ComponentActivator _
)
public:
DelegateRegistrar(
    Type^ implementor,
    ComponentActivator^ creator
)
Parameters
implementor (Type)
The implementor.
creator (ComponentActivator)
The creator.


CreateActivator Method

CreateActivator Method
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar ► CreateActivator()()()
Creates the activator for the registration.
Declaration Syntax
C# Visual Basic Visual C++
protected override IActivator CreateActivator()
Protected Overrides Function CreateActivator As IActivator
protected:
virtual IActivator^ CreateActivator() override
Return Value
An activator.


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected override IConcreteRegistrar Syntax { get; }
Protected Overrides ReadOnly Property Syntax As IConcreteRegistrar
protected:
virtual property IConcreteRegistrar^ Syntax {
    IConcreteRegistrar^ get () override;
}
Value


Autofac.Registrars.Generic Namespace

Autofac.Registrars.Generic Namespace
Namespaces ► Autofac.Registrars.Generic
Open generic type registration support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars.Generic
Namespace Autofac.Registrars.Generic
namespace Autofac.Registrars.Generic
Types
All Types Classes
Icon | Type | Description
 | GenericRegistrar | Creates generic component registrations that will be automatically bound to concrete types as they are requested.
 | GenericRegistrationHandler | This class, not yet part of the public API, provides a means by which generic component registrations can be made.


GenericRegistrar Class

GenericRegistrar Class
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar
Creates generic component registrations that will be automatically bound to concrete types as they are requested.
Declaration Syntax
C# Visual Basic Visual C++
public class GenericRegistrar : Registrar<IGenericRegistrar>,
    IModule, IGenericRegistrar, IRegistrar<IGenericRegistrar>, IFluentInterface
Public Class GenericRegistrar _
    Inherits Registrar(Of IGenericRegistrar) _
    Implements IModule, IGenericRegistrar, IRegistrar(Of IGenericRegistrar),  _
    IFluentInterface
public ref class GenericRegistrar : public Registrar<IGenericRegistrar^>,
    IModule, IGenericRegistrar, IRegistrar<IGenericRegistrar^>, IFluentInterface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericRegistrar(Type) | Initializes a new instance of the GenericRegistrar class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | DoConfigure(IContainer) | Registers the component. (Overrides Registrar <(Of <( IGenericRegistrar >)>).DoConfigure(IContainer).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Overrides Registrar <(Of <( IGenericRegistrar >)>).Syntax.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UsingConstructor(array<Type>[]()[]) | Enforce that the specific constructor with the provided signature is used.
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from Registrar<(Of <(TSyntax>)>).)
Remarks
The interface of this class and returned IRegistrar are non-generic as C# (or the CLR) does not allow partially-constructed generic types like IList<> to be used as generic arguments.
Inheritance Hierarchy
Object
 | Registrar <(Of <( IGenericRegistrar >)>)
 |  | GenericRegistrar


GenericRegistrar Constructor (implementor)

GenericRegistrar Constructor (implementor)
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar ► GenericRegistrar(Type)
Initializes a new instance of the GenericRegistrar class.
Declaration Syntax
C# Visual Basic Visual C++
public GenericRegistrar(
    Type implementor
)
Public Sub New ( _
    implementor As Type _
)
public:
GenericRegistrar(
    Type^ implementor
)
Parameters
implementor (Type)
The implementor.


DoConfigure Method (container)

DoConfigure Method (container)
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar ► DoConfigure(IContainer)
Registers the component.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DoConfigure(
    IContainer container
)
Protected Overrides Sub DoConfigure ( _
    container As IContainer _
)
protected:
virtual void DoConfigure(
    IContainer^ container
) override
Parameters
container (IContainer)
The container.


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected override IGenericRegistrar Syntax { get; }
Protected Overrides ReadOnly Property Syntax As IGenericRegistrar
protected:
virtual property IGenericRegistrar^ Syntax {
    IGenericRegistrar^ get () override;
}
Value


UsingConstructor Method (ctorSignature)

UsingConstructor Method (ctorSignature)
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar ► UsingConstructor(array<Type>[]()[])
Enforce that the specific constructor with the provided signature is used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IGenericRegistrar UsingConstructor(
    params Type[] ctorSignature
)
Public Overridable Function UsingConstructor ( _
    ParamArray ctorSignature As Type() _
) As IGenericRegistrar
public:
virtual IGenericRegistrar^ UsingConstructor(
    ... array<Type^>^ ctorSignature
)
Parameters
ctorSignature (array< Type >[]()[])
The types that designate the constructor to use.
Return Value
A registrar allowing registration to continue.


GenericRegistrationHandler Class

GenericRegistrationHandler Class
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrationHandler
This class, not yet part of the public API, provides a means by which generic component registrations can be made.
Declaration Syntax
C# Visual Basic Visual C++
public class GenericRegistrationHandler : ReflectiveRegistrationSource
Public Class GenericRegistrationHandler _
    Inherits ReflectiveRegistrationSource
public ref class GenericRegistrationHandler : public ReflectiveRegistrationSource
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenericRegistrationHandler(IEnumerable<(Of <(Service>)>), Type, DeferredRegistrationParameters, IConstructorSelector) | Initializes a new instance of the GenericRegistrationHandler class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%) | Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose. (Overrides ReflectiveRegistrationSource.TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%).)
 | TryGetRegistration(Service, IComponentRegistration%) | Retrieve a registration for an unregistered service, to be used by the container. (Inherited from ReflectiveRegistrationSource.)
Remarks
This class creates registrations by handling the Container.ServiceNotRegistered event. This feels hacky but keeps the container cleaner and simpler. Will have to see how performance goes.
Inheritance Hierarchy
Object
 | ReflectiveRegistrationSource
 |  | GenericRegistrationHandler


GenericRegistrationHandler Constructor (services, implementor, deferredParams, constructorSelector)

GenericRegistrationHandler Constructor (services, implementor, deferredParams, constructorSelector)
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrationHandler ► GenericRegistrationHandler(IEnumerable<(Of <(Service>)>), Type, DeferredRegistrationParameters, IConstructorSelector)
Initializes a new instance of the GenericRegistrationHandler class.
Declaration Syntax
C# Visual Basic Visual C++
public GenericRegistrationHandler(
    IEnumerable<Service> services,
    Type implementor,
    DeferredRegistrationParameters deferredParams,
    IConstructorSelector constructorSelector
)
Public Sub New ( _
    services As IEnumerable(Of Service), _
    implementor As Type, _
    deferredParams As DeferredRegistrationParameters, _
    constructorSelector As IConstructorSelector _
)
public:
GenericRegistrationHandler(
    IEnumerable<Service^>^ services,
    Type^ implementor,
    DeferredRegistrationParameters^ deferredParams,
    IConstructorSelector^ constructorSelector
)
Parameters
services (IEnumerable <(Of <( Service >)>))
The services.
implementor (Type)
The implementor.
deferredParams (DeferredRegistrationParameters)
The deferred params.
constructorSelector (IConstructorSelector)
The constructor selector.


TryGetImplementation Method (service, implementor, services)

TryGetImplementation Method (service, implementor, services)
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrationHandler ► TryGetImplementation(Service, Type%, IEnumerable<(Of <(Service>)>)%)
Determine if the service represents a type that can be registered, and if so, retrieve that type as well as the services that the registration should expose.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool TryGetImplementation(
    Service service,
    out Type implementor,
    out IEnumerable<Service> services
)
Protected Overrides Function TryGetImplementation ( _
    service As Service, _
    <OutAttribute> ByRef implementor As Type, _
    <OutAttribute> ByRef services As IEnumerable(Of Service) _
) As Boolean
protected:
virtual bool TryGetImplementation(
    Service^ service,
    [OutAttribute] Type^% implementor,
    [OutAttribute] IEnumerable<Service^>^% services
) override
Parameters
service (Service)
The service.
implementor ( Type %)
The implementation type.
services ( IEnumerable <(Of <( Service >)>) %)
The services.
Return Value
True if a registration can be made.


Autofac.Registrars.ProvidedInstance Namespace

Autofac.Registrars.ProvidedInstance Namespace
Namespaces ► Autofac.Registrars.ProvidedInstance
Instance registration support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars.ProvidedInstance
Namespace Autofac.Registrars.ProvidedInstance
namespace Autofac.Registrars.ProvidedInstance
Types
All Types Classes
Icon | Type | Description
 | ProvidedInstanceRegistrar | Register a component using a provided instance.


ProvidedInstanceRegistrar Class

ProvidedInstanceRegistrar Class
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar
Register a component using a provided instance.
Declaration Syntax
C# Visual Basic Visual C++
public class ProvidedInstanceRegistrar : ConcreteRegistrar<IConcreteRegistrar>,
    IConcreteRegistrar, IConcreteRegistrar<IConcreteRegistrar>, IRegistrar<IConcreteRegistrar>,
    IFluentInterface
Public Class ProvidedInstanceRegistrar _
    Inherits ConcreteRegistrar(Of IConcreteRegistrar) _
    Implements IConcreteRegistrar, IConcreteRegistrar(Of IConcreteRegistrar),  _
    IRegistrar(Of IConcreteRegistrar), IFluentInterface
public ref class ProvidedInstanceRegistrar : public ConcreteRegistrar<IConcreteRegistrar^>,
    IConcreteRegistrar, IConcreteRegistrar<IConcreteRegistrar^>, IRegistrar<IConcreteRegistrar^>,
    IFluentInterface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProvidedInstanceRegistrar(Object) | Initializes a new instance of the ProvidedInstanceRegistrar class.
 | ProvidedInstanceRegistrar(Object, Type) | Initializes a new instance of the ProvidedInstanceRegistrar class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Service>[]()[]) | Change the service associated with the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | CreateActivator()()() | Creates the activator for the registration. (Overrides ConcreteRegistrar <(Of <( IConcreteRegistrar >)>).CreateActivator()()().)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | DoConfigure(IContainer) | Resolves issue #7 - Provided instances not disposed unless they are resolved first. Manually attaches instance to container's disposer if Container ownership is chosen. (Overrides ConcreteRegistrar <(Of <( IConcreteRegistrar >)>).DoConfigure(IContainer).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | A unique service identifier that will be associated with the resulting registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Type) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Service) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Named(String) | Setst the name of the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Overrides Registrar <(Of <( IConcreteRegistrar >)>).Syntax.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Overrides Registrar <(Of <( IConcreteRegistrar >)>).WithScope(InstanceScope).)
Inheritance Hierarchy
Object
 | Registrar <(Of <( IConcreteRegistrar >)>)
 |  | ConcreteRegistrar <(Of <( IConcreteRegistrar >)>)
 |  |  | ProvidedInstanceRegistrar


ProvidedInstanceRegistrar Constructor

ProvidedInstanceRegistrar Constructor
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► ProvidedInstanceRegistrar()()()
Members
Icon | Member | Description
 | ProvidedInstanceRegistrar(Object) | Initializes a new instance of the ProvidedInstanceRegistrar class.
 | ProvidedInstanceRegistrar(Object, Type) | Initializes a new instance of the ProvidedInstanceRegistrar class.


ProvidedInstanceRegistrar Constructor (instance)

ProvidedInstanceRegistrar Constructor (instance)
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► ProvidedInstanceRegistrar(Object)
Initializes a new instance of the ProvidedInstanceRegistrar class.
Declaration Syntax
C# Visual Basic Visual C++
public ProvidedInstanceRegistrar(
    Object instance
)
Public Sub New ( _
    instance As Object _
)
public:
ProvidedInstanceRegistrar(
    Object^ instance
)
Parameters
instance (Object)
The instance.


ProvidedInstanceRegistrar Constructor (instance, defaultService)

ProvidedInstanceRegistrar Constructor (instance, defaultService)
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► ProvidedInstanceRegistrar(Object, Type)
Initializes a new instance of the ProvidedInstanceRegistrar class.
Declaration Syntax
C# Visual Basic Visual C++
public ProvidedInstanceRegistrar(
    Object instance,
    Type defaultService
)
Public Sub New ( _
    instance As Object, _
    defaultService As Type _
)
public:
ProvidedInstanceRegistrar(
    Object^ instance,
    Type^ defaultService
)
Parameters
instance (Object)
The instance.
defaultService (Type)
The default service.


CreateActivator Method

CreateActivator Method
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► CreateActivator()()()
Creates the activator for the registration.
Declaration Syntax
C# Visual Basic Visual C++
protected override IActivator CreateActivator()
Protected Overrides Function CreateActivator As IActivator
protected:
virtual IActivator^ CreateActivator() override
Return Value
An activator.


DoConfigure Method (container)

DoConfigure Method (container)
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► DoConfigure(IContainer)
Resolves issue #7 - Provided instances not disposed unless they are resolved first. Manually attaches instance to container's disposer if Container ownership is chosen.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DoConfigure(
    IContainer container
)
Protected Overrides Sub DoConfigure ( _
    container As IContainer _
)
protected:
virtual void DoConfigure(
    IContainer^ container
) override
Parameters
container (IContainer)
The container.


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected override IConcreteRegistrar Syntax { get; }
Protected Overrides ReadOnly Property Syntax As IConcreteRegistrar
protected:
virtual property IConcreteRegistrar^ Syntax {
    IConcreteRegistrar^ get () override;
}
Value


WithScope Method (scope)

WithScope Method (scope)
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► WithScope(InstanceScope)
Change the scope associated with the registration. This determines how instances are tracked and shared.
Declaration Syntax
C# Visual Basic Visual C++
public override IConcreteRegistrar WithScope(
    InstanceScope scope
)
Public Overrides Function WithScope ( _
    scope As InstanceScope _
) As IConcreteRegistrar
public:
virtual IConcreteRegistrar^ WithScope(
    InstanceScope scope
) override
Parameters
scope (InstanceScope)
The scope model to use.
Return Value
A registrar allowing registration to continue.


Autofac.Registrars.Reflective Namespace

Autofac.Registrars.Reflective Namespace
Namespaces ► Autofac.Registrars.Reflective
Type-based registration support.
Declaration Syntax
C# Visual Basic Visual C++
namespace Autofac.Registrars.Reflective
Namespace Autofac.Registrars.Reflective
namespace Autofac.Registrars.Reflective
Types
All Types Classes
Icon | Type | Description
 | ReflectiveRegistrar | Register a component to be created through reflection.


ReflectiveRegistrar Class

ReflectiveRegistrar Class
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar
Register a component to be created through reflection.
Declaration Syntax
C# Visual Basic Visual C++
public class ReflectiveRegistrar : ConcreteRegistrar<IReflectiveRegistrar>,
    IReflectiveRegistrar, IConcreteRegistrar<IReflectiveRegistrar>, IRegistrar<IReflectiveRegistrar>,
    IFluentInterface
Public Class ReflectiveRegistrar _
    Inherits ConcreteRegistrar(Of IReflectiveRegistrar) _
    Implements IReflectiveRegistrar, IConcreteRegistrar(Of IReflectiveRegistrar),  _
    IRegistrar(Of IReflectiveRegistrar), IFluentInterface
public ref class ReflectiveRegistrar : public ConcreteRegistrar<IReflectiveRegistrar^>,
    IReflectiveRegistrar, IConcreteRegistrar<IReflectiveRegistrar^>, IRegistrar<IReflectiveRegistrar^>,
    IFluentInterface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReflectiveRegistrar(Type) | Initializes a new instance of the ReflectiveRegistrar class.
 | ActivatedHandlers | The handlers for the Activated event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ActivatingHandlers | The handlers for the Activating event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | AddService(Service) | Add a service to be exposed by the component. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | AddServices(IEnumerable<(Of <(Service>)>)) | Add many services to be exposed by the component. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Service>[]()[]) | Change the service associated with the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | As(array<Type>[]()[]) | Change the service associated with the registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Configure(IContainer) | Apply the module to the container. Subclasses should implement DoConfigure() rather than overriding this member. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ContainerScoped()()() | An instance will be created once per container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | CreateActivator()()() | Creates the activator for the registration. (Overrides ConcreteRegistrar <(Of <( IReflectiveRegistrar >)>).CreateActivator()()().)
 | DefaultOnly()()() | Filters the services exposed by the registration to include only those that are not already registered. I.e., will not override existing registrations. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | DoConfigure(IContainer) | Registers the component. If the component has not been assigned a name, explicit services or a factory delegate, then it will be registered as providing its own type as the default service. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedProperties | Gets the extended properties. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | ExternallyOwned()()() | The instance(s) will not be disposed when the container is disposed. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | FactoryScoped()()() | An instance will be created every time one is requested. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FireRegistered(RegisteredEventArgs) | Fires the registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | A unique service identifier that will be associated with the resulting registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | InContext<(Of <(T>)>)(T) | Sets the component to be resolvable only in contexts tagged with the provided tag. Implies that the component is container-scoped, however factory-scoped can be specified explicitly. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | MemberOf(String) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Type) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberOf(Service) | Adds the registration to a previously registered collection. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Named(String) | Setst the name of the registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | OnActivated(EventHandler<(Of <(ActivatedEventArgs>)>)) | Call the provided handler when an instance is activated. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnActivating(EventHandler<(Of <(ActivatingEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnlyIf(Predicate<(Of <(IContainer>)>)) | Applies the registration only if the supplied predicate is true at the time the container is built. If applied multiple times, predicates are composed with the 'and' operator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnPreparing(EventHandler<(Of <(PreparingEventArgs>)>)) | Call the provided handler when preparing to activate an instance. OnPreparing is the place to interrupt of modify the parameters to the activation process. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OnRegistered(EventHandler<(Of <(RegisteredEventArgs>)>)) | Call the provided handler when activating an instance. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | OwnedByContainer()()() | The instance(s) will be disposed with the container. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Ownership | The instance ownership used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | PreparingHandlers | The handlers for the Preparing event used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegisterComponent(IContainer, IComponentRegistration) | Sets up the registration with events, registers it in the container, and fires the Registered event. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | RegistrationCreator | Gets or sets the registration creator. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Scope | The instance scope used by this registration. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Services | The services exposed by this registration. (Inherited from ConcreteRegistrar<(Of <(TSyntax>)>).)
 | SingletonScoped()()() | Only one instance will ever be created. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | Syntax | Returns this instance, correctly-typed. (Overrides Registrar <(Of <( IReflectiveRegistrar >)>).Syntax.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UsingConstructor(array<Type>[]()[]) | Enforce that the specific constructor with the provided signature is used.
 | WithArguments(array<Parameter>[]()[]) | Associates constructor parameters with default values.
 | WithArguments(IEnumerable<(Of <(Parameter>)>)) | Associates constructor parameters with default values.
 | WithExtendedProperty(String, Object) | Associates an extended property with the registration. The property must not already exist. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithOwnership(InstanceOwnership) | Change the ownership model associated with the registration. This determines when the instances are disposed and by whom. (Inherited from Registrar<(Of <(TSyntax>)>).)
 | WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>)) | Provide explicit property values to be set on the new object.
 | WithProperties(array<NamedPropertyParameter>[]()[]) | Provide explicit property values to be set on the new object.
 | WithScope(InstanceScope) | Change the scope associated with the registration. This determines how instances are tracked and shared. (Inherited from Registrar<(Of <(TSyntax>)>).)
Inheritance Hierarchy
Object
 | Registrar <(Of <( IReflectiveRegistrar >)>)
 |  | ConcreteRegistrar <(Of <( IReflectiveRegistrar >)>)
 |  |  | ReflectiveRegistrar


ReflectiveRegistrar Constructor (implementor)

ReflectiveRegistrar Constructor (implementor)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► ReflectiveRegistrar(Type)
Initializes a new instance of the ReflectiveRegistrar class.
Declaration Syntax
C# Visual Basic Visual C++
public ReflectiveRegistrar(
    Type implementor
)
Public Sub New ( _
    implementor As Type _
)
public:
ReflectiveRegistrar(
    Type^ implementor
)
Parameters
implementor (Type)
The implementation type.


CreateActivator Method

CreateActivator Method
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► CreateActivator()()()
Creates the activator for the registration.
Declaration Syntax
C# Visual Basic Visual C++
protected override IActivator CreateActivator()
Protected Overrides Function CreateActivator As IActivator
protected:
virtual IActivator^ CreateActivator() override
Return Value
An activator.


Syntax Property

Syntax Property
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► Syntax
Returns this instance, correctly-typed.
Declaration Syntax
C# Visual Basic Visual C++
protected override IReflectiveRegistrar Syntax { get; }
Protected Overrides ReadOnly Property Syntax As IReflectiveRegistrar
protected:
virtual property IReflectiveRegistrar^ Syntax {
    IReflectiveRegistrar^ get () override;
}
Value


UsingConstructor Method (ctorSignature)

UsingConstructor Method (ctorSignature)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► UsingConstructor(array<Type>[]()[])
Enforce that the specific constructor with the provided signature is used.
Declaration Syntax
C# Visual Basic Visual C++
public IReflectiveRegistrar UsingConstructor(
    params Type[] ctorSignature
)
Public Function UsingConstructor ( _
    ParamArray ctorSignature As Type() _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ UsingConstructor(
    ... array<Type^>^ ctorSignature
) sealed
Parameters
ctorSignature (array< Type >[]()[])
The types that designate the constructor to use.
Return Value
A registrar allowing registration to continue.


WithArguments Method

WithArguments Method
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithArguments()()()
Members
Icon | Member | Description
 | WithArguments(array<Parameter>[]()[]) | Associates constructor parameters with default values.
 | WithArguments(IEnumerable<(Of <(Parameter>)>)) | Associates constructor parameters with default values.


WithArguments Method (additionalCtorArgs)

WithArguments Method (additionalCtorArgs)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithArguments(array<Parameter>[]()[])
Associates constructor parameters with default values.
Declaration Syntax
C# Visual Basic Visual C++
public IReflectiveRegistrar WithArguments(
    params Parameter[] additionalCtorArgs
)
Public Function WithArguments ( _
    ParamArray additionalCtorArgs As Parameter() _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ WithArguments(
    ... array<Parameter^>^ additionalCtorArgs
) sealed
Parameters
additionalCtorArgs (array< Parameter >[]()[])
The named values to apply to the constructor. These may be overriden by supplying any/all values to the IContext.Resolve() method.
Return Value
A registrar allowing registration to continue.


WithArguments Method (additionalCtorArgs)

WithArguments Method (additionalCtorArgs)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithArguments(IEnumerable<(Of <(Parameter>)>))
Associates constructor parameters with default values.
Declaration Syntax
C# Visual Basic Visual C++
public IReflectiveRegistrar WithArguments(
    IEnumerable<Parameter> additionalCtorArgs
)
Public Function WithArguments ( _
    additionalCtorArgs As IEnumerable(Of Parameter) _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ WithArguments(
    IEnumerable<Parameter^>^ additionalCtorArgs
) sealed
Parameters
additionalCtorArgs (IEnumerable <(Of <( Parameter >)>))
The named values to apply to the constructor. These may be overriden by supplying any/all values to the IContext.Resolve() method.
Return Value
A registrar allowing registration to continue.


WithProperties Method

WithProperties Method
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithProperties()()()
Members
Icon | Member | Description
 | WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>)) | Provide explicit property values to be set on the new object.
 | WithProperties(array<NamedPropertyParameter>[]()[]) | Provide explicit property values to be set on the new object.


WithProperties Method (explicitProperties)

WithProperties Method (explicitProperties)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithProperties(array<NamedPropertyParameter>[]()[])
Provide explicit property values to be set on the new object.
Declaration Syntax
C# Visual Basic Visual C++
public IReflectiveRegistrar WithProperties(
    params NamedPropertyParameter[] explicitProperties
)
Public Function WithProperties ( _
    ParamArray explicitProperties As NamedPropertyParameter() _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ WithProperties(
    ... array<NamedPropertyParameter^>^ explicitProperties
) sealed
Parameters
explicitProperties (array< NamedPropertyParameter >[]()[])

[Missing <param name="explicitProperties"/> documentation for "M:Autofac.Registrars.Reflective.ReflectiveRegistrar.WithProperties(Autofac.NamedPropertyParameter[])"]

Return Value
A registrar allowing configuration to continue.
Remarks
Note, supplying a null value will not prevent property injection if property injection is done through an OnActivating handler.


WithProperties Method (explicitProperties)

WithProperties Method (explicitProperties)
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► WithProperties(IEnumerable<(Of <(NamedPropertyParameter>)>))
Provide explicit property values to be set on the new object.
Declaration Syntax
C# Visual Basic Visual C++
public IReflectiveRegistrar WithProperties(
    IEnumerable<NamedPropertyParameter> explicitProperties
)
Public Function WithProperties ( _
    explicitProperties As IEnumerable(Of NamedPropertyParameter) _
) As IReflectiveRegistrar
public:
virtual IReflectiveRegistrar^ WithProperties(
    IEnumerable<NamedPropertyParameter^>^ explicitProperties
) sealed
Parameters
explicitProperties (IEnumerable <(Of <( NamedPropertyParameter >)>))

[Missing <param name="explicitProperties"/> documentation for "M:Autofac.Registrars.Reflective.ReflectiveRegistrar.WithProperties(System.Collections.Generic.IEnumerable{Autofac.NamedPropertyParameter})"]

Return Value

[Missing <returns> documentation for M:Autofac.Registrars.Reflective.ReflectiveRegistrar.WithProperties(System.Collections.Generic.IEnumerable{Autofac.NamedPropertyParameter})]

Remarks
Note, supplying a null value will not prevent property injection if property injection is done through an OnActivating handler.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► FileElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ServiceElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ComponentElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► ModuleElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Dispose Method

Dispose Method
Namespaces ► Autofac ► Container ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides Disposable.Dispose(Boolean).)
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► ComponentElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ExtendedPropertyElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► FileElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► ServiceElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ModuleElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


TryResolve Method

TryResolve Method
Namespaces ► Autofac ► IContainer ► TryResolve()()()
Members
Icon | Member | Description
 | TryResolve<(Of <(TService>)>)(TService%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | TryResolve<(Of <(TService>)>)(TService%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Type, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(String, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | TryResolve(Service, Object%, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► ModuleElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


As Method

As Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar<(Of <(TSyntax>)>) ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() |
 | As<(Of <(TService>)>)()()() |
 | As(array<Service>[]()[]) | Associate services with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► ServiceElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


ResolveOptional Method

ResolveOptional Method
Namespaces ► Autofac ► IContainer ► ResolveOptional()()()
Members
Icon | Member | Description
 | ResolveOptional<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | ResolveOptional<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► PropertyElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► SectionHandler ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► ComponentElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


As Method

As Method
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar ► As()()()
Members
Icon | Member | Description
 | As(array<Service>[]()[]) | Change the service associated with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


As Method

As Method
Namespaces ► Autofac.Registrars.Automatic ► AutomaticRegistrar ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


As Method

As Method
Namespaces ► Autofac.Registrars.Generic ► GenericRegistrar ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► ModuleElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


As Method

As Method
Namespaces ► Autofac.Registrars.ProvidedInstance ► ProvidedInstanceRegistrar ► As()()()
Members
Icon | Member | Description
 | As(array<Service>[]()[]) | Change the service associated with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars.Delegate ► DelegateRegistrar ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


Resolve Method

Resolve Method
Namespaces ► Autofac ► IContainer ► Resolve()()()
Members
Icon | Member | Description
 | Resolve<(Of <(TService>)>)(array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Type, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(String, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve(Service, array<Parameter>[]()[]) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve<(Of <(TService>)>)(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Type, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(String, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.
 | Resolve(Service, IEnumerable<(Of <(Parameter>)>)) | Retrieve a service registered with the container.


As Method

As Method
Namespaces ► Autofac.Registrars ► IConcreteRegistrar ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() |
 | As<(Of <(TService>)>)()()() |
 | As(array<Service>[]()[]) | Associate services with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


MemberOf Method

MemberOf Method
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► MemberOf()()()
Members
Icon | Member | Description
 | MemberOf(String) | Adds the registration to a previously registered collection.
 | MemberOf<(Of <(TService>)>)()()() | Adds the registration to a previously registered collection.
 | MemberOf(Type) | Adds the registration to a previously registered collection.
 | MemberOf(Service) | Adds the registration to a previously registered collection.


As Method

As Method
Namespaces ► Autofac.Registrars ► ConcreteRegistrar<(Of <(TSyntax>)>) ► As()()()
Members
Icon | Member | Description
 | As(array<Service>[]()[]) | Change the service associated with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ComponentElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► FileElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► ServiceElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


As Method

As Method
Namespaces ► Autofac.Registrars ► IGenericRegistrar ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() |
 | As<(Of <(TService>)>)()()() |
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ParameterElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► FileElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Dispose Method

Dispose Method
Namespaces ► Autofac.Component ► Registration ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


As Method

As Method
Namespaces ► Autofac.Registrars.Reflective ► ReflectiveRegistrar ► As()()()
Members
Icon | Member | Description
 | As(array<Service>[]()[]) | Change the service associated with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


As Method

As Method
Namespaces ► Autofac.Registrars ► IReflectiveRegistrar ► As()()()
Members
Icon | Member | Description
 | As<(Of <(TService>)>)()()() |
 | As<(Of <(TService>)>)()()() |
 | As(array<Service>[]()[]) | Associate services with the registration.
 | As<(Of <(TService>)>)()()() | Change the service associated with the registration. Change the service associated with the registration. Change the service associated with the registration.
 | As(array<Type>[]()[]) | Change the service associated with the registration.


BaseGet Method

BaseGet Method
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection ► BaseGet()()()
Members
Icon | Member | Description
 | BaseGet(Object) | Returns the configuration element with the specified key.
 | BaseGet(Int32) | Gets the configuration element at the specified index location.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ModuleElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► NamedConfigurationElementCollection<(Of <(TElementType>)>) ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ServiceElement ► Item
Members
Icon | Member | Description
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► ExtendedPropertyElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


Item Property

Item Property
Namespaces ► Autofac.Configuration ► ParameterElementCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the TElementType at the specified index.
 | Item[([(ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element.
 | Item[([(String])]) | Gets or sets a property, attribute, or child element of this configuration element.


IsRegistered Method

IsRegistered Method
Namespaces ► Autofac ► IContainer ► IsRegistered()()()
Members
Icon | Member | Description
 | IsRegistered(Type) | Determine whether or not a service has been registered.
 | IsRegistered(String) | Determine whether or not a service has been registered.
 | IsRegistered(Service) | Determine whether or not a service has been registered.
 | IsRegistered<(Of <(TService>)>)()()() | Determine whether or not a service has been registered.


BaseAdd Method

BaseAdd Method
Namespaces ► Autofac.Configuration ► FileElementCollection ► BaseAdd()()()
Members
Icon | Member | Description
 | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection.
 | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection.
 | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► PropertyElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.


CreateNewElement Method

CreateNewElement Method
Namespaces ► Autofac.Configuration ► ComponentElementCollection ► CreateNewElement()()()
Members
Icon | Member | Description
 | CreateNewElement()()() | Creates a new ConfigurationElement. (Overrides ConfigurationElementCollection.CreateNewElement()()().)
 | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class.